Modify

Opened 4 years ago

Closed 3 years ago

#14928 closed defect (invalid)

[packages] gpgme: configure: error: C compiler cannot create executables

Reported by: zloop Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

build fails on a VM running Debian 7

configure: WARNING: unrecognized options: --disable-nls, --without-pth
configure: loading site script /home/tenchi/prog/git/openwrt/include/site/i486-openwrt-linux-uclibc
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for i486-openwrt-linux-strip... i486-openwrt-linux-uclibc-strip
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i486-pc-linux-gnu
checking host system type... i486-openwrt-linux-gnu
checking for style of include used by make... GNU
checking for i486-openwrt-linux-gcc... i486-openwrt-linux-uclibc-gcc
checking whether the C compiler works... no
configure: error: in `/home/tenchi/prog/git/openwrt/build_dir/target-i386_i486_uClibc-0.9.33.2/gpgme-1.4.3':
configure: error: C compiler cannot create executables
See `config.log' for more details
make[3]: *** [/home/tenchi/prog/git/openwrt/build_dir/target-i386_i486_uClibc-0.9.33.2/gpgme-1.4.3/.configured_] Error 77

config.log to follow

Attachments (2)

config.log (18.4 KB) - added by zloop 4 years ago.
config.log from build dir of gpgme
diffconfig.txt (2.1 KB) - added by zloop 4 years ago.
output of diffconfig.sh

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by zloop

config.log from build dir of gpgme

Changed 4 years ago by zloop

output of diffconfig.sh

comment:1 Changed 3 years ago by anonymous

I have the same error. any solution?

comment:2 Changed 3 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

gpgme is unmaintained. no changes will be made to it until it is pushed to github and maintained.

comment:3 Changed 3 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

I understand that "gpgme is unmaintained". But I just want to make sure one thing: is this a problem of gpgme package alone?

I figured out how to compile it successfully: when I choose this package manually and compile it, it will show the errors as above. But when I choose all packages and compile the whole openwrt package repository, it will compile successfully.

So, is there a chance to find out the problem? dependencies?

comment:4 Changed 3 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Don't reopen tickets to enforce discussions. Use mailing lists, chat or the forum.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.