Modify

Opened 4 years ago

Closed 2 years ago

#14919 closed defect (fixed)

DFS channels are not listed by luci (even though DFS is supported)

Reported by: devel@… Owned by:
Priority: normal Milestone: Barrier Breaker 14.07
Component: luci Version: Trunk
Keywords: channels, dfs Cc:

Description

The current ath9k driver implements DFS and thus is allowed to use outdoor channels.

But sadly only the indoor channels (36, 40, 44 and 48) are available in the channel list. Outdoor channels can be chosen manually via their numeric value. This works if the patch from #14867 was applied before.

The cause of the problem seems to be the condition that filters the list of visible channels in the luci interface (see usr/lib/lua/luci/model/cbi/admin_network/wifi.lua):

       if not f.restricted then

The restricted flag is defined in source:openwrt/package/network/utils/iwinfo/src/iwinfo_nl80211.c line 2067:

   e->restricted = ( 
           freqs[NL80211_FREQUENCY_ATTR_PASSIVE_SCAN] ||
           freqs[NL80211_FREQUENCY_ATTR_NO_IBSS]      ||  
           freqs[NL80211_FREQUENCY_ATTR_RADAR]
   ) ? 1 : 0;

I am not sure if the definition of the restricted flag should be changed or if the filter condition needs to be improved.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:2 Changed 2 years ago by sumpfralle

This issue seems to be solved with Chaos Calmer.

Thank you!

comment:3 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.