Modify

Opened 4 years ago

Closed 4 years ago

#14867 closed defect (fixed)

Missing ieee80211h=1 in hostapd.conf hinders use of 5GHz outdoor channels

Reported by: tillw Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: DFS hostapd 802.11h doth Cc:

Description

In recent trunk all of ath9k, nl80211, and hostapd support the use of 5 GHz outdoor channels in Europe by implementing radar detection and DFS (802.11h protocol extensions.)

However, selecting a 5 GHz outdoor channel such as 112 fails:

Thu Jan  1 00:08:10 1970 daemon.notice netifd: radio0 (933): Configuration file: /var/run/hostapd-phy0.conf
Thu Jan  1 00:08:10 1970 daemon.notice netifd: radio0 (933): wlan0: IEEE 802.11 Configured channel (112) not found from the channel list of current mode (2) IEEE 802.11a
Thu Jan  1 00:08:10 1970 daemon.notice netifd: radio0 (933): wlan0: IEEE 802.11 Hardware does not support configured channel
Thu Jan  1 00:08:10 1970 daemon.notice netifd: radio0 (933): Could not select hw_mode and channel. (-3)
Thu Jan  1 00:08:10 1970 daemon.notice netifd: radio0 (933): wlan0: Unable to setup interface.

The above is caused by disabled use of 802.11h in hostapd. To enable 802.11h, the line

ieee80211h=1

must be included in hostapd.conf.

We attached a patch for netifd.sh (which ends up as /lib/netifd/hostapd.sh on our Nanostation). After applying the patch, the device-level attribute "doth" in /etc/config/wireless is used to control the generation of a "ieee80211h=1" line for hostapd.conf.

With the patch applied, channel 112 is finally usable.

root@OpenWrt:~# iw wlan0 info
Interface wlan0
        ifindex 10
        wdev 0x6
        addr dc:9f:db:xx:xx:xx
        ssid OpenWrt
        type AP
        wiphy 0
        channel 112 (5560 MHz), width: 20 MHz, center1: 5560 MHz

Attachments (1)

netifd.sh.patch (1.1 KB) - added by tillw 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by tillw

comment:1 Changed 4 years ago by anonymous

It looks like Matti Laakso is working on the same issue in parallel (see thread (PATCH v2) hostapd: enable DFS support) on the openwrt-devel mailing list.

comment:2 Changed 4 years ago by tim@…

I've attached an updated patch to #15620

comment:3 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

dfs support added in r40690

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.