Modify

Opened 4 years ago

Closed 4 years ago

#14863 closed defect (fixed)

Stateless mode in odhcp6c broken

Reported by: anonymous Owned by: cyrus
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: odhcp6c stateless Cc:

Description

Stateless mode support in odhcp6c seems to be broken in the recent snapshot (39382).
My ISP's router provides an IPv6 prefix (devices are SLAAC-configured) and dnsmasq-dhcp6 on another device provides DNS server information.
In 39294 is was working properly.

From /etc/config/network:

option proto 'dhcpv6'
option reqprefix 'no'
option reqaddress 'none'

In recent snapshot 39382 odhcp6c tries to get an address from the DHCPv6 server again and again. Of course this failes as the DHCPv6 server provides only DNS information.

Sun Jan 26 16:44:51 2014 daemon.notice odhcp6c[835]: (re)starting transaction on wlan0
Sun Jan 26 16:44:51 2014 daemon.notice odhcp6c[835]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Sun Jan 26 16:44:51 2014 daemon.notice odhcp6c[835]: Got a valid reply after 2ms
Sun Jan 26 16:44:52 2014 daemon.notice odhcp6c[835]: Starting REQUEST transaction (timeout 4294967295s, max rc 10)
Sun Jan 26 16:44:52 2014 daemon.notice odhcp6c[835]: Send REQUEST message (elapsed 0ms, rc 0)
Sun Jan 26 16:44:52 2014 daemon.notice odhcp6c[835]: Got a valid reply after 2ms
Sun Jan 26 16:44:52 2014 daemon.warn odhcp6c[835]: Server returned message status 2 (no addresses available)

In snapshot 39294 (on another device) it works as expected:

Sat Jan 25 22:47:00 2014 daemon.notice odhcp6c[9759]: Starting INFOREQ transaction (timeout 4294967295s, max rc 0)
Sat Jan 25 22:47:00 2014 daemon.notice odhcp6c[9759]: Send INFOREQ message (elapsed 0ms, rc 0)
Sat Jan 25 22:47:00 2014 daemon.notice odhcp6c[9759]: Got a valid reply after 2ms
Sat Jan 25 22:47:00 2014 daemon.notice odhcp6c[9759]: entering stateless-mode on br-lan
Sat Jan 25 22:47:00 2014 daemon.notice odhcp6c[9759]: Starting <POLL> transaction (timeout 259200s, max rc 0)

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 4 years ago by anonymous

Just verified it: Replaced /usr/sbin/odhcp6c with the previous version and it works again as expected.

comment:2 in reply to: ↑ 1 Changed 4 years ago by another

Replying to anonymous:

Just verified it: Replaced /usr/sbin/odhcp6c with the previous version and it works again as expected.

And with the "previous version" you mean 39294? It that was ok, then the bug has surfaced between the Dec 15 version and current one:
https://dev.openwrt.org/changeset?new=39311@trunk%2Fpackage%2Fnetwork%2Fipv6%2Fodhcp6c&old=39294@trunk%2Fpackage%2Fnetwork%2Fipv6%2Fodhcp6c

However, in the odhcp6c repository that Dec15 version's changeset be05c0ded0257cbb82857f6d01226ef6de28befe is from November 11th, so a bit longer period to look for the reason.
https://github.com/sbyx/odhcp6c/commits/master

comment:3 Changed 4 years ago by anonymous

"And with the "previous version" you mean 39294?"
Exactly ..

comment:4 Changed 4 years ago by cyrus

  • Owner changed from developers to cyrus
  • Status changed from new to accepted

Bug confirmed. Fix is in the queue. Will push it later this week.

comment:5 Changed 4 years ago by cyrus

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in r39433

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.