Modify

Opened 4 years ago

Last modified 4 years ago

#14861 new defect

2 x tun devices swapping ips after reboot

Reported by: rizla3066 Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

I have 2 servers set in /etc/config/openvpn. Both have the server ips set in the openvpn config. Both adapters are set to 'unmanaged' in network interface.

When they start tun0 should have ip of 10.10.10.0 and tun1 an ip of 10.8.0.0

When i go to interfaces tab in luci i can see that tun0 and tun1 have the correct ip addresses that have been set in openvpn config. This is also the same so ifconfig.

After a reboot, maybe 10 reboots or just 1 the ip addresses will swap between the two adapters, so tun0 will have ip 10.8.0.0 and tun1 will have 10.10.10.0.

However on my client i am allocated the correct ip address for what the adapter should be.

When i do '/etc/init.d/openvpn reload' the ips are corrected untill next reboot.

Pictures speak a thousand words so here we go
How it should be
https://drive.google.com/file/d/0B6krP4a3ZvukcnhMOHBLcTNlQ1k/edit?usp=sharing
https://drive.google.com/file/d/0B6krP4a3ZvukN1pmb1dNUnpka2M/edit?usp=sharing

How it is after a reboot
https://drive.google.com/file/d/0B6krP4a3ZvukMkxNaWZHVF9KOGs/edit?usp=sharing
https://drive.google.com/file/d/0B6krP4a3ZvukWUYydTJNbmVFejg/edit?usp=sharing

Forgot to mention this happens on AttitadeAdjustment and BarrierBreak. My router model is wndr3800 (ar71xx)

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Vladimir Ulrich <wedmer@…>

In vpn config try to change dev option from "tun" to "tun0" and "tun1"

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.