Modify

Opened 4 years ago

Closed 3 years ago

#14859 closed defect (moved_to_github)

Unable to open Asterisk database

Reported by: shermanrand@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09
Keywords: Asterisk astdb Cc:

Description

Have installed Attitude Adjustment and Asterisk18 which runs (peers) only under -gvvc and get the following error -

db.c:115 dbinit: Unable to open Asterisk database '/var/lib/asterisk/astdb': No such file or directory

Believe it has something to do with my init.d asterisk - which is below. - Please advise -

#!/bin/sh /etc/rc.common

# Copyright (C) 2008 OpenWrt.org
START=50

DEST=
DEFAULT=$DEST/etc/default/asterisk
OPTIONS=""

start() {

[ -f $DEFAULT ] && . $DEFAULT

[ -d $DEST/var/run/asterisk ] [ -d $DEST/var/log/asterisk ] [ -d $DEST/var/spool/asterisk ] [ -d /var/spool/asterisk ] [ -h $DEST/usr/lib/asterisk/astdb ]
mkdir -p $DEST/var/run/asterisk
mkdir -p $DEST/var/log/asterisk
mkdir -p $DEST/var/spool/asterisk
mkdir -p /var/spool/asterisk
ln -sf /var/spool/asterisk/astdb $DEST/usr/lib/asterisk/astdb

$DEST/usr/sbin/asterisk $OPTIONS

}

stop() {

[ -f $DEST/var/run/asterisk/asterisk.pid ] && kill $(cat $DEST/var/run/asterisk/asterisk.pid) >/dev/null 2>&1

}

Attachments (1)

asteriskinitd.txt (868 bytes) - added by shermanrand@… 4 years ago.
initd with correct format

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by shermanrand@…

initd with correct format

comment:1 Changed 4 years ago by anonymous

The init.d did not post in the wiki ticket correctly since it has
in it's format.

Please see attachment for actual init.d for asterisk18.

comment:2 Changed 4 years ago by anonymous

Same problem and solved with this:
https://dev.openwrt.org/ticket/9618#comment:3

comment:3 Changed 4 years ago by anonymous

Sorry I forgot ... Asterisk 11

comment:4 Changed 4 years ago by slachta

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9618.

comment:5 Changed 4 years ago by slachta

Current trunk should have this issue fixed. Not by changing asterisk.conf directories section template to generic section, but in init script.

comment:6 Changed 4 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Please check the trunk version (asterisk 11) because error is still present and the only way is remove (!) from directories (asterisk.conf)

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:8 Changed 3 years ago by jogo

  • Resolution set to moved_to_github
  • Status changed from reopened to closed

Asterisk is now maintained here: https://github.com/openwrt/telephony.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.