Modify

Opened 4 years ago

Closed 3 years ago

#14781 closed defect (fixed)

No SSID broadcast after r38914 when using STA and AP simultaneously on the same interface

Reported by: nunojpg Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

I'm using the following config on a WRT160NL:

root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

option ula_prefix 'fdae:7edb:7091::/48'

config interface 'lan'

option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.5.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'

option proto 'dhcp'
list dns 8.8.4.4
list dns 8.8.8.8


config interface 'wan6'

option ifname '@wan'
option proto 'dhcpv6'

config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4 5'

root@OpenWrt:/# cat /etc/config/wireless
config wifi-device radio0

option type mac80211
option channel 11
option hwmode 11ng
option path 'platform/ath9k'
option htmode HT20
list ht_capab SHORT-GI-40
list ht_capab DSSS_CCK-40

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none

config wifi-iface

option device radio0
option network wan
option mode sta
option ssid AAAAAAAAAAAA
option encryption psk
option key BBBBBBBBBBBB

The router gets connectivity fine trough the WiFi STA, but the AP SSID does not appear.

root@OpenWrt:/# iw dev wlan0 info
Interface wlan0

ifindex 6
wdev 0x2
addr 00:03:7f:bf:1e:7e
type managed
wiphy 0
channel 1 (2412 MHz), width: 20 MHz (no HT), center1: 2412 MHz

root@OpenWrt:/# iw dev wlan0-1 info
Interface wlan0-1

ifindex 7
wdev 0x3
addr 02:03:7f:bf:1e:7e
type AP
wiphy 0

root@OpenWrt:/# ubus call network device status
Failed to parse message data

root@OpenWrt:/# logread
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.090000] NET: Registered protocol family 16
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.100000] MIPS: machine is Linksys WRT160NL
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 0.130000] ar71xx: using random MAC address for eth0
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 0.330000] ar71xx: using random MAC address for eth1
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.610000] bio: create slab <bio-0> at 0
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.620000] Switching to clocksource MIPS
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.630000] NET: Registered protocol family 2
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.630000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.630000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.640000] TCP: Hash tables configured (established 512 bind 512)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.640000] TCP: reno registered
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.650000] UDP hash table entries: 256 (order: 0, 4096 bytes)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.650000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.660000] NET: Registered protocol family 1
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 0.660000] PCI: CLS 0 bytes, default 32
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.680000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.690000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.700000] msgmni has been set to 56
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.700000] io scheduler noop registered
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.700000] io scheduler deadline registered (default)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.710000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.740000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.740000] console [ttyS0] enabled, bootconsole disabled
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.760000] ath79-spi ath79-spi: master is unqueued, this is deprecated
Thu Jan 1 00:00:11 1970 kern.warn kernel: [ 0.770000] m25p80 spi0.0: found mx25l6405d, expected m25p80
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.770000] m25p80 spi0.0: mx25l6405d (8192 Kbytes)
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.780000] 6 wrt160nl partitions found on MTD device spi0.0
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.780000] Creating 6 MTD partitions on "spi0.0":
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.790000] 0x000000000000-0x000000040000 : "u-boot"
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.790000] 0x000000040000-0x000000140000 : "kernel"
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.800000] 0x000000140000-0x0000007e0000 : "rootfs"
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.810000] mtd: device 2 (rootfs) set to be root filesystem
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.810000] 1 squashfs-split partitions found on MTD device rootfs
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.820000] 0x000000300000-0x0000007e0000 : "rootfs_data"
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.830000] 0x0000007e0000-0x0000007f0000 : "nvram"
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.830000] 0x0000007f0000-0x000000800000 : "art"
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 0.840000] 0x000000040000-0x0000007e0000 : "firmware"
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 0.860000] libphy: ag71xx_mdio: probed
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.170000] Registering RTL8306SD switch with Chip ID: 0x5988, version: 0x0000
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.180000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=00008306, driver=Realtek RTL8306S]
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.190000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RMII
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.500000] ag71xx ag71xx.1: connected to PHY at ag71xx-mdio.0:04 [uid=00008306, driver=Realtek RTL8306S]
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.510000] eth1: Atheros AG71xx at 0xba000000, irq 5, mode:RMII
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.520000] TCP: cubic registered
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.520000] NET: Registered protocol family 17
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.520000] 8021q: 802.1Q VLAN Support v1.8
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.530000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 1.540000] Freeing unused kernel memory: 276K (8031b000 - 80360000)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.020000] usbcore: registered new interface driver usbfs
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.030000] usbcore: registered new interface driver hub
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.030000] usbcore: registered new device driver usb
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.040000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.050000] ehci-platform: EHCI generic platform driver
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.060000] ehci-platform ehci-platform: EHCI Host Controller
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.060000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.070000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.100000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.100000] hub 1-0:1.0: USB hub found
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 5.110000] hub 1-0:1.0: 1 port detected
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 6.230000] ar71xx: pll_reg 0xb8050014: 0x13000a44
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 6.230000] eth0: link up (100Mbps/Full duplex)
Thu Jan 1 00:00:11 1970 kern.notice kernel: [ 8.160000] jffs2: notice: (315) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 13 of xref (0 dead, 2 orphan) found.
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 8.190000] eth0: link down
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.250000] NET: Registered protocol family 10
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.270000] nf_conntrack version 0.5.0 (454 buckets, 1816 max)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.280000] ip6_tables: (C) 2000-2006 Netfilter Core Team
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.310000] Loading modules backported from Linux version master-2013-11-05-0-gafa3093
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.310000] Backport generated by backports.git backports-20130802-0-gdb67a3f
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.320000] ip_tables: (C) 2000-2006 Netfilter Core Team
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.370000] xt_time: kernel timezone is -0000
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.400000] cfg80211: Calling CRDA to update world regulatory domain
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.400000] cfg80211: World regulatory domain updated:
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.410000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.420000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.420000] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.430000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.440000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (300 mBi, 2000 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.450000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (300 mBi, 2000 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.460000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.510000] PPP generic driver version 2.4.2
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.530000] NET: Registered protocol family 24
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 9.610000] ath: EEPROM regdomain: 0x0
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 9.610000] ath: EEPROM indicates default country code should be used
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 9.610000] ath: doing EEPROM country->regdmn map search
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 9.610000] ath: country maps to regdmn code: 0x3a
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 9.610000] ath: Country alpha2 being used: US
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 9.610000] ath: Regpair used: 0x3a
Thu Jan 1 00:00:11 1970 kern.debug kernel: [ 9.630000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.640000] ieee80211 phy0: Atheros AR9100 MAC/BB Rev:7 AR2122 RF Rev:a2 mem=0xb80c0000, irq=2
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.660000] cfg80211: Calling CRDA for country: US
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.680000] cfg80211: Regulatory domain changed to country: US
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.680000] cfg80211: DFS Master region FCC
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.690000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.690000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.700000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (300 mBi, 1700 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.710000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (300 mBi, 2400 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.720000] cfg80211: (5490000 KHz - 5600000 KHz @ 80000 KHz), (300 mBi, 2400 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.720000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2400 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.730000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (300 mBi, 3000 mBm)
Thu Jan 1 00:00:11 1970 kern.info kernel: [ 9.740000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Thu Jan 1 00:00:13 1970 authpriv.info dropbear[568]: Not backgrounding
Thu Jan 1 00:00:14 1970 user.emerg syslog: setting up led WLAN
Thu Jan 1 00:00:14 1970 user.emerg syslog: - init complete -
Thu Jan 1 00:00:15 1970 kern.info kernel: [ 15.560000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Thu Jan 1 00:00:15 1970 kern.info kernel: [ 15.560000] device eth0 entered promiscuous mode
Thu Jan 1 00:00:15 1970 kern.info kernel: [ 15.570000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
Thu Jan 1 00:00:15 1970 daemon.notice netifd: Interface 'lan' is now up
Thu Jan 1 00:00:15 1970 daemon.notice netifd: Interface 'loopback' is now up
Thu Jan 1 00:00:15 1970 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Thu Jan 1 00:00:17 1970 kern.debug kernel: [ 17.360000] ar71xx: pll_reg 0xb8050014: 0x13000a44
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.360000] eth0: link up (100Mbps/Full duplex)
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.360000] br-lan: port 1(eth0) entered forwarding state
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.370000] br-lan: port 1(eth0) entered forwarding state
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.370000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.390000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.440000] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.480000] device wlan0-1 entered promiscuous mode
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.480000] br-lan: port 2(wlan0-1) entered forwarding state
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.490000] br-lan: port 2(wlan0-1) entered forwarding state
Thu Jan 1 00:00:17 1970 kern.info kernel: [ 17.730000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Thu Jan 1 00:00:18 1970 kern.info kernel: [ 18.360000] br-lan: port 2(wlan0-1) entered disabled state
Thu Jan 1 00:00:18 1970 daemon.notice netifd: wan (816): udhcpc (v1.19.4) started
Thu Jan 1 00:00:18 1970 daemon.notice netifd: wan (816): Sending discover...
Thu Jan 1 00:00:18 1970 kern.info kernel: [ 18.970000] wlan0: authenticate with 00:24:17:69:8d:64
Thu Jan 1 00:00:18 1970 kern.info kernel: [ 18.980000] wlan0: send auth to 00:24:17:69:8d:64 (try 1/3)
Thu Jan 1 00:00:18 1970 kern.info kernel: [ 18.980000] wlan0: authenticated
Thu Jan 1 00:00:19 1970 kern.info kernel: [ 18.990000] ath9k ath9k wlan0: disabling HT/VHT due to WEP/TKIP use
Thu Jan 1 00:00:19 1970 kern.info kernel: [ 19.000000] wlan0: associate with 00:24:17:69:8d:64 (try 1/3)
Thu Jan 1 00:00:19 1970 kern.info kernel: [ 19.000000] wlan0: RX AssocResp from 00:24:17:69:8d:64 (capab=0x411 status=0 aid=1)
Thu Jan 1 00:00:19 1970 kern.info kernel: [ 19.010000] wlan0: associated
Thu Jan 1 00:00:19 1970 kern.info kernel: [ 19.020000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Thu Jan 1 00:00:19 1970 kern.info kernel: [ 19.370000] br-lan: port 1(eth0) entered forwarding state
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq[834]: started, version 2.66 cachesize 150
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq[834]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq-dhcp[834]: DHCP, IP range 192.168.5.100 -- 192.168.5.249, lease time 12h
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq[834]: using local addresses only for domain lan
Thu Jan 1 00:00:21 1970 daemon.warn dnsmasq[834]: no servers found in /tmp/resolv.conf.auto, will retry
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq[834]: read /etc/hosts - 1 addresses
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq-dhcp[834]: read /etc/ethers - 0 addresses
Thu Jan 1 00:00:21 1970 daemon.notice netifd: wan (816): Sending discover...
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq[834]: read /etc/hosts - 1 addresses
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq[834]: read /tmp/hosts/6relayd - 0 addresses
Thu Jan 1 00:00:21 1970 daemon.info dnsmasq-dhcp[834]: read /etc/ethers - 0 addresses
Thu Jan 1 00:00:24 1970 daemon.notice netifd: wan (816): Sending discover...
Thu Jan 1 00:00:24 1970 daemon.notice netifd: wan (816): Sending select for 192.168.1.100...
Thu Jan 1 00:00:24 1970 daemon.notice netifd: wan (816): Lease of 192.168.1.100 obtained, lease time 3600
Thu Jan 1 00:00:24 1970 daemon.notice netifd: Interface 'wan' is now up
Thu Jan 1 00:00:24 1970 daemon.notice odhcp6c[921]: (re)starting transaction on wlan0
Thu Jan 1 00:00:24 1970 daemon.notice odhcp6c[921]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Thu Jan 1 00:00:25 1970 user.notice firewall: Reloading firewall due to ifup of wan (wlan0)
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[834]: reading /tmp/resolv.conf.auto
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[834]: using nameserver 192.168.1.254#53
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[834]: using nameserver 192.168.1.254#53
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[834]: using nameserver 8.8.8.8#53
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[834]: using nameserver 8.8.4.4#53
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[834]: using local addresses only for domain lan
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[834]: exiting on receipt of SIGTERM
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: started, version 2.66 cachesize 150
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq-dhcp[978]: DHCP, IP range 192.168.5.100 -- 192.168.5.249, lease time 12h
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: using local addresses only for domain lan
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: reading /tmp/resolv.conf.auto
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: using nameserver 192.168.1.254#53
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: using nameserver 192.168.1.254#53
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: using nameserver 8.8.8.8#53
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: using nameserver 8.8.4.4#53
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: using local addresses only for domain lan
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: read /etc/hosts - 1 addresses
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq[978]: read /tmp/hosts/6relayd - 0 addresses
Thu Jan 1 00:00:26 1970 daemon.info dnsmasq-dhcp[978]: read /etc/ethers - 0 addresses
Thu Jan 16 14:11:06 2014 daemon.notice netifd: Interface 'wan6' is now up
Thu Jan 16 14:11:06 2014 user.notice firewall: Reloading firewall due to ifup of wan6 (wlan0)
Thu Jan 16 14:11:07 2014 daemon.warn 6relayd[848]: Termination requested by signal.
Thu Jan 16 14:11:08 2014 daemon.info dnsmasq[978]: read /etc/hosts - 1 addresses
Thu Jan 16 14:11:08 2014 daemon.info dnsmasq[978]: read /tmp/hosts/6relayd - 0 addresses
Thu Jan 16 14:11:08 2014 daemon.info dnsmasq-dhcp[978]: read /etc/ethers - 0 addresses
Thu Jan 16 14:11:08 2014 user.notice firewall: Reloading firewall due to ifup of wan6 ()
Thu Jan 16 14:19:57 2014 user.notice firewall: Reloading firewall due to ifup of wan6 ()
Thu Jan 16 14:23:17 2014 user.notice firewall: Reloading firewall due to ifup of wan6 ()
Thu Jan 16 14:32:29 2014 user.notice firewall: Reloading firewall due to ifup of wan6 ()
Thu Jan 16 14:39:25 2014 user.notice firewall: Reloading firewall due to ifup of wan6 ()
Thu Jan 16 14:40:55 2014 daemon.notice netifd: wan (816): Sending renew...
Thu Jan 16 14:40:55 2014 daemon.notice netifd: wan (816): Lease of 192.168.1.100 obtained, lease time 3600
Thu Jan 16 14:40:56 2014 user.notice firewall: Reloading firewall due to ifup of wan ()
Thu Jan 16 14:46:54 2014 user.notice firewall: Reloading firewall due to ifup of wan6 ()

root@OpenWrt:/# ifconfig
br-lan Link encap:Ethernet HWaddr BA:35:64:B6:15:B6

inet addr:192.168.5.1 Bcast:192.168.5.255 Mask:255.255.255.0
inet6 addr: fe80::b835:64ff:feb6:15b6/64 Scope:Link
inet6 addr: fdae:7edb:7091::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:2306 (2.2 KiB)

eth0 Link encap:Ethernet HWaddr BA:35:64:B6:15:B6

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:2306 (2.2 KiB)
Interrupt:4

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1352 (1.3 KiB) TX bytes:1352 (1.3 KiB)

wlan0 Link encap:Ethernet HWaddr 00:03:7F:BF:1E:7E

inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::203:7fff:febf:1e7e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:591 errors:0 dropped:0 overruns:0 frame:0
TX packets:503 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:42303 (41.3 KiB) TX bytes:337570 (329.6 KiB)

wlan0-1 Link encap:Ethernet HWaddr 02:03:7F:BF:1E:7E

UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@OpenWrt:/# cat /etc/openwrt_version
r39295

Attachments (0)

Change History (12)

comment:1 Changed 4 years ago by nunojpg

  • Component changed from packages to base system
  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker (trunk)

comment:2 Changed 4 years ago by nunojpg

I can provide remote access to this router.

comment:3 follow-up: Changed 4 years ago by jow

Try swapping the order of sta and ap please.

comment:4 in reply to: ↑ 3 Changed 4 years ago by nunojpg

Replying to jow:

Try swapping the order of sta and ap please.

Issue remains.

comment:5 Changed 4 years ago by nunojpg

Tested now with r39412 and I found the same issue.

comment:6 Changed 4 years ago by nbd

please try r39426 or newer

comment:7 Changed 4 years ago by nunojpg

  • Resolution set to fixed
  • Status changed from new to closed

r39455 looks to be working perfectly.

comment:8 Changed 3 years ago by mailgpa@…

Similar issue on TP-Link Archer C5 V1 / r43797 (as well as TP-Link Archer C7 V2 / r43819)

The router gets connectivity fine trough the WiFi STA, but the AP SSID does not appear.

Please find info from Archer C5 below

# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbe:518a:458d::/48'

config interface 'lan'
	option ifname 'eth1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'lte'
	option proto 'ncm'
	option ifname 'wwan0'
	option pincode '1154'
	option authtype 'none'
	option delay '5'
	option device '/dev/ttyUSB0'
	option mode 'lte'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 3 4 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6'
# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/qca955x_wmac'
	option noscan '1'
	option hwmode '11g'
	option htmode 'HT40'
	option channel '4'
	option country '00'
	option distance '15'
	option txpower '21'

config wifi-iface
	option encryption 'psk2'
	option device 'radio0'
	option key 'xxx'
	option ssid 'ramanet_24'
	option mode 'ap'
	option network 'lan'
	option wds '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'pci0000:01/0000:01:00.0'
	option htmode 'VHT80'
	option hwmode '11a'
	option country 'BG'
	option channel '48'
	option txpower '17'
	option log_level '0'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'ramanet'
	option key 'xxx'
	option encryption 'psk2'
	option wds '1'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'sta'
	option ssid 'ramanet_link'
	option bssid 'EA:94:F6:C7:CD:76'
	option key 'xxx'
	option encryption 'psk2'
	option wds '1'
# iw dev wlan0 info
Interface wlan0
	ifindex 32
	wdev 0x16
	addr 14:cc:20:46:a9:0c
	type managed
	wiphy 0
	channel 48 (5240 MHz), width: 80 MHz, center1: 5210 MHz
# iw dev wlan0-1 info
Interface wlan0-1
	ifindex 33
	wdev 0x17
	addr 16:cc:20:46:a9:0c
	type AP
	wiphy 0
# cat /proc/net/dev
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
    lo:   33934     432    0    0    0     0          0         0    33934     432    0    0    0     0       0          0
 wwan0: 16460868   26873    0    0    0     0          0         0 108152954   33979    0    0    0     0       0          0
 wlan1:  708617    3533    0    0    0     0          0         0  1237221    3046    0    0    0     0       0          0
  eth1:       0       0    0    0    0     0          0         0   306487     923    0    0    0     0       0          0
wlan0-1:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
 wlan0:  418839    2156    0    0    0     0          0         0   569288    1321    0    0    0     0       0          0
  eth0:       0       0    0    0    0     0          0         0   241012     722    0    0    0     0       0          0
br-lan: 566240503  413003    0    0    0     0          0         0 20393958   68813    0    0    0     0       0          0

# ubus call network.device status
{
	"br-lan": {
		"external": false,
		"present": true,
		"type": "Bridge",
		"up": true,
		"carrier": true,
		"bridge-members": [
			"eth1",
			"wlan0",
			"wlan0-1",
			"wlan1"
		],
		"macaddr": "14:cc:20:46:a9:0e",
		"statistics": {
			"collisions": 0,
			"rx_frame_errors": 0,
			"tx_compressed": 0,
			"multicast": 0,
			"rx_length_errors": 0,
			"tx_dropped": 0,
			"rx_bytes": 566512356,
			"rx_missed_errors": 0,
			"tx_errors": 0,
			"rx_compressed": 0,
			"rx_over_errors": 0,
			"tx_fifo_errors": 0,
			"rx_crc_errors": 0,
			"rx_packets": 415663,
			"tx_heartbeat_errors": 0,
			"rx_dropped": 0,
			"tx_aborted_errors": 0,
			"tx_packets": 70550,
			"rx_errors": 0,
			"tx_bytes": 20744726,
			"tx_window_errors": 0,
			"rx_fifo_errors": 0,
			"tx_carrier_errors": 0
		}
	},
	"eth0": {
		"external": false,
		"present": true,
		"type": "Network device",
		"up": true,
		"carrier": true,
		"link-advertising": [
			"1000F"
		],
		"link-supported": [
			"1000F"
		],
		"speed": "1000F",
		"statistics": {
			"collisions": 0,
			"rx_frame_errors": 0,
			"tx_compressed": 0,
			"multicast": 0,
				"rx_length_errors": 0,
			"tx_dropped": 0,
			"rx_bytes": 0,
			"rx_missed_errors": 0,
			"tx_errors": 0,
			"rx_compressed": 0,
			"rx_over_errors": 0,
			"tx_fifo_errors": 0,
			"rx_crc_errors": 0,
			"rx_packets": 0,
			"tx_heartbeat_errors": 0,
			"rx_dropped": 0,
			"tx_aborted_errors": 0,
			"tx_packets": 752,
			"rx_errors": 0,
			"tx_bytes": 251272,
			"tx_window_errors": 0,
			"rx_fifo_errors": 0,
			"tx_carrier_errors": 0
		}
	},
	"eth1": {
		"external": false,
		"present": true,
		"type": "Network device",
		"up": true,
		"carrier": true,
		"ipv6": false,
		"statistics": {
			"collisions": 0,
			"rx_frame_errors": 0,
			"tx_compressed": 0,
			"multicast": 0,
			"rx_length_errors": 0,
			"tx_dropped": 0,
			"rx_bytes": 0,
			"rx_missed_errors": 0,
			"tx_errors": 0,
			"rx_compressed": 0,
			"rx_over_errors": 0,
			"tx_fifo_errors": 0,
			"rx_crc_errors": 0,
			"rx_packets": 0,
			"tx_heartbeat_errors": 0,
			"rx_dropped": 0,
			"tx_aborted_errors": 0,
			"tx_packets": 926,
			"rx_errors": 0,
			"tx_bytes": 306981,
			"tx_window_errors": 0,
			"rx_fifo_errors": 0,
			"tx_carrier_errors": 0
		}
	},
	"lo": {
		"external": false,
		"present": true,
		"type": "Network device",
		"up": true,
		"carrier": true,
		"statistics": {
			"collisions": 0,
			"rx_frame_errors": 0,
			"tx_compressed": 0,
			"multicast": 0,
			"rx_length_errors": 0,
			"tx_dropped": 0,
			"rx_bytes": 39726,
			"rx_missed_errors": 0,
			"tx_errors": 0,
			"rx_compressed": 0,
			"rx_over_errors": 0,
			"tx_fifo_errors": 0,
			"rx_crc_errors": 0,
			"rx_packets": 512,
			"tx_heartbeat_errors": 0,
			"rx_dropped": 0,
			"tx_aborted_errors": 0,
			"tx_packets": 512,
			"rx_errors": 0,
			"tx_bytes": 39726,
			"tx_window_errors": 0,
			"rx_fifo_errors": 0,
			"tx_carrier_errors": 0
		}
	},
	"wlan0": {
		"external": true,
		"present": true,
		"type": "Network device",
		"up": true,
		"carrier": true,
		"ipv6": false,
		"statistics": {
			"collisions": 0,
			"rx_frame_errors": 0,
			"tx_compressed": 0,
			"multicast": 0,
			"rx_length_errors": 0,
			"tx_dropped": 0,
			"rx_bytes": 550960,
			"rx_missed_errors": 0,
			"tx_errors": 0,
			"rx_compressed": 0,
			"rx_over_errors": 0,
			"tx_fifo_errors": 0,
			"rx_crc_errors": 0,
			"rx_packets": 3045,
			"tx_heartbeat_errors": 0,
			"rx_dropped": 0,
			"tx_aborted_errors": 0,
			"tx_packets": 1737,
			"rx_errors": 0,
			"tx_bytes": 699898,
			"tx_window_errors": 0,
			"rx_fifo_errors": 0,
			"tx_carrier_errors": 0
		}
	},
	"wlan0-1": {
		"external": true,
		"present": true,
		"type": "Network device",
		"up": true,
		"carrier": false,
		"ipv6": false,
		"statistics": {
			"collisions": 0,
			"rx_frame_errors": 0,
			"tx_compressed": 0,
			"multicast": 0,
			"rx_length_errors": 0,
			"tx_dropped": 0,
			"rx_bytes": 0,
			"rx_missed_errors": 0,
			"tx_errors": 0,
			"rx_compressed": 0,
			"rx_over_errors": 0,
			"tx_fifo_errors": 0,
			"rx_crc_errors": 0,
			"rx_packets": 0,
			"tx_heartbeat_errors": 0,
			"rx_dropped": 0,
			"tx_aborted_errors": 0,
			"tx_packets": 0,
			"rx_errors": 0,
			"tx_bytes": 0,
			"tx_window_errors": 0,
			"rx_fifo_errors": 0,
			"tx_carrier_errors": 0
		}
	},
	"wlan1": {
		"external": true,
		"present": true,
		"type": "Network device",
		"up": true,
		"carrier": true,
		"ipv6": false,
		"statistics": {
			"collisions": 0,
			"rx_frame_errors": 0,
			"tx_compressed": 0,
			"multicast": 0,
			"rx_length_errors": 0,
			"tx_dropped": 0,
			"rx_bytes": 886105,
			"rx_missed_errors": 0,
			"tx_errors": 0,
			"rx_compressed": 0,
			"rx_over_errors": 0,
			"tx_fifo_errors": 0,
			"rx_crc_errors": 0,
			"rx_packets": 5309,
			"tx_heartbeat_errors": 0,
			"rx_dropped": 0,
			"tx_aborted_errors": 0,
			"tx_packets": 4376,
			"rx_errors": 0,
			"tx_bytes": 1496247,
			"tx_window_errors": 0,
			"rx_fifo_errors": 0,
			"tx_carrier_errors": 0
		}
	},
	"wwan0": {
		"external": false,
		"present": true,
		"type": "Network device",
		"up": true,
		"carrier": true,
		"statistics": {
			"collisions": 0,
			"rx_frame_errors": 0,
			"tx_compressed": 0,
			"multicast": 0,
			"rx_length_errors": 0,
			"tx_dropped": 0,
			"rx_bytes": 16704570,
			"rx_missed_errors": 0,
			"tx_errors": 0,
			"rx_compressed": 0,
			"rx_over_errors": 0,
			"tx_fifo_errors": 0,
			"rx_crc_errors": 0,
			"rx_packets": 28238,
			"tx_heartbeat_errors": 0,
			"rx_dropped": 0,
			"tx_aborted_errors": 0,
			"tx_packets": 36284,
			"rx_errors": 0,
			"tx_bytes": 113287858,
			"tx_window_errors": 0,
			"rx_fifo_errors": 0,
			"tx_carrier_errors": 0
		}
	}
}
# ifconfig
br-lan    Link encap:Ethernet  HWaddr 14:CC:20:46:A9:0E  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdbe:518a:458d::1/60 Scope:Global
          inet6 addr: fe80::16cc:20ff:fe46:a90e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:417045 errors:0 dropped:0 overruns:0 frame:0
          TX packets:71333 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:566694936 (540.4 MiB)  TX bytes:21016032 (20.0 MiB)

eth0      Link encap:Ethernet  HWaddr 14:CC:20:46:A9:0F  
          inet6 addr: fe80::16cc:20ff:fe46:a90f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:776 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:259334 (253.2 KiB)
          Interrupt:4 

eth1      Link encap:Ethernet  HWaddr 14:CC:20:46:A9:0E  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:929 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:307159 (299.9 KiB)
          Interrupt:5 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:560 errors:0 dropped:0 overruns:0 frame:0
          TX packets:560 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:43026 (42.0 KiB)  TX bytes:43026 (42.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 14:CC:20:46:A9:0C  
          inet6 addr: fe80::16cc:20ff:fe46:a90c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4098 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2199 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:694359 (678.0 KiB)  TX bytes:830114 (810.6 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 16:CC:20:46:A9:0C  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan1     Link encap:Ethernet  HWaddr 14:CC:20:46:A9:0D  
          inet6 addr: fe80::16cc:20ff:fe46:a90d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5668 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4728 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:947218 (925.0 KiB)  TX bytes:1658743 (1.5 MiB)

wwan0     Link encap:Ethernet  HWaddr 0C:5B:8F:27:9A:64  
          inet addr:100.71.68.39  Bcast:100.71.68.47  Mask:255.255.255.240
          inet6 addr: fe80::e5b:8fff:fe27:9a64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:28751 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37417 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:16899838 (16.1 MiB)  TX bytes:117185841 (111.7 MiB)

comment:9 Changed 3 years ago by mailgpa@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed 3 years ago by anonymous

Swapping the order of sta and ap does not help

comment:11 Changed 3 years ago by nbd

fixed in current trunk

comment:12 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.