Modify

Opened 4 years ago

Closed 3 years ago

#14744 closed defect (duplicate)

rt2x00queue_write_tx_frame Error

Reported by: fclql Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

r39211 hg255d

Kernel error:

[ 1053.700000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[ 1053.700000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[ 1053.700000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[ 1053.700000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[ 1053.700000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[ 1053.700000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[ 1053.700000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[ 1053.700000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by anonymous

using r39422, Dlink DIR 615 D4

the same problem

comment:2 Changed 4 years ago by anonymous

This issue seems to be a duplicate of
/ticket/14531.html

comment:3 Changed 4 years ago by ericwong

I have recently build AA, r41581 for rt3052 based router.
WIFI radio "works" but after I used it for a few hours to about a day, WIFI radio will "die". What I mean is WIFI radio is still on and can be discovered in WIFI scan. However, any devices trying to connect to it will not be able to get IP address or WIFI connection. If I restart the router, this problem will be gone temporarily but will reappear after sometime.

dmesg shows the same error as the post above.
Since AA currently uses the same BB backport WIFI driver, I think the source of the problem is probably the same.

I am not sure if this matters but in my wireless configuration, I am also using 40mhz channel width like this.

option channel '1'
option htmode 'HT40+'

Using this configuration, restarting WIFI will result in this message.

root@Gargoyle:~# wifi
Configuration file: /var/run/hostapd-phy0.conf
wlan0: interface state UNINITIALIZED->HT_SCAN
handle_probe_req: send failed
handle_probe_req: send failed
20/40 MHz operation not permitted on channel pri=1 sec=5 based on overlapping BSSes
Using interface wlan0 with hwaddr 00:0c:43:30:xx:xx and ssid "Gargoyle"
wlan0: interface state HT_SCAN->ENABLED
wlan0: AP-ENABLED
root@Gargoyle:~#

If I enable noscan, like this

option channel '1'
option htmode 'HT40+'
option noscan '1'

The output will be changed to

root@Gargoyle:~# wifi
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 00:0c:43:30:xx:xx and ssid "Gargoyle"
wlan0: interface state UNINITIALIZED->ENABLED
wlan0: AP-ENABLED
root@Gargoyle:~#

This means that the handle_probe_req error is related to the noscan option not enabled. I am not sure if this error is related to the rt2x00queue_write_tx_frame error.

I am now testing/using my rt305x router with noscan enabled to see if it will solve this WIFI problem. Will report back if my WIFI radio continue to die....

I would be happy to test any code changes that may fix this problem. Please reply here, so I will get a notification.

comment:4 Changed 4 years ago by ericwong

noscan option didn't fix/help my problem.
My rt305x radio continue to die like this...

[66910.260000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[66910.280000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[66910.290000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2

Manually restarting WIFI from here....

[67321.250000] device wlan0 left promiscuous mode
[67321.250000] br-lan: port 2(wlan0) entered disabled state
[67321.520000] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[67321.740000] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[67323.140000] device wlan0 entered promiscuous mode
[67323.540000] br-lan: port 2(wlan0) entered forwarding state
[67323.550000] br-lan: port 2(wlan0) entered forwarding state
[67324.390000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Arrived at non-free entry in the non-full queue 2
[67324.390000] Please file bug report to http://rt2x00.serialmonkey.com
[67325.550000] br-lan: port 2(wlan0) entered forwarding state

Related tickets
/ticket/13523.html
/ticket/14138.html
/ticket/16853.html
/ticket/12313.html

Last edited 3 years ago by ericwong (previous) (diff)

comment:5 Changed 3 years ago by ericwong

handle_probe_req: send failed

I noticed this error is device dependent. I tried two non-identical router which can use the same firmware file. When tested using the same settings, only one of the router will report this error while the other does not.

In other words, this error is not related to the rt2x00queue_write_tx_frame error in this ticket.

comment:6 Changed 3 years ago by ericwong

As a result of my rt3052 wifi dying due to the WIFI bug described above, I downgraded back to my last known working ROM based on AA r36469.

However, I continue to see those errors above in the log.
i.e.
ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2

ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Arrived at non-free entry in the non-full queue 2

On AA r36469, despite the presence of these errors, my rt3052 WIFI is typically able to operate for weeks without problem... I still can't figure out why or how to solve this. Anyone have some clues?

comment:7 Changed 3 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.