Modify

Opened 11 years ago

Closed 10 years ago

#1459 closed defect (worksforme)

Failed compiling strongswan-2.8.2 _copyright.c: undefined reference to `ipsec_version_code'

Reported by: stainblack@… Owned by: florian
Priority: low Milestone: Kamikaze 7.06
Component: packages Version:
Keywords: strongswan undefined reference Cc:

Description

trunk revision 6557

make[6]: Entering directory `/home/tristano/devel/trunk/build_mipsel/strongswan-2.8.2/programs/_copyright'
mipsel-linux-uclibc-gcc -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -I./linux/include -I/home/tristano/devel/trunk/staging_dir_mipsel/usr/include -L/home/tristano/devel/trunk/staging_dir_mipsel/usr/lib -I../../linux/include -Wall -Wpointer-arith -Wcast-qual -Wstrict-prototypes -Wbad-function-cast -DNAT_TRAVERSAL -L/home/tristano/devel/trunk/staging_dir_mipsel/usr/lib -L/home/tristano/devel/trunk/staging_dir_mipsel/lib _copyright.c -o _copyright
/tmp/cczq8fta.o: In function `main':
_copyright.c:(.text+0x2c): undefined reference to `ipsec_version_code'
_copyright.c:(.text+0x44): undefined reference to `ipsec_copyright_notice'
collect2: ld returned 1 exit status
make[6]: * [_copyright] Error 1
make[6]: Leaving directory `/home/tristano/devel/trunk/build_mipsel/strongswan-2.8.2/programs/_copyright'
make[5]:
* [programs] Error 1
make[5]: Leaving directory `/home/tristano/devel/trunk/build_mipsel/strongswan-2.8.2/programs'
make[4]: * [programs] Error 1
make[4]: Leaving directory `/home/tristano/devel/trunk/build_mipsel/strongswan-2.8.2'
make[3]:
* /home/tristano/devel/trunk/build_mipsel/strongswan-2.8.2/.built Error 2
make[3]: Leaving directory `/home/tristano/devel/trunk/package/strongswan'
make[2]: * [strongswan-compile] Error 2
make[2]: Leaving directory `/home/tristano/devel/trunk/package'
make[1]:
* [package/compile] Error 2
make[1]: Leaving directory `/home/tristano/devel/trunk'
make: * [world] Error 2

Attachments (0)

Change History (7)

comment:1 Changed 11 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:2 Changed 11 years ago by florian

  • Keywords strongswan undefined reference added
  • Milestone set to Kamikaze Milestone 1
  • Priority changed from normal to low

comment:3 Changed 11 years ago by florian

  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot reproduce the bug here. Can you please checkout to the latest SVN revision and test ?

comment:4 Changed 10 years ago by davide_lenza@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

make -j1 -C strongswan compile
make[3]: Entering directory `/home/wioptimo/kamikaze_7.09/package/strongswan'
make -C /home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2 AR=mipsel-linux-uclibc-ar AS="mipsel-linux-uclibc-gcc -c -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" LD=mipsel-linux-uclibc-ld NM=mipsel-linux-uclibc-nm CC="mipsel-linux-uclibc-gcc" GCC="mipsel-linux-uclibc-gcc" CXX=mipsel-linux-uclibc-g++ RANLIB=mipsel-linux-uclibc-ranlib STRIP=mipsel-linux-uclibc-strip OBJCOPY=mipsel-linux-uclibc-objcopy OBJDUMP=mipsel-linux-uclibc-objdump SIZE=mipsel-linux-uclibc-size LINUX_RELEASE="1" KERNELSRC="/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/linux-2.4.34" ARCH="mips" CROSS_COMPILE="mipsel-linux-uclibc-" USERCOMPILE="-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -I./linux/include -I/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/usr/include -I/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/include -L/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/usr/lib -L/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/lib" IPSECDIR="/usr/lib/ipsec" INC_USRLOCAL="/usr" LDFLAGS="-L/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/usr/lib -L/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/lib" DESTDIR="/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/ipkg-install" programs module install
make[4]: Entering directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2'
make[5]: Entering directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/lib'
make[6]: Entering directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/lib/libfreeswan'
make[6]: Nothing to be done for `programs'.
make[6]: Leaving directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/lib/libfreeswan'
make[6]: Entering directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/lib/libdes'
make[6]: Nothing to be done for `programs'.
make[6]: Leaving directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/lib/libdes'
make[5]: Leaving directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/lib'
make[5]: Entering directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/programs'
make[6]: Entering directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/programs/_copyright'
mipsel-linux-uclibc-gcc -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -I./linux/include -I/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/usr/include -I/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/include -L/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/usr/lib -L/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/lib -I../../linux/include -Wall -Wpointer-arith -Wcast-qual -Wstrict-prototypes -Wbad-function-cast -DNAT_TRAVERSAL -L/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/usr/lib -L/home/wioptimo/kamikaze_7.09/staging_dir_mipsel/lib _copyright.c -o _copyright
/tmp/ccTbEd3w.o: In function `main':
_copyright.c:(.text+0x2c): undefined reference to `ipsec_version_code'
_copyright.c:(.text+0x44): undefined reference to `ipsec_copyright_notice'
collect2: ld returned 1 exit status
make[6]: * [_copyright] Error 1
make[6]: Leaving directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/programs/_copyright'
make[5]:
* [programs] Error 1
make[5]: Leaving directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/programs'
make[4]: * [programs] Error 1
make[4]: Leaving directory `/home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2'
make[3]:
* /home/wioptimo/kamikaze_7.09/build_mipsel/linux-2.4-brcm/strongswan-2.8.2/.built Error 2
make[3]: Leaving directory `/home/wioptimo/kamikaze_7.09/package/strongswan'
make[2]: * [strongswan-compile] Error 2
make[2]: Leaving directory `/home/wioptimo/kamikaze_7.09/package'
make[1]:
* [package/compile] Error 2
make[1]: Leaving directory `/home/wioptimo/kamikaze_7.09'
make: * [world] Error 2
wioptimo@wioptimo-laptop:~/kamikaze_7.09$
wioptimo@wioptimo-laptop:~/kamikaze_7.09$ svn co https://svn.openwrt.org/openwrt/

comment:5 follow-up: Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from reopened to closed

Still can't reproduce the bug with 7.09.

comment:6 in reply to: ↑ 5 Changed 10 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to florian:

Still can't reproduce the bug with 7.09.

I'm using Ubuntu. I have to change linux distribution?

comment:7 Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from reopened to closed

No better use packages if possible.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.