Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#1457 closed defect (fixed)

"Illegal instruction" during boot - system can't boot and work!

Reported by: blackcat. Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Illegal instruction Cc:

Description

It seems that busybox mount causes the problem.
The console boot log:

Linux version 2.4.34 (admin@ferret) (gcc version 3.4.6 (OpenWrt-2.0)) #2 Sun Mar 11 14:27:17 MSK 2007
Setting the PFC to its default value
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
On node 0 totalpages: 8192
zone(0): 8192 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
CPU: BCM4704 rev 9 at 264 MHz
Using 132.000 MHz high precision timer.
Calibrating delay loop... 262.96 BogoMIPS
Memory: 30420k/32768k available (1465k kernel code, 2348k reserved, 100k data, 92k init, 0k highmem)
Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
Checking for 'wait' instruction...  unavailable.
POSIX conformance testing by UNIFIX
PCI: Initializing host
PCI: Fixing up bus 0
PCI: Fixing up bridge
PCI: Fixing up bus 1
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Registering mini_fo version $Id$
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
squashfs: version 3.0 (2006/03/15) Phillip Lougher
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0xb8000300 (irq = 3) is a 16550A
ttyS01 at 0xb8000400 (irq = 3) is a 16550A
b44.c:v0.93 (Mar, 2004)
eth0: Broadcom 47xx 10/100BaseT Ethernet 00:18:f3:95:73:8a
eth1: Broadcom 47xx 10/100BaseT Ethernet 00:90:4c:a1:00:2d
 Amd/Fujitsu Extended Query Table v1.3 at 0x0040
number of CFI chips: 1
cfi_cmdset_0002: Disabling fast programming due to code brokenness.
Flash device: 0x800000 at 0x1c000000
bootloader size: 262144
Physically mapped flash: Filesystem type: squashfs, size=0x5e3d08
Updating TRX offsets and length:
old trx = [0x0000001c, 0x000008ec, 0x0007e000], len=0x00662000 crc32=0x71b4f9c1
new trx = [0x0000001c, 0x000008ec, 0x0007e000], len=0x00670000 crc32=0x40712d45
Done
Creating 5 MTD partitions on "Physically mapped flash":
0x00000000-0x00040000 : "cfe"
0x00040000-0x007f0000 : "linux"
0x000be000-0x006b0000 : "rootfs"
mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
0x007f0000-0x00800000 : "nvram"
0x006b0000-0x007f0000 : "OpenWrt"
sflash: found no supported devices
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 4096)
ip_conntrack version 2.1 (5953 buckets, 5953 max) - 360 bytes per conntrack
ip_tables: (C) 2000-2002 Netfilter core team
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
NET4: Ethernet Bridge 008 for NET4.0
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 92k freed
Algorithmics/MIPS FPU Emulator v1.5
Illegal instruction
Illegal instruction
mount: mounting none on /sys failed
/etc/preinit: /etc/preinit: 42: /sbin/hotplug2: not found
Illegal instruction
Illegal instruction
Illegal instruction
Illegal instruction
Illegal instruction
rmmod: switch-core: Success
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
Unlocking linux ...
Could not open mtd device: linux
Illegal instruction
Illegal instruction
Illegal instruction
Illegal instruction
Illegal instruction
switching to jffs2
Illegal instruction
mount: cannot read /etc/fstab: No such file or directory
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
init started:  BusyBox v1.4.1 (2007-03-11 14:08:59 MSK) multi-call binary

At this point system hungs.

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by jhansen@…

Does this happen with the current revision (specifically after bug 1465 was fixed)?

comment:2 Changed 11 years ago by blackcat.

The problem is gone with current release of Kamikaze (6627).
Please close this ticket.

comment:3 Changed 11 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.