Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14508 closed enhancement (wontfix)

get hostname via dhcp in netifd

Reported by: vivien.frenot@… Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: netifd dhcp.script Cc:

Description

Hello,

This is a solution for the TODO hostname in dhcp.script.
It change uci hostname if defined into dhcp reply.

Attachments (1)

dhcp_with_hostname.script (2.0 KB) - added by vivien.frenot@… 4 years ago.
dhcp.scrip with hostname

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by vivien.frenot@…

dhcp.scrip with hostname

comment:1 Changed 4 years ago by vfrenot

Nothing? this is a really minor modification.

comment:2 Changed 4 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

It might be a minor change but not a really clean one.

First of all you issue a flash write whenever a lease is received which is an absolute no-go.
Then you unconditionally overwrite user settings in /e/c/system, that behaviuor should get an explicit enable switch.
Furthermore a trigger is missing to reload affected services in order to actually propagate the changed hostname downstream.

Finally you did not attach a proper patch but a complete copy of a modified script and lastly your submission is a feature implementation and not a bug and thus should be sent to the development list according to SubmittingPatches.

comment:3 Changed 4 years ago by vfrenot

thx for your answer.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.