Modify

Opened 4 years ago

Closed 3 years ago

Last modified 2 years ago

#14488 closed enhancement (invalid)

TP Link TD-W8980

Reported by: Smx Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: tplink W8980 Cc:

Description

Hi everyone. I know porting/maintaining openwrt is not a trivial task, but i'd like to see official support for the W8980.
The W8980 is very very similar to the W8970. Everything is the same, exept for the extra 5ghz wave 300 chipset on the W8980 (it's dualband).

The W8980 source code is the same as W8970 one exept for wave 300 support (see GPL_TD-W8980/lantiq/modules/wave300). The kernel, uboot and core components in W8980 are 1:1 the same as W8970 ones.

Changes:
-W8980 Build Makefile is changed to build lqwlan_build lqhostapd_build (wave 300 wlan and hostapd).
-os_lib is slightly modified for dual band support.
-W8980 config has USB 3g Dongle disabled, INCLUDE_MTD_TYPE2 enabled and dual band options enabled.

Attachments (0)

Change History (19)

comment:1 Changed 4 years ago by tripolar

  • Resolution set to not_a_bug
  • Status changed from new to closed

feel free to send patches, that add support for this device, to the ml.

comment:2 Changed 4 years ago by anonymous

There is one old Metalink driver (version 3.1) - here: https://www.dropbox.com/s/0tg0krp4rwt8e7g/lq-wave-300-03.01.00.12.31.09.58ada131737d.src.tar.gz
But it supports only two modes: Managed and AP and no VAPs. It is totally incompatible with mac80211 subsystem.
The newer driver (3.2) is a closed source driver, such as bcmwl, and for kernel 2.6.32.
It is two times bigger, and has support for VAPs and debugging.

I managed to compile OpenWRT AA with metalink driver(3.1), but it was a difficult task.
Driver seems to be unstable.

Just use image for W8970, and forget about 5GHz in this model - that is my advice.

comment:3 Changed 4 years ago by Smx

That Metalink driver is from W8980 sources, together with hostapd-lantiq.
(GPL_TD-W8980/lantiq/modules/wave300/lq-wave-300-03.01.00.12.31.09.58ada131737d.src)
(GPL_TD-W8980/lantiq/modules/wave300/hostapd-lantiq)
Could you provide the patches you made to build those for Openwrt?

comment:4 Changed 4 years ago by lpm11 _ at _ wp _dot_ pl

I can not provide patches - it is too complicated to build this driver. Moreover it has some binary bloobs (RF management, AOCS). I can share you all files (kernel module - 1 file, firmware - 3 files, radio calibration - 4 files, and script for OpenWRT - 1 file) needed to activate Metalink wireless chip and to make it visible under OpenWRT (and Luci).

Only working features are:
AP mode - Open/WPA/WPA2 PSK (WEP not included by me)
Client mode - Open/WEP/WPA/WPA2 PSK

hostapd is working only with special patch, only original version.
wpa_supplicant is working OOTB, but you have to compile original version from sources - not from OpenWRT.
wpa_cli is NOT working with this chipset - I don't know the reason.

You can't scan WiFi networks with OpenWRT (you can from command line), you can't use monitor mode or ad-hoc mode, and you can't get ANY info about connected clients and signal level.

Because of limitations - I finished playing with this chipset. If somebody provide 3.2 source - I can continue the work.

comment:5 Changed 4 years ago by anonymous

+1 from me, would be great to see support for W8980, very needed :)

comment:6 Changed 4 years ago by anonymous

+1
I also would like the support for W8980 :). I know that it is not trivial but W8980 it is getting very popular.

comment:7 Changed 4 years ago by anonymous

+1
Yup, just bought one too. Eagerly waiting to get openwrt inside it :)

comment:8 Changed 4 years ago by anonymous

+1
Yup, just bought one too. Eagerly waiting to get openwrt inside it :) 2

comment:9 Changed 3 years ago by lpm11

On installed W8970 Barrier Breaker image download https://www.sendspace.com/file/4n0mg9 - and send to router for example to /tmp. This is special prepared version for new kernel and we will try to start 5GHz working - now it is NOT working - this is PREALPHA stage; build only for further work.

Install WEXT: opkg install wireles-tools
Then do: cd / ; tar zxvf Wave300-preAlpha-0.01.tar.gz
And try to load WiFi driver : insmod mtlk ap=1
Set parameters: iwpriv mtlk0 sCountry CZ; iwconfig mtlk0 essid test
And next: ifconfig mtlk0 up - this step will fail
But you will get info about missing firmware - Wave300 ProgModel.
Just give me dmesg lines - then I could prepare next prealpha version.

comment:10 Changed 3 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

OK 5GHz is out of the question right now but 2.4GHz should be working (uses an Atheros AR9287 chip) yet it isn't due to a bug in pci-ath-fixup.c, which uses a hardcoded base address, which is correct for most models but not this one.
Geoffrey McRae provided a patch and I wrote instructions in the forum describing exactly which lines to modify:
https://forum.openwrt.org/viewtopic.php?pid=256207#p256207
I can confirm that 2.4GHz works on W8980 after applying this patch. Can it please be merged to trunk?

comment:11 Changed 3 years ago by anonymous

Any progress on this one?

comment:12 Changed 3 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

No, because the SubmittingPatches protocol was not followed. Please don't misuse the bug tracker for feature requests.

comment:13 Changed 3 years ago by anonymous

I currently don't have the time to spend learning the patches protocol. It does work for me so I'm OK with it. If someone else wants to submit this as an official patch, go ahead, the instructions are right there in the forum. You may PM me (NiQ in the forum) if you have any questions and I'll do my best to assist you.

comment:14 Changed 3 years ago by Jefferson Spindola

Hello, I buy a TD- w8980 with new firmware 6017(after 12.10.2013) with new uboot version tha first byte is 0x03. I can´t initiaziled it in putty terminal. tdw8980wiki site(http://wiki.openwrt.org/toh/tp-link/td-w8980) say this version RSA signed. The are any solution to crossflash my TD-w8990 to tD-w9980?

comment:15 Changed 3 years ago by anonymous

XWAY WAVE300 driver v3.2 source code in case someone decides to port it to openwrt:
http://www.speedyshare.com/rgYPx/wave300-3.2.1.1.48.tar.gz

comment:16 follow-up: Changed 3 years ago by anonymous

The main problem is that second PCI device is not visible.

comment:17 in reply to: ↑ 16 ; follow-up: Changed 3 years ago by anonymous

Replying to anonymous:

The main problem is that second PCI device is not visible.

Hi can you see the 2.4 controller 168c:a199 in lspci even w/o drivers?

comment:18 in reply to: ↑ 17 Changed 3 years ago by Adrien

Replying to anonymous:

Replying to anonymous:

The main problem is that second PCI device is not visible.

Hi can you see the 2.4 controller 168c:a199 in lspci even w/o drivers?

Hello,

Here the result of the commands lspci in a TD-W9980.
The wifi card 5 Ghz Wave 300 isn't visible.

root@OpenWrt:~# lspci
00:00.0 PCI bridge: Device 1bef:0011 (rev 01)
01:00.0 Ethernet controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
root@OpenWrt:~# lspci -n
00:00.0 0604: 1bef:0011 (rev 01)
01:00.0 0200: 168c:002e (rev 01)

comment:19 Changed 2 years ago by anonymous

I have seen this ticket too late, but I have just sent an updated version of Geoffrey McRae's patch for inclusion (this will fix 2.4G wifi): http://patchwork.ozlabs.org/patch/515498/

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.