Modify

Opened 4 years ago

Last modified 2 years ago

#14482 reopened defect

wa901nd no space left problem

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

i was able to use luci since last release. now whenever i try to install luci it says no memory left even if there is enough space.

Attachments (0)

Change History (21)

comment:1 Changed 4 years ago by anonymous

Include luci into your firmware file and use this then. For "installation" you need more space then for when its aleeady included into an firmware file.

comment:2 Changed 4 years ago by tripolar

  • Resolution set to not_a_bug
  • Status changed from new to closed

not a bug. if your device has limited flash space it won't be possible to install packages that won't fit onto the free flash. as this device has only 4mb flash, try to remove programs (you installed allready on the jffs2) or try to include the package into a firmware you create on your own.

Last edited 4 years ago by tripolar (previous) (diff)

comment:3 Changed 4 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

i was able to install luci and haveged since last update of trunk! but now i cant install luci. why does the new trunk takes more space?

comment:4 Changed 4 years ago by tripolar

please show me the output of "df" and "opkg list-installed" with the old firmware and with latest trunk

Last edited 4 years ago by tripolar (previous) (diff)

comment:5 Changed 4 years ago by tripolar

updates to programs (that happend in between) can lead to bigger footprints and more dependencies

comment:6 Changed 4 years ago by tripolar

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

comment:7 Changed 4 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

Hm, got the same on TPLINK WR841ND v7...so far was always updating without problem, now I'm without LUCI, it says not enough space :

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                  768.0K    708.0K     60.0K  92% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    14.1M    588.0K     13.5M   4% /tmp
/dev/mtdblock3          768.0K    708.0K     60.0K  92% /overlay
overlayfs:/overlay      768.0K    708.0K     60.0K  92% /
tmpfs                   512.0K         0    512.0K   0% /dev

...this is after : mtd -r erase rootfs_data and opkg update + opkg install luci
I'm afraid that latests trunks killed this option for 4MB devices.

comment:8 Changed 4 years ago by anonymous

On 12.09 final :

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    1.1M    224.0K    864.0K  21% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    14.3M     68.0K     14.2M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock3            1.1M    224.0K    864.0K  21% /overlay
overlayfs:/overlay        1.1M    224.0K    864.0K  21% /

comment:9 Changed 4 years ago by anonymous

screw you

comment:10 Changed 4 years ago by anonymous

I have the same problem with last version installed today.
I had luci and after flashing an upgrade I cannot install it anymore:

root@OpenWrt:/overlay# df
Filesystem 1K-blocks Used Available Use% Mounted on
rootfs 768 708 60 92% /
/dev/root 2304 2304 0 100% /rom
tmpfs 14460 580 13880 4% /tmp
tmpfs 14460 12 14448 0% /tmp/root
tmpfs 512 0 512 0% /dev
/dev/mtdblock3 768 708 60 92% /overlay
overlayfs:/overlay 768 708 60 92% /

root@OpenWrt:/overlay# df
Filesystem 1K-blocks Used Available Use% Mounted on
rootfs 768 708 60 92% /
/dev/root 2304 2304 0 100% /rom
tmpfs 14460 580 13880 4% /tmp
tmpfs 14460 12 14448 0% /tmp/root
tmpfs 512 0 512 0% /dev
/dev/mtdblock3 768 708 60 92% /overlay
overlayfs:/overlay 768 708 60 92% /

What can I do?

comment:11 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

A package feed used in the snapshot builds was pulling in bogus dependencies, bloating up the root filesystem size. This has been fixed, but you need to wait for the next snapshot build to complete before you get a new image without the extra files.

comment:12 Changed 4 years ago by anonymous

in what build is the fix released? Can you give us a Little Signal, when we can update the accesspoint? (I installed the release from the 20th of december and have the same Problems.

comment:13 Changed 4 years ago by anonymous

already fixed in r39132

comment:14 follow-up: Changed 3 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Same problem in CC?

CHAOS CALMER (Bleeding Edge, r43124)

sysupgrade image is 3.080.196 bytes and Luci does not fit anymore :(

For exapmple BB rc2 was 2.883.588, that 130 KB are really an issue!

comment:15 in reply to: ↑ 14 Changed 3 years ago by anonymous

Replying to anonymous:

Same problem in CC?

CHAOS CALMER (Bleeding Edge, r43124)

sysupgrade image is 3.080.196 bytes and Luci does not fit anymore :(

For exapmple BB rc2 was 2.883.588, that 130 KB are really an issue!

I can definitely confirm, no free space and Luci stops working or won't install.

Back to stable and it's working.

comment:16 Changed 3 years ago by lissny

same problem 740n while installing luci it says about no disk space left...
i downloaded at 17th april 2015 snapshots

comment:17 in reply to: ↑ description Changed 3 years ago by anonymous

Replying to anonymous:

i was able to use luci since last release. now whenever i try to install luci it says no memory left even if there is enough space.

comment:18 Changed 3 years ago by anonymous

yea I cannot install luci on chaos rc2 tplink 3420 v2 device (4mb)

comment:19 Changed 3 years ago by anonymous

yea I cannot install luci on chaos rc2 tplink 3420 v2 device (4mb)

comment:20 Changed 2 years ago by anonymous

same problem, cannot install luci on barrier braker 15.05.rc3, device tplink wa901nd-v2
back to Barrier Breaker 14.07 (luci integrated in rom)

comment:21 Changed 2 years ago by anonymous

*chaos_calmer 15.05.rc3

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.