Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14478 closed defect (wontfix)

Openwrt vs free space

Reported by: anonymous Owned by: developers
Priority: high Milestone: Attitude Adjustment 12.09.1
Component: packages Version: Attitude Adjustment 12.09
Keywords: Cc:

Description

I was tried to install nano into my openwrt. It failed with message "you have only 60kb, linbcurces needs 110". Before installation I had 210k, after 60kb.

I want to get back my 210kb without manual removal of packages content. Should I reinstall openwrt?

Attachments (0)

Change History (9)

comment:1 Changed 4 years ago by anonymous

I am interesting why "opkg" is not marked as "WIP" if it is not finished?

comment:2 Changed 4 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

Use the forum for support questions.

comment:3 Changed 4 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

If "opkg install" was failed it should make cleanup, but it just stops. Why this is "not a bug"? Can you please give an answer?

comment:4 Changed 4 years ago by anonymous

If you dont want to provide automatic cleanup after "opkg install package" was failed, can you please consider adding "opkg cleanup package"?

function cleanup_package (package)

if package is installed

return

else

try to delete all files, that belongs to this package
apply "cleanup_package" to all ancestors of this package

comment:5 Changed 4 years ago by jow

  • Resolution set to wontfix
  • Status changed from reopened to closed

Discuss this upstream with the opkg project. To me it does not sound like a cleanup problem but simply a case where automatically installed dependencies simply did not get uninstalled, in such a case the autoremove option might help.

Anyhow, nobody is going to look into this so I'll mark this as wontfix. If you have specific changes feel free to send patches to the development list.

comment:6 Changed 4 years ago by anonymous

ok, no problem.

comment:7 Changed 4 years ago by anonymous

Just today I have to go through this process of manually removing all library files from a incorrect installation due to space requirements.

Trust me..implementing a full blown clean up process is much more easier than removing all those files manually considering the fact if one wrong file is deleted then we might not be able to boot up.

My solution is simple.
First of all we try to simulate the process and get the max memory for all packages which are dependencies then we get total available space. If the system thinks that there is enough space on overlay partition then it installs otherwise there will be a warning.

comment:8 Changed 4 years ago by anonymous

Only problem is that your approach would not properly account for filesystem compression.

comment:9 Changed 4 years ago by anonymous

I had the same problem, found this via Google, fixed it by reinstalling nano and then running opkg remove --autoremove nano

root@OpenWrt:~# opkg remove --autoremove nano
Removing package nano from root...
libncurses was autoinstalled and is now orphaned, removing.
Removing package libncurses from root...
terminfo was autoinstalled and is now orphaned, removing.
Removing package terminfo from root...
root@OpenWrt:~# 

You're welcome, fellow Googlers (or DuckDuckGo-ers) ;)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.