Modify

Opened 4 years ago

Last modified 3 years ago

#14463 new defect

cannot compile slang2 = ncurses terminfo problem? (and so newt, zaptel, yate)

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Attitude Adjustment 12.09.1
Component: packages Version: Trunk
Keywords: Cc:

Description

On my old host terminfo was also in /usr/share/terminfo.
It seems that changed for ncurses-base 5.9+20130119-1.
Now it's only in /lib/terminfo on the host which builds.

Slang2 checks had this output before (with ncurses-base 5.7 on host):

checking for terminfo... ./configure: line 6794: /space/build-attitude_adjustment/attitude_adjustment/files/ncurses5-config: No such file or directory
yes

Now (with ncurses-base 5.9 on host) it says:

checking for terminfo... ./configure: line 6794: /space/build-attitude_adjustment/attitude_adjustment/files/ncurses5-config: No such file or directory
no

The consequence when building slang2 is that instead

ccache_cc -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -fpic -Wall -W -pedantic -Winline -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wshadow -Wstrict-prototypes -Wformat=2  mipsobjs/slsh.o mipsobjs/readline.o -o mipsobjs/slsh_exe -L/space/build-attitude_adjustment/attitude_adjustment/staging_dir/target-mips_r2_uClibc-0.9.33.2/usr/lib -L/space/build-attitude_adjustment/attitude_adjustment/staging_dir/target-mips_r2_uClibc-0.9.33.2/lib -L/space/build-attitude_adjustment/attitude_adjustment/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/usr/lib -L/space/build-attitude_adjustment/attitude_adjustment/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/lib -L../src/mipselfobjs  -Wl,-export-dynamic -L/space/build-attitude_adjustment/attitude_adjustment/build_dir/target-mips_r2_uClibc-0.9.33.2/slang-2.2.4/src/mipselfobjs -lslang  -ldl  -lm

you get

ccache_cc -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -fpic -Wall -W -pedantic -Winline -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wshadow -Wstrict-prototypes -Wformat=2  mipsobjs/slsh.o mipsobjs/readline.o -o mipsobjs/slsh_exe -L/space/build-attitude_adjustment/attitude_adjustment/staging_dir/target-mips_r2_uClibc-0.9.33.2/usr/lib -L/space/build-attitude_adjustment/attitude_adjustment/staging_dir/target-mips_r2_uClibc-0.9.33.2/lib -L/space/build-attitude_adjustment/attitude_adjustment/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/usr/lib -L/space/build-attitude_adjustment/attitude_adjustment/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/lib -L../src/mipselfobjs  -Wl,-export-dynamic -L/space/build-attitude_adjustment/attitude_adjustment/build_dir/target-mips_r2_uClibc-0.9.33.2/slang-2.2.4/src/mipselfobjs -lslang  -ltermcap -ldl  -lm

which leads to:

/space/build-attitude_adjustment/attitude_adjustment/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/lib/gcc/mips-openwrt-linux-uclibc/4.6.3/../../../../mips-openwrt-linux-uclibc/bin/ld: cannot find -ltermcap
collect2: ld returned 1 exit status
make[5]: *** [mipsobjs/slsh_exe] Error 1

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by andim

Confirmed here (on aptosid live system, once a slight update has been done; on BB trunk). Nicely written report!
So it seems one would need an owrt patch for slang2 package to account for the new terminfo location (and then retain querying the old one as fallback), and which is to be applied to upstream soonish, too.

comment:2 Changed 3 years ago by anonymous

confirmed here, problem still present

comment:3 Changed 3 years ago by anonymous

Problem not solved =(

comment:4 Changed 3 years ago by sleytus

I ran into the same problem building openwrt-yun. Here is a fix:
Edit the file ../feeds/packages/libs/slang2/files/ncurses5-config and change

echo "/usr/share/terminfo"

to

echo "/lib/terminfo"

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.