Modify

Opened 4 years ago

Closed 4 years ago

#14370 closed defect (duplicate)

Asterisk 1.8.x listening ok, local peers not connected

Reported by: zouhair.s@… Owned by: slachta
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Asterisk 1.8.x peers uclibc Cc:

Description

Hi,
i have successfully build git version (r38435) (uClibc 0.9.33.2) of openwrt target Broadcom BCM63xx (neufbox4).
using Asterisk 1.8.x local sip peers not connected, and sip debug on, i dont get any output log from asterisk.
tested with asterisk 1.8.10.1 / 1.8.24.0 same result :/
possible uClibc bug ??

# ifconfig br-lan
br-lan    Link encap:Ethernet  HWaddr 00:25:15:XX:XX:XX  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fd52:34e4:99ec::1/60 Scope:Global
          inet6 addr: fe80::225:15ff:fe13:32e9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3801 errors:0 dropped:7 overruns:0 frame:0
          TX packets:3431 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:281825 (275.2 KiB)  TX bytes:684452 (668.4 KiB)


# asterisk -rx "sip show peers" |grep 1110
Name/username             Host                                    Dyn Forcerport ACL Port     Status
1110/1110                   (Unspecified)                            D   N             0        UNKNOWN

# tcpdump -ni eth1 -f 'port 5060'
tcpdump: WARNING: eth1: no IPv4 address assigned
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes
15:56:29.807958 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 336
15:56:32.808336 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 335
15:56:35.808779 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 334
15:56:38.809083 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 335
15:56:46.810992 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 335
15:56:49.811385 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 335
15:56:52.811769 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 335
15:56:55.812161 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 332
15:57:03.814000 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 334
15:57:06.814379 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 335
15:57:09.814774 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 334
15:57:12.815177 IP 192.168.1.8.5060 > 192.168.1.2.5060: SIP, length: 335

# netstat -naptu |grep asterisk
udp    95232      0 0.0.0.0:5060            0.0.0.0:*                           1114/asterisk


---- sip.conf ---
[general]
context=default
bindaddr=0.0.0.0
transport=udp
bindport=5060
localnet=192.168.1.0/255.255.255.0
canreinvite=no
progressinband=yes
maxexpirey=3600
defaultexpirey=1800

;peer
[1110]                                                                
type=friend                                                           
host=dynamic                                                          
defaultuser=1110                                                    
secret=PASWORD                                                      
callerid="Home" <1110>                                          
dtmfmode=auto                                                         
qualify=yes                                                           
canreinvite=no                                                        
disallow=all                                                          
allow=alaw                                                            
allow=ulaw                                                            
context=local                                                           
mailbox=8888@default

ofcourse, my asterisk config work file in same hardware with older version of openwrt (r27128).

NB: other network (tcp) packages like dropbear, lighthttpd... work fine.



Attachments (0)

Change History (7)

comment:1 follow-up: Changed 4 years ago by slachta

  • Owner changed from developers to slachta
  • Status changed from new to assigned

Hello,

I think it is a duplicate of #11929. If it is so, it is an uClibc issue described in the #11929 ticket. The same issue should also appear in asterisk-11.x package.

As a workaround the specific IP for your peer should work.

[yourpeer]
;put here your peer variables
host=<put here specific peer IP>

Please, check it and let me know.

Regards,
Jiri

comment:2 Changed 4 years ago by slachta

  • Resolution set to duplicate
  • Status changed from assigned to closed

I tested it and it is the duplicate of #11929. If you think it is a different issue, feel free to reopen it.

Regards,
Jiri

comment:3 in reply to: ↑ 1 Changed 4 years ago by anonymous

Replying to slachta:

Hello,

I think it is a duplicate of #11929. If it is so, it is an uClibc issue described in the #11929 ticket. The same issue should also appear in asterisk-11.x package.

As a workaround the specific IP for your peer should work.

[yourpeer]
;put here your peer variables
host=<put here specific peer IP>

Please, check it and let me know.

Regards,
Jiri

no, not work.
possible is not same issue !

here my sip settings:

*CLI> sip show settings


Global Settings:
----------------
  UDP Bindaddress:        0.0.0.0:5060
  TCP SIP Bindaddress:    Disabled
  TLS SIP Bindaddress:    Disabled
  Videosupport:           Yes
  Textsupport:            No
  Ignore SDP sess. ver.:  No
  AutoCreate Peer:        No
  Match Auth Username:    No
  Allow unknown access:   Yes
  Allow subscriptions:    Yes
  Allow overlap dialing:  Yes
  Allow promisc. redir:   No
  Enable call counters:   No
  SIP domain support:     No
  Realm. auth:            No
  Our auth realm          asterisk
  Use domains as realms:  No
  Call to non-local dom.: Yes
  URI user is phone no:   No
  Always auth rejects:    Yes
  Direct RTP setup:       No
  User Agent:             Asterisk PBX 1.8.24.0
  SDP Session Name:       Asterisk PBX 1.8.24.0
  SDP Owner Name:         root
  Reg. context:           (not set)
  Regexten on Qualify:    No
  Legacy userfield parse: No
  Caller ID:              asterisk
  From: Domain:           
  Record SIP history:     Off
  Call Events:            Off
  Auth. Failure Events:   Off
  T.38 support:           No
  T.38 EC mode:           Unknown
  T.38 MaxDtgrm:          -1
  SIP realtime:           Disabled
  Qualify Freq :          60000 ms
  Q.850 Reason header:    No
  Store SIP_CAUSE:        No

Network QoS Settings:
---------------------------
  IP ToS SIP:             CS0
  IP ToS RTP audio:       CS0
  IP ToS RTP video:       CS0
  IP ToS RTP text:        CS0
  802.1p CoS SIP:         4
  802.1p CoS RTP audio:   5
  802.1p CoS RTP video:   6
  802.1p CoS RTP text:    5
  Jitterbuffer enabled:   No

Network Settings:
---------------------------
  SIP address remapping:  Disabled
  Externhost:             <none>
  Externaddr:             (null)
  Externrefresh:          10
  Localnet:               192.168.1.0/255.255.255.0

Global Signalling Settings:
---------------------------
  Codecs:                 0x3c000e (gsm|ulaw|alaw|h261|h263|h263p|h264)
  Codec Order:            alaw:20,ulaw:20,gsm:20
  Relax DTMF:             No
  RFC2833 Compensation:   No
  Symmetric RTP:          No
  Compact SIP headers:    No
  RTP Keepalive:          0 (Disabled)
  RTP Timeout:            0 (Disabled)
  RTP Hold Timeout:       0 (Disabled)
  MWI NOTIFY mime type:   application/simple-message-summary
  DNS SRV lookup:         Yes
  Pedantic SIP support:   Yes
  Reg. min duration       60 secs
  Reg. max duration:      3600 secs
  Reg. default duration:  1800 secs
  Outbound reg. timeout:  20 secs
  Outbound reg. attempts: 0
  Notify ringing state:   Yes
    Include CID:          No
  Notify hold state:      No
  SIP Transfer mode:      open
  Max Call Bitrate:       384 kbps
  Auto-Framing:           No
  Outb. proxy:            <not set> 
  Session Timers:         Accept
  Session Refresher:      uas
  Session Expires:        1800 secs
  Session Min-SE:         90 secs
  Timer T1:               500
  Timer T1 minimum:       100
  Timer B:                32000
  No premature media:     Yes
  Max forwards:           70

Default Settings:
-----------------
  Allowed transports:     UDP
  Outbound transport:	  UDP
  Context:                default
  Force rport:            No
  DTMF:                   rfc2833
  Qualify:                0
  Use ClientCode:         No
  Progress inband:        Yes
  Language:               fr
  MOH Interpret:          default
  MOH Suggest:            
  Voice Mail Extension:   asterisk

----
*CLI>

i need test with eglibc, but r38435 not compile :/
/ticket/14380.html

Thanks.

comment:4 Changed 4 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:5 follow-up: Changed 4 years ago by slachta

Hello,

could you please try to download this patch, patch your buildroot and recompile your whole environment by:

make dirclean
make

and try this again?

The default config with this patch allows me to register the clients without any issue on ar71xx and x86. I can't currently replicate your issue, so I would appreciate, if you could try to patch your uClibc and see, if it happens or not. If the bug still persists, I will start to investigate more.

comment:6 in reply to: ↑ 5 Changed 4 years ago by anonymous

Replying to slachta:

Hello,

could you please try to download this patch, patch your buildroot and recompile your whole environment by:

make dirclean
make

and try this again?

The default config with this patch allows me to register the clients without any issue on ar71xx and x86. I can't currently replicate your issue, so I would appreciate, if you could try to patch your uClibc and see, if it happens or not. If the bug still persists, I will start to investigate more.

Yes, this patch is slove the issue.
Asterisk work now with the default config (host=dynamic...)
but, why this patch is not committed yet ?

Thanks.

comment:7 Changed 4 years ago by slachta

  • Resolution set to duplicate
  • Status changed from reopened to closed

The reason is that we do not have a clean fix for that issue. We are waiting for that issue being solved in uClibc upstream.

I am closing this issue as a duplicate of #11929. For further information please follow the #11929 ticket.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.