Modify

Opened 4 years ago

Closed 4 years ago

#14315 closed defect (duplicate)

[Buffalo WBMR]GCC 4.8 Linaro+binutils_linaro does not compile

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: toolchain Version: Trunk
Keywords: gcc trunk binutils wbmr buffalo Cc:

Description

When I try to build a new trunk version for WBMR with gcc 4.8 linaro and binutils linaro I got this error.

                 from /home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4/src/include/drv_dsl_cpe_os_linux.h:19,
                 from /home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4/src/include/drv_dsl_cpe_os.h:26,
                 from /home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4/src/include/drv_dsl_cpe_api.h:243,
                 from /home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4/src/common/drv_dsl_cpe_api.c:14:
/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/linux-3.10.13/include/linux/cpumask.h: In function 'cpumask_parse':
/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/linux-3.10.13/include/linux/cpumask.h:603:26: warning: signed and unsigned type in conditional expression [-Wsign-compare]
  int len = nl ? nl - buf : strlen(buf);
                          ^
{standard input}: Assembler messages:
{standard input}:4932: Error: illegal operands `lbu'
{standard input}:4934: Error: illegal operands `sb'
{standard input}:4935: Error: illegal operands `beqz'
{standard input}:4936: Error: illegal operands `addiu'
{standard input}:5019: Error: illegal operands `lbu'
{standard input}:5021: Error: illegal operands `sb'
{standard input}:5022: Error: illegal operands `bnez'
{standard input}:5044: Error: illegal operands `lbu'
{standard input}:5046: Error: illegal operands `sb'
{standard input}:5047: Error: illegal operands `bnez'
make[8]: *** [/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4/src/common/drv_dsl_cpe_api.o] Error 1
make[7]: *** [_module_/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4/src] Error 2
make[6]: *** [sub-make] Error 2
make[6]: Leaving directory `/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/linux-3.10.13'
make[5]: *** [drv_dsl_cpe_api.ko] Error 2
make[5]: Leaving directory `/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4/src'
make[5]: Entering directory `/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4'
make[5]: Nothing to be done for `all-am'.
make[5]: Leaving directory `/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4'
make[3]: *** [/home/kitsune/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xway/ltq-dsl-ar9/drv_dsl_cpe_api-3.24.4.4/.built] Error 2
make[3]: Leaving directory `/home/kitsune/openwrt/package/kernel/lantiq/ltq-adsl'
make[2]: *** [package/kernel/lantiq/ltq-adsl/compile] Error 2
make[2]: Leaving directory `/home/kitsune/openwrt'
make[1]: *** [/home/kitsune/openwrt/staging_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/kitsune/openwrt'
make: *** [world] Errore 2

Using the default gcc 4.6 and binutils 2.22 there is no error.
I attach here the .config

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by anonymous

This is a duplicate of #14188. PKG_USE_MIPS16:=0 needs to be added to the Makefile.

comment:2 Changed 4 years ago by anonymous

thanks. now it works.

comment:3 Changed 4 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.