Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14307 closed defect (fixed)

ath9k: kernel panic and reboot loop - probably caused by r38354

Reported by: Damian Kaczkowski <damian.kaczkowski+openwrt@…> Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi.

ar71xx
tl-wr1043nd
r38359

Build done from scratch on fresh buildroot. r38352 works ok.

syslog:

U-Boot 1.1.4 (Apr 28 2011 - 15:55:09)

AP83 (ar9100) U-boot 0.0.11
DRAM:
sri
32 MB
id read 0x100000ff
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7100_enet_initialize...
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
eth0
Autobooting in 1 seconds## Booting image at bf020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...



OpenWrt kernel loader for AR7XXX/AR9XXX
Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
Looking for OpenWrt image... found at 0xbf022000
Decompressing kernel... done!
Starting kernel at 80060000...

[    0.000000] Linux version 3.10.13 (dk@owrt) (collect2: ld returned 1 exit status) #1 Thu Oct 10 19:31:45 CEST 2013
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9132 rev 2
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:5.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] Reserving 0MB of memory at 0MB for crashkernel
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  board=TL-WR1043ND console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 28776k/32768k available (2216k kernel code, 3992k reserved, 591k data, 260k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.100000] MIPS: machine is TP-LINK TL-WR1043ND
[    0.360000] bio: create slab <bio-0> at 0
[    0.370000] Switching to clocksource MIPS
[    0.380000] NET: Registered protocol family 2
[    0.380000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.380000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.390000] TCP: Hash tables configured (established 512 bind 512)
[    0.390000] TCP: reno registered
[    0.400000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.400000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.410000] NET: Registered protocol family 1
[    0.430000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.440000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.450000] msgmni has been set to 56
[    0.450000] io scheduler noop registered
[    0.450000] io scheduler deadline registered (default)
[    0.460000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.490000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[    0.490000] console [ttyS0] enabled, bootconsole disabled
[    0.490000] console [ttyS0] enabled, bootconsole disabled
[    0.510000] ath79-spi ath79-spi: master is unqueued, this is deprecated
[    0.520000] m25p80 spi0.0: found s25sl064p, expected m25p80
[    0.520000] m25p80 spi0.0: s25sl064p (8192 Kbytes)
[    0.530000] 5 tp-link partitions found on MTD device spi0.0
[    0.530000] Creating 5 MTD partitions on "spi0.0":
[    0.540000] 0x000000000000-0x000000020000 : "u-boot"
[    0.540000] 0x000000020000-0x00000011cc00 : "kernel"
[    0.550000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.560000] 0x00000011cc00-0x0000007f0000 : "rootfs"
[    0.570000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.580000] mtd: partition "rootfs" set to be root filesystem
[    0.590000] 1 squashfs-split partitions found on MTD device rootfs
[    0.590000] 0x000000450000-0x0000007f0000 : "rootfs_data"
[    0.600000] 0x0000007f0000-0x000000800000 : "art"
[    0.610000] 0x000000020000-0x0000007f0000 : "firmware"
[    0.620000] Realtek RTL8366RB ethernet switch driver version 0.2.4
[    0.730000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
[    0.730000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[    0.910000] libphy: rtl8366rb: probed
[    0.920000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RGMII
[    1.230000] TCP: cubic registered
[    1.230000] NET: Registered protocol family 17
[    1.240000] 8021q: 802.1Q VLAN Support v1.8
[    1.250000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    1.260000] Freeing unused kernel memory: 260K (8031f000 - 80360000)
Console is alive
procd: Console is alive
- watchdog -
procd: - watchdog -
[    4.560000] usbcore: registered new interface driver usbfs
[    4.570000] usbcore: registered new interface driver hub
[    4.570000] usbcore: registered new device driver usb
[    4.620000] SCSI subsystem initialized
[    4.630000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.640000] ehci-platform: EHCI generic platform driver
[    4.640000] ehci-platform ehci-platform: EHCI Host Controller
[    4.650000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    4.660000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    4.680000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    4.680000] hub 1-0:1.0: USB hub found
[    4.690000] hub 1-0:1.0: 1 port detected
[    4.700000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.710000] usbcore: registered new interface driver usb-storage
kmod: ran 30 iterations
- preinit -
procd: - preinit -
[    5.010000] eth0: link up (1000Mbps/Full duplex)
Press the [f] key and hit [enter] to enter failsafe mode
kmod: ran 1 iterations
mount_root: jffs2 is not ready - marker found
[    8.520000] eth0: link down
- early -
procd: - early -
- watchdog -
procd: - watchdog -
/sbin/hotplug-call: /etc/hotplug.d/usb/20-usb_mode: line 1: service_triggers: not found
- init -
procd: - init -
Failed to connect to ubus
Please press Enter to activate this console.
[   10.350000] u32 classifier
[   10.350000]     input device check on
[   10.350000]     Actions configured
[   10.380000] Mirror/redirect action on
[   10.390000] Loading modules backported from Linux version master-2013-06-27-0-gdcfa6d5
[   10.390000] Backport generated by backports.git backports-20130617-4-ge3220f5
[   10.430000] nf_conntrack version 0.5.0 (453 buckets, 1812 max)
[   10.450000] Netfilter messages via NETLINK v0.30.
[   10.480000] usbip_core: USB/IP Core v1.0.0
[   10.480000] usbcore: registered new interface driver usbip-host
[   10.490000] usbip_host: USB/IP Host Driver v1.0.0
[   10.510000] usbcore: registered new interface driver usbserial
[   10.510000] usbcore: registered new interface driver usbserial_generic
[   10.530000] usbserial: USB Serial support registered for generic
[   10.600000] xt_time: kernel timezone is -0000
[   10.690000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   10.700000] cfg80211: Calling CRDA to update world regulatory domain
[   10.700000] cfg80211: World regulatory domain updated:
[   10.710000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   10.720000] cfg80211:   (2402000 KHz - 2494000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[   10.720000] cfg80211:   (4910000 KHz - 5835000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[   10.830000] ctnetlink v0.93: registering with nfnetlink.
[   10.850000] PPP generic driver version 2.4.2
[   10.870000] NET: Registered protocol family 24
[   10.890000] usbcore: registered new interface driver option
[   10.910000] usbserial: USB Serial support registered for GSM modem (1-port)
[   10.960000] ieee80211 phy0: Atheros AR9100 MAC/BB Rev:7 AR2133 RF Rev:a2 mem=0xb80c0000, irq=2
[   10.970000] cfg80211: Calling CRDA for country: US
[   10.970000] cfg80211: Regulatory domain changed to country: US
[   10.980000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   10.990000] cfg80211:   (2402000 KHz - 2494000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[   11.000000] cfg80211:   (4910000 KHz - 5835000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[   20.630000] eth0: link up (1000Mbps/Full duplex)
[   20.640000] device eth0 entered promiscuous mode
[   20.640000] br-lan: port 1(eth0) entered listening state
[   20.650000] br-lan: port 1(eth0) entered listening state
[   21.100000] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   21.130000] jffs2_build_filesystem(): unlocking the mtd device... done.
[   21.130000] jffs2_build_filesystem(): erasing all blocks after the end marker... [   22.650000] br-lan: port 1(eth0) entered learning state
[   24.140000] cfg80211: Calling CRDA for country: PL
[   24.160000] cfg80211: Regulatory domain changed to country: PL
[   24.160000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   24.170000] cfg80211:   (2402000 KHz - 2494000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[   24.180000] cfg80211:   (4910000 KHz - 5835000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[   24.650000] br-lan: port 1(eth0) entered forwarding state
[   28.690000] CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 80de546c, ra == 80de59cc
[   28.700000] Oops[#1]:
[   28.700000] CPU: 0 PID: 1311 Comm: hostapd Not tainted 3.10.13 #1
[   28.700000] task: 816ed920 ti: 8156e000 task.ti: 8156e000

[   28.700000] $ 0   : 00000000 00000000 00000000 00000001
[   28.700000] $ 4   : 80d61400 80d68010 00000000 00000040
[   28.700000] $ 8   : 00000038 800647f8 00000002 00000013
[   28.700000] $12   : 000000ff fffffffb 0000003f 00000001
[   28.700000] $16   : 80d61400 81884010 00000000 80d61400
[   28.700000] $20   : 80ed6810 81788000 00000000 00000001
[   28.700000] $24   : 00000001 80de13c4
[   28.700000] $28   : 8156e000 8156fcb0 7fdc6e38 80de59cc
[   28.700000] Hi    : 00000007
[   28.700000] Lo    : 1d360000
[   28.700000] epc   : 80de546c ath9k_spectral_scan_trigger+0xa2c/0xaa4 [ath9k]
[   28.700000]     Not tainted
[   28.700000] ra    : 80de59cc ath_startrecv+0x90/0x100 [ath9k]
[   28.700000] Status: 1000dc03 KERNEL EXL IE
[   28.700000] Cause : 0080000c
[   28.700000] BadVA : 00000000
[   28.700000] PrId  : 00019374 (MIPS 24Kc)
[   28.700000] Modules linked in: ath9k pppoe ppp_async option iptable_nat ath9k_common usb_wwan pppox ppp_generic nf_nat_ipv4 nf_conntrack_netlink nf_conntrack_ipv4 mac80211 iptable_raw iptable_mangle iptable_filter ipt_ah ipt_REJECT ipt_MASQUERADE ipt_ECN ip_tables cfg80211 ath9k_hw xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_hashlimit xt_esp xt_ecn xt_dscp xt_conntrack xt_connmark xt_connbytes xt_comment xt_TEE xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY x_tables usbserial usbip_host usbip_core slhc nfnetlink nf_nat nf_defrag_ipv4 nf_conntrack macvlan crc_ccitt compat ath act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress ledtrig_usbdev ledtrig_netdev ifb vfat fat nls_utf8 nls_iso8859_2 nls_iso8859_1 nls_cp852 nls_cp850 nls_cp437 nls_cp1250 chainiv eseqiv crypto_wq sha1_generic krng rng md5 hmac des_generic deflate zlib_inflate zlib_deflate cbc authenc aead arc4 crypto_blkcipher usb_storage leds_gpio ohci_hcd ledtrig_timer ledtrig_default_on ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 crc16 jbd2 mbcache usbcore nls_base usb_common crypto_hash
[   28.700000] Process hostapd (pid: 1311, threadinfo=8156e000, task=816ed920, tls=77d4e440)
[   28.700000] Stack : 00000001 81884010 00000000 00000000 00000000 80d61400 81884010 80d68048
          80d61d10 80de59cc 00000000 80d87668 00000000 81884010 00000001 80d61400
          81884010 00000000 80d61c94 80de2958 818841ac 81884010 80d61400 80d61c94
          818841ac 81884010 80d61400 80d61c94 80ed6810 80de3c20 fffffff1 0000000d
          fffffff0 0000000d 81788000 00000000 81788000 8178802c 80d60a80 817883c8
          ...
[   28.700000] Call Trace:
[   28.700000] [<80de546c>] ath9k_spectral_scan_trigger+0xa2c/0xaa4 [ath9k]
[   28.700000]
[   28.700000]
Code: 8cb2000c  8c910888  00809821 <ae400000> 8ca20014  00a08021  ae420004  8ca20008  2c430001
[   28.970000] ---[ end trace 0b481f82b2e54056 ]---
[   28.980000] Kernel panic - not syncing: Fatal exception in interrupt
[   28.980000] Rebooting in 3 seconds..

U-Boot 1.1.4 (Apr 28 2011 - 15:55:09)

AP83 (ar9100) U-boot 0.0.11
DRAM:
sri
32 MB

wireless config:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'platform/ath9k'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'DSSS_CCK-40'
        option channel '1'
        option txpower '17'
        option country 'PL'
        option noscan '0'
        option disabled '0'

config wifi-iface 'wlan0_0'
        option disabled '0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'ssid'
        option encryption 'psk2+ccmp'
        option key 'secret'

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by hnyman <hannu.nyman@…>

I am most likely experiencing the same.
ar71xx/wndr3700

build 38351 worked ok, but 38361 goes into reboot loop if wireless is not disabled.

wireless config

config wifi-device 'radio0'
        option type 'mac80211'
        option phy 'phy0'
        option hwmode '11ng'
        option htmode 'HT40+'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '1'
        option channel '3'
        option txpower '20'
        option country 'FI'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'wwwwwwwwwwwwww'
        option key 'xzxzxzxzx'
        option wps_pushbutton '1'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option phy 'phy1'
        option hwmode '11na'
        option htmode 'HT40+'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '17'
        option country 'FI'
        option disabled '1'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'zzzzzzzzzz'
        option encryption 'psk2'
        option key 'xxx'
        option wps_pushbutton '1'

comment:2 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r38362, sorry about that

comment:3 Changed 4 years ago by hnyman <hannu.nyman@…>

Somebody should maybe stop the buildbot builds with this bug. For example, the popular ar71xx platform is currently being built with revision 38360. That will be the current snapshot build going to the weekend...

ar71xx, au1000, ep93xx, imx23 are the platforms being currently built with affected revisions. I am not sure about the role of ath9k in the other platforms, but ar71xx will affected in a major way.

There will probably be complaints about the endless reboot loop, if somebody installs those builds.

http://buildbot.openwrt.org:8010/grid

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.