Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14302 closed defect (obsolete)

make bfd.info fail

Reported by: ciusss89 Owned by: developers
Priority: normal Milestone:
Component: base system Version: Kamikaze 8.09
Keywords: unknown command `colophon' / `cygnus' Cc:

Description

My build platform setup:
Dual core machine with jessie/sid debian version, kernel 3.11-3.dmz.2-liquorix-amd64
gcc version 4.8.1 (Debian 4.8.1-10)

Compiling last atheros kamikaze revision make proce's stops on bfd.info.

make[8]: Entering directory `/mnt/data/OpenWrt_build/atheros/build_dir/toolchain-mips_gcc4.1.2/binutils-2.18/bfd/doc'
make[8]: `chew' is up to date.
make[8]: Leaving directory `/mnt/data/OpenWrt_build/atheros/build_dir/toolchain-mips_gcc4.1.2/binutils-2.18/bfd/doc'
./chew -f ../.././bfd/doc/doc.str <../.././bfd/doc/../targets.c >targets.tmp
/bin/bash ../.././bfd/doc/../../move-if-change targets.tmp targets.texi
restore=: && backupdir=".am$$" && \
        rm -rf $backupdir && mkdir $backupdir && \
        if (makeinfo --split-size=5000000 --split-size=5000000 --version) >/dev/null 2>&1; then \
          for f in bfd.info bfd.info-[0-9] bfd.info-[0-9][0-9] bfd.i[0-9] bfd.i[0-9][0-9]; do \
            if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \
          done; \
        else :; fi && \
        if makeinfo --split-size=5000000 --split-size=5000000   -I ../.././bfd/doc \
         -o bfd.info `test -f 'bfd.texinfo' || echo '../.././bfd/doc/'`bfd.texinfo; \
        then \
          rc=0; \
        else \
          rc=$?; \
          $restore $backupdir/* `echo "./bfd.info" | sed 's|[^/]*$||'`; \
        fi; \
        rm -rf $backupdir; exit $rc
bfd.texinfo:326: unknown command `colophon'
bfd.texinfo:337: unknown command `cygnus'
./elf.texi:11: raising the section level of @subsubsection which is too low
make[7]: *** [bfd.info] Error 1

See attachment with full log err

Attachments (2)

Full log (6.4 KB) - added by ciusss89 4 years ago.
Full err log
0101-binutils-no-docs.patch (401 bytes) - added by karlp@… 4 years ago.
tell binutils not to bother making documentation

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by ciusss89

Full err log

comment:1 follow-up: Changed 4 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed

this seems to be a very old and obsolete version. how about trying current trunk or 12.09?

comment:2 in reply to: ↑ 1 Changed 4 years ago by ciusss89

Hi,

Old devices with 16mb of ram have problem with recent revision of openwrt such us backfire or attitude adjustment 12.09.
For example (Fonera + )atheros 2315 with 16mb are unusable with last revision...

Giuseppe.

Replying to nbd:

this seems to be a very old and obsolete version. how about trying current trunk or 12.09?

comment:3 Changed 4 years ago by jow

Thats fine, but if you need to use old openwrt then use an old distro to build it! No one is going to fix issues in old buildroot releases which are typically caused by too new gnu utilities. Run a Debian 6 or even 5 in a VM and use that to compile Kamikaze.

Changed 4 years ago by karlp@…

tell binutils not to bother making documentation

comment:4 Changed 4 years ago by karlp@…

fwiw, the attached patch fixes this, using the same tactic as in /ticket/13039.html

(and yes, get a newer openwrt! I was tricked into building a gross hackjob of old and new openwrt and had to deal with this :(

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.