Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14263 closed defect (not_a_bug)

Seems changeset 38277 intruduce a compile dependency that break compile

Reported by: hunters Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,
after changeset 38277 to fix my issue with Intel Centrino Wireless-N 2230 cards the compile fail with this error:

install -d -m0755 /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/lib/firmware
install -m0644 /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/linux-firmware-6942dba419d2ebf8c15514972e89734fd7a8cebc/iwlwifi-2030-6.ucode /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/lib/firmware
find /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn -name 'CVS' -o -name '.svn' -o -name '.#*' -o -name '*~'| xargs -r rm -rf
Package kmod-iwlagn is missing dependencies for the following libraries:
mac80211.ko
make[3]: * /home/hunters/src/openwrt/trunk/bin/x86/packages/kmod-iwlagn_3.3.8+2013-06-27-1_x86.ipk Error 1
make[3]: Leaving directory `/home/hunters/src/openwrt/trunk/package/kernel/mac80211'
make[2]:
* [package/kernel/mac80211/compile] Error 2
make[2]: Leaving directory `/home/hunters/src/openwrt/trunk'
make[1]: * /home/hunters/src/openwrt/trunk/staging_dir/target-i386_i486_uClibc-0.9.33.2/stamp/.package_compile Error 2
make[1]: Leaving directory `/home/hunters/src/openwrt/trunk'
make:
* [world] Errore 2

I have correctly in .config:

CONFIG_PACKAGE_kmod-iwlagn=y
CONFIG_PACKAGE_kmod-mac80211=y

Thank you
Regards
Bye

Attachments (0)

Change History (6)

comment:1 follow-ups: Changed 4 years ago by nbd

I can't reproduce this. Please try

make defconfig
make package/mac80211/{clean,compile} V=s

comment:2 Changed 4 years ago by hunters

Down my comment

Last edited 4 years ago by hunters (previous) (diff)

comment:3 in reply to: ↑ 1 Changed 4 years ago by hunters

Replying to nbd:

I can't reproduce this. Please try

make defconfig
make package/mac80211/{clean,compile} V=s

Hi,

a strange think i didn't noticed before. During compile there is an error:

bash: dkl: command not found

The only reference to dkl i found is in include/kernel.mk
May be the problem is there but I tried removing the line with that command and the error still persist.

Anyway here is the result of the command you asked for:

mkdir -p /home/hunters/src/openwrt/trunk/bin/x86/packages /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/CONTROL /home/hunters/src/openwrt/trunk/staging_dir/target-i386_i486_uClibc-0.9.33.2/pkginfo
. /home/hunters/src/openwrt/trunk/include/shell.sh; export modules=; probe_module() { mods="$1"; boot="$2"; shift 2; for mod in $mods; do if [ -e /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/lib/modules/3.3.8/$mod.ko ]; then mkdir -p /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules.d; echo "$mod" >> /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules.d/iwlagn; fi; done; if [ -e /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules.d/iwlagn ]; then if [ "$boot" = "1" ]; then mkdir -p /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules-boot.d; ln -s ../modules.d/iwlagn /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules-boot.d/; fi; modules="${modules:+$modules}"; fi; }; add_module() { priority="$1"; mods="$2"; boot="$3"; shift 3; for mod in $mods; do if [ -e /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/lib/modules/3.3.8/$mod.ko ]; then mkdir -p /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules.d; echo "$mod" >> /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules.d/$priority-iwlagn; fi; done; if [ -e /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules.d/$priority-iwlagn ]; then if [ "$boot" = "1" ]; then mkdir -p /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules-boot.d; ln -s ../modules.d/$priority-iwlagn /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules-boot.d/; fi; modules="${modules:+$modules }$priority-iwlagn"; fi; }; probe_module "iwlwifi iwldvm" ""; if [ -n "$modules" ]; then mkdir -p /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/etc/modules.d; mkdir -p /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/CONTROL; echo "#!/bin/sh" > /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/CONTROL/postinst; echo "[ -z \"\$IPKG_INSTROOT\" ] || exit 0" >> /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/CONTROL/postinst; echo ". /lib/functions.sh" >> /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/CONTROL/postinst; echo "insert_modules $modules" >> /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/CONTROL/postinst; chmod 0755 /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/CONTROL/postinst; fi
install -d -m0755 /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/lib/firmware
install -m0644 /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/linux-firmware-6942dba419d2ebf8c15514972e89734fd7a8cebc/iwlwifi-2030-6.ucode /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn/lib/firmware
find /home/hunters/src/openwrt/trunk/build_dir/target-i386_i486_uClibc-0.9.33.2/linux-x86_kvm_guest/compat-wireless-2013-06-27/ipkg-x86/kmod-iwlagn -name 'CVS' -o -name '.svn' -o -name '.#*' -o -name '*~'| xargs -r rm -rf
Package kmod-iwlagn is missing dependencies for the following libraries:
mac80211.ko
make[2]: *** [/home/hunters/src/openwrt/trunk/bin/x86/packages/kmod-iwlagn_3.3.8+2013-06-27-1_x86.ipk] Error 1
make[2]: Leaving directory `/home/hunters/src/openwrt/trunk/package/kernel/mac80211'
make[1]: *** [package/kernel/mac80211/compile] Error 2
make[1]: Leaving directory `/home/hunters/src/openwrt/trunk'
make: *** [package/mac80211/compile] Errore 2

comment:4 in reply to: ↑ 1 Changed 4 years ago by hunters

Replying to nbd:

I can't reproduce this. Please try

make defconfig
make package/mac80211/{clean,compile} V=s

Seems it was a problem of some files being corrupted in the build environment... I deleted all the trunk and downloaded it again. Now it compile fine without error.
Sorry.
Thank you
Bye

comment:5 Changed 4 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.