Modify

Opened 4 years ago

Last modified 4 years ago

#14238 new defect

some wireless devices are unable to connect since upgrade to 12.09

Reported by: onlyjob Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Since upgrade to 12.09 some wireless devices lost ability to connect to AP. They simply unable to authenticate with correct WPA2 PSK (CCMP).
The affected system is x86/generic with the following PCI NIC:

Ethernet controller: Qualcomm Atheros AR2413/AR2414 Wireless Network Adapter [AR5005G(S) 802.11bg] (rev 01)

Some devices have no problems connecting to AP but "motorola Xoom" and the PC with USB "ID 0b05:1723 ASUSTek Computer, Inc. WL-167G v2 802.11g Adapter [Ralink RT2571W]" can't connect to wireless network at all. The following is logged by openwrt on every authentication attempt:

daemon.notice hostapd: wlan0: STA **:**:**:**:**:** IEEE 802.11: did not acknowledge authentication response

I'm aware of similar bugs #13966 and #14083 that were closed without explanation like if the problem were fixed but sadly it is still there: I tried 12.09/release, 12.09.01/trunk-r38033 and trunk-r38220 and all of them exhibit the same problem. I also tried to re-create AP configuration from scratch but it didn't help.
Reinstalling backfire-10.03.1 fixes the issue (no configuration change).

For the record at least three devices were not affected by upgrade and still can use wireless network without any problems whatsoever:

  • Android 4 based mobile phone (same OS version as Motorola Xoom that lost connectivity)
  • Nokia N900
  • Notebook with PCMCIA card "Qualcomm Atheros AR5212/AR5213 Wireless Network Adapter (rev 01)"

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by onlyjob

I think I found the culprit. I was trying to bisect the problem and got conflicting results e.g. non-working wireless clients (as described) with openwrt version that was working in the past.
Finally I found that setting Distance Optimization (under Network::Wifi:Wireless_network::Advanced_settings) to non empty value such as "10" or "40" reliably break connectivity of some wireless clients. The most confusing problem is that there is no way to fix it without completely turning off computer. Even if I restore Distance Optimization to empty value and re-flash new openwrt version the problem stays until computer switched off. Unfortunately it looks like I flashed new version of openwrt without turning off the power after playing with Distance Optimization parameter.
Hence I couldn't trust my own results any more so I ended up flashing 12.09/release "attitude adjustment" which is working well so far.
Please disregard this bug report. IMHO now it can be closed as invalid or re-titled into something like "unable to reset Distance Optimization". Thanks.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.