Modify

Opened 4 years ago

Last modified 4 years ago

#14219 new defect

Netgear WNDR3800 do not run from update 38120

Reported by: sqter@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: other Version: Trunk
Keywords: Cc:

Description

Bad generated image for NETGEAR WNDR3800. Older MAKE 38117 swapped version here "trunk/target/linux/ar71xx/image/Makefile" is working properly.

Sorry for my bad english

SqTER

Attachments (3)

kernel (61.7 KB) - added by sqter@… 4 years ago.
My kernel configuration
base_config (135.9 KB) - added by sqter 4 years ago.
Global config
diffconfig (16.6 KB) - added by sqter 4 years ago.
here is output of diffconfig.sh

Download all attachments as: .zip

Change History (13)

comment:1 Changed 4 years ago by anonymous

I built yesterday version 38192 successfully for WNDR3800. Flashed it and runs ok.

I suggest that you do "make clean" first and then rebuild.

comment:2 Changed 4 years ago by sqter@…

I always do a "make clean" and "make dirclean".
I tried yesterday, flashed it and device bricked. Only unbrick device by u-boot works
I will build tonight last source and write if it works or not.

greetings

SqTER

comment:3 Changed 4 years ago by hnyman <hannu.nyman@…>

I am currently running trunk version 38208 on my WNDR3800.

No problems except the effects of the broken ubox kmodloader/insmod affecting mounting FAT-based drives due to inability to load iso8859-1 code page. (see #14182 and #14189)

comment:4 Changed 4 years ago by anonymous

make clean / dirclean is not enough if the .config is outdated. In particular make sure that busybox rewadlink is enabled.

Changed 4 years ago by sqter@…

My kernel configuration

Changed 4 years ago by sqter

Global config

comment:5 Changed 4 years ago by sqter

I added my files to verify the configuration.

comment:6 follow-up: Changed 4 years ago by sqter

I built today version 38220 successfully for WNDR3800. Flashed it and don't work.
Power LED stay ON (orange) - router can't load OpenWrt system files.

comment:7 in reply to: ↑ 6 Changed 4 years ago by hnyman

Replying to sqter:

I built today version 38220 successfully for WNDR3800. Flashed it and don't work.
Power LED stay ON (orange) - router can't load OpenWrt system files.

I don't remember seeing a WNDR3700/3800 boot hang situation where the power LED remains on, so you might have stumbled into something new.

How do the LEDs behave during the boot process? How far into the boot does it progress?

You might try attaching a TTL serial cable to the connector inside the router and see the console log during the whole boot process.

Regarding configs, probably nobody will try to find anomalies in the full 130 kB .config file. More sensible info would be the output of ./scripts/diffconfig.sh

Changed 4 years ago by sqter

here is output of diffconfig.sh

comment:8 Changed 4 years ago by sqter

Unfortunately my router is still under warranty and don't wanna void it, so I can't really disassemble it to get to serial connector (don't have any cable for it anyway).

LED behaviour:
orange power comes on and stays on permanently, after a few secs switch flashes once. and that's it, power stays orange.

diff output in my previous post.

comment:9 Changed 4 years ago by nbd

try disabling the following options:

CONFIG_BUSYBOX_CONFIG_KLOGD
CONFIG_BUSYBOX_CONFIG_SYSLOGD
CONFIG_BUSYBOX_CONFIG_LOCALE_SUPPORT
CONFIG_BUSYBOX_CONFIG_WATCHDOG
CONFIG_PACKAGE_blkid
CONFIG_PACKAGE_swap-utils

then rebuild and see if it starts working again

comment:10 Changed 4 years ago by sqter

Not work

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.