Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14187 closed defect (not_a_bug)

tl-wr1041n can't use usb port on attitude adjustment 12.09

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Attitude Adjustment 12.09
Keywords: tl-wr1041n wr1041n usb Cc:

Description

firmware image from:

http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/openwrt-ar71xx-generic-tl-wr1041n-v2-squashfs-sysupgrade.bin

=========================================

use "lsusb":

root@OpenWrt:~# lsusb
unable to initialize libusb: -99

=========================================

Other Information:

directory "/proc/bus/usb/" is empty
i set pppoe to connect to the Internet, no other changes, is the default

=========================================

Kernel Log:

[ 0.000000] Linux version 3.3.8 (blogic@Debian-60-squeeze-64-minimal) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Sat Mar 23 16:49:30 UTC 2013
[ 0.000000] MyLoader: sysp=163c8a9a, boardp=8ae910a6, parts=5bede646
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 0001974c (MIPS 74Kc)
[ 0.000000] SoC: Atheros AR9342 rev 1
[ 0.000000] Clocks: CPU:560.000MHz, DDR:450.000MHz, AHB:225.000MHz, Ref:25.000MHz
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone PFN ranges:
[ 0.000000] Normal 0x00000000 -> 0x00004000
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] Early memory PFN ranges
[ 0.000000] 0: 0x00000000 -> 0x00004000
[ 0.000000] On node 0 totalpages: 16384
[ 0.000000] free_area_init_node: node 0, pgdat 802f1100, node_mem_map 81000000
[ 0.000000] Normal zone: 128 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 16256 pages, LIFO batch:3
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
[ 0.000000] Kernel command line: board=TL-WR1041N-v2 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 61488k/65536k available (2211k kernel code, 4048k reserved, 418k data, 212k init, 0k highmem)
[ 0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Calibrating delay loop... 278.93 BogoMIPS (lpj=1394688)
[ 0.070000] pid_max: default: 32768 minimum: 301
[ 0.070000] Mount-cache hash table entries: 512
[ 0.080000] NET: Registered protocol family 16
[ 0.080000] gpiochip_add: registered GPIOs 0 to 22 on device: ath79
[ 0.090000] MIPS: machine is TP-LINK TL-WR1041N v2
[ 0.300000] bio: create slab <bio-0> at 0
[ 0.310000] Switching to clocksource MIPS
[ 0.310000] NET: Registered protocol family 2
[ 0.320000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.320000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[ 0.330000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.330000] TCP: Hash tables configured (established 2048 bind 2048)
[ 0.340000] TCP reno registered
[ 0.340000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.350000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.350000] NET: Registered protocol family 1
[ 0.360000] PCI: CLS 0 bytes, default 32
[ 0.370000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.380000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.390000] msgmni has been set to 120
[ 0.390000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
[ 0.400000] io scheduler noop registered
[ 0.400000] io scheduler deadline registered (default)
[ 0.410000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.440000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[ 0.450000] console [ttyS0] enabled, bootconsole disabled
[ 0.460000] m25p80 spi0.0: found w25q128, expected m25p80
[ 0.470000] m25p80 spi0.0: w25q128 (16384 Kbytes)
[ 0.470000] 5 tp-link partitions found on MTD device spi0.0
[ 0.480000] Creating 5 MTD partitions on "spi0.0":
[ 0.480000] 0x000000000000-0x000000020000 : "u-boot"
[ 0.490000] 0x000000020000-0x000000109c90 : "kernel"
[ 0.490000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.510000] 0x000000109c90-0x000000ff0000 : "rootfs"
[ 0.510000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.530000] mtd: partition "rootfs" set to be root filesystem
[ 0.530000] mtd: partition "rootfs_data" created automatically, ofs=2E0000, len=D10000
[ 0.540000] 0x0000002e0000-0x000000ff0000 : "rootfs_data"
[ 0.550000] 0x000000ff0000-0x000001000000 : "art"
[ 0.560000] 0x000000020000-0x000000ff0000 : "firmware"
[ 0.580000] ag71xx_mdio: probed
[ 0.710000] ag71xx_mdio: probed
[ 0.720000] eth0: Atheros AG71xx at 0xb9000000, irq 4
[ 1.300000] eth0: Atheros AR8327 switch driver attached.
[ 2.440000] ag71xx ag71xx.0: eth0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd033, driver=Atheros AR8216/AR8236/AR8316]
[ 2.460000] TCP cubic registered
[ 2.460000] NET: Registered protocol family 17
[ 2.460000] Bridge firewalling registered
[ 2.470000] 8021q: 802.1Q VLAN Support v1.8
[ 2.480000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 2.480000] Freeing unused kernel memory: 212k freed
[ 4.100000] Registered led device: tp-link:green:system
[ 4.100000] Registered led device: tp-link:green:wps
[ 4.100000] Registered led device: tp-link:green:wlan
[ 5.440000] eth0: link up (1000Mbps/Full duplex)
[ 7.370000] JFFS2 notice: (495) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 10 of xref (0 dead, 0 orphan) found.
[ 7.540000] eth0: link down
[ 8.870000] Compat-drivers backport release: compat-drivers-2012-09-04-2-gddac993
[ 8.880000] Backport based on wireless-testing.git master-2012-09-07
[ 8.890000] compat.git: wireless-testing.git
[ 8.920000] cfg80211: Calling CRDA to update world regulatory domain
[ 8.920000] cfg80211: World regulatory domain updated:
[ 8.930000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 8.940000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 8.940000] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 8.950000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 8.960000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 8.970000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 9.230000] usbcore: registered new interface driver usbfs
[ 9.240000] usbcore: registered new interface driver hub
[ 9.250000] usbcore: registered new device driver usb
[ 9.680000] ath: EEPROM regdomain: 0x0
[ 9.680000] ath: EEPROM indicates default country code should be used
[ 9.680000] ath: doing EEPROM country->regdmn map search
[ 9.680000] ath: country maps to regdmn code: 0x3a
[ 9.680000] ath: Country alpha2 being used: US
[ 9.680000] ath: Regpair used: 0x3a
[ 9.690000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 9.690000] Registered led device: ath9k-phy0
[ 9.690000] ieee80211 phy0: Atheros AR9340 Rev:0 mem=0xb8100000, irq=47
[ 9.700000] cfg80211: Calling CRDA for country: US
[ 9.700000] cfg80211: Regulatory domain changed to country: US
[ 9.710000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 9.710000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 9.720000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 9.730000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 9.740000] cfg80211: (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 9.750000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 9.750000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 9.810000] PPP generic driver version 2.4.2
[ 10.000000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 10.170000] NET: Registered protocol family 24
[ 10.180000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 10.200000] nf_conntrack version 0.5.0 (964 buckets, 3856 max)
[ 10.390000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 13.520000] device eth0.1 entered promiscuous mode
[ 13.520000] device eth0 entered promiscuous mode
[ 13.750000] eth0: link up (1000Mbps/Full duplex)
[ 13.790000] br-lan: port 1(eth0.1) entered forwarding state
[ 13.790000] br-lan: port 1(eth0.1) entered forwarding state
[ 15.790000] br-lan: port 1(eth0.1) entered forwarding state

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 4 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

The TL-WR1041N has no USB port from factory. If you soldered one its up to you to modify the kernel accordingly. If your model is actually a TL-WR1043ND then you flashed the wrong image.

Either way, this does not seem to be an OpenWrt bug.

comment:2 in reply to: ↑ 1 Changed 4 years ago by anonymous

Replying to jow:

The TL-WR1041N has no USB port from factory. If you soldered one its up to you to modify the kernel accordingly. If your model is actually a TL-WR1043ND then you flashed the wrong image.

Either way, this does not seem to be an OpenWrt bug.

i soldered a USB port, can you please give me some suggestions about modify the kernel?

comment:3 Changed 4 years ago by anonymous

i find a 3rd-party compiled firmware from a china forum, poster side it's default attitude adjustment 12.09 just add USB support, but i can't guarantee

if you search this ticket from "wr1041n" and "usb", maybe this can help you:
http://www.right.com.cn/forum/forum.php?mod=viewthread&tid=123066
http://www.kuaipan.cn/file/id_221585952738502.htm

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.