Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14185 closed defect (fixed)

TP-Link MR3020 Couldn't set tty to PPP discipline: Invalid argument

Reported by: lth@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: 3G PPP Cc:

Description

Just build an image for the MR3020 and I am unable to make it work with a 3G USB Modem (Huawei E1750). The Modem works perfectly OK in a TP WR1043ND with OpenWRT build a few weeks back, but with the latest trunk it establish the 3G connection (using the chat script ending with CONNECT) but then fails with:

Couldn't set tty to PPP discipline: Invalid argument

I googled that error and most advice said to include PPP_ASYNC kernel module. But that module doesn't seem to exist any longer, and as I said - it works perfectly well in another router.

I have attached my config.

Attachments (1)

config.mr3020 (2.2 KB) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by anonymous

comment:1 Changed 4 years ago by lth@…

The relevant part of the log reads:

Thu Sep 19 01:05:25 2013 local2.info chat[2257]: ATD*99***1#^M^M
Thu Sep 19 01:05:25 2013 local2.info chat[2257]: CONNECT
Thu Sep 19 01:05:25 2013 local2.info chat[2257]:  -- got it
Thu Sep 19 01:05:25 2013 local2.info chat[2257]: send ( ^M)
Thu Sep 19 01:05:25 2013 daemon.info pppd[2255]: Serial connection established.
Thu Sep 19 01:05:25 2013 daemon.err pppd[2255]: Couldn't set tty to PPP discipline: Invalid argument
Thu Sep 19 01:05:26 2013 daemon.info pppd[2255]: Exit.
Thu Sep 19 01:05:26 2013 daemon.notice netifd: Interface '3g' is now down

comment:2 Changed 4 years ago by lth@…

The config above is a diff only generated with scripts/diffconfig.sh. For some reason the system wouldn't allow me to upload complete config (said it was spam).

comment:3 Changed 4 years ago by lbthomsen

I was digging into this a bit deeper and actually the problem is ppp_async is not loaded. Comparing latest built with that of a few weeks back it seems that the file

/etc/modules.d/30-ppp

does not exist any longer and that is why the module is not loaded. Recreating this file solves the problem.

comment:4 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in r38055

comment:5 Changed 4 years ago by lbthomsen

I can confirm it's working now. That was quick - thanx!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.