Modify

Opened 4 years ago

Last modified 4 years ago

#14142 new defect

Luci wifi page don,t support chinese SSID

Reported by: k25c2yf Owned by:
Priority: normal Milestone: Attitude Adjustment 12.09.1
Component: luci Version: Attitude Adjustment 12.09
Keywords: chinese ssid Cc:

Description

/etc/config/wireless

config wifi-iface

option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid '梁振英正仆街'
option encryption 'psk2+ccmp'
option key '123456'


http://192.168.1.1/cgi-bin/luci/;stok=7306378b93cea8da018443d59561fd74/admin/network/wireless/

This page contains the following errors:
error on line 122 at column 13: Encoding error
Below is a rendering of the page up to the first error.
<a href="/cgi-bin/luci/;stok=7306378b93cea8da018443d59561fd74/admin/network/wireless/radio1.network1/">radio1: Master &#34;￿箶￿￿￿￿￿￿￿&#34;</a>


Attachments (3)

wireless (1.1 KB) - added by k25c2yf 4 years ago.
chinese.jpg (49.9 KB) - added by k25c2yf 4 years ago.
error.jpg (115.0 KB) - added by k25c2yf 4 years ago.
luci error

Download all attachments as: .zip

Change History (12)

Changed 4 years ago by k25c2yf

Changed 4 years ago by k25c2yf

comment:1 follow-up: Changed 4 years ago by wiqiu@…

笨蛋,用英语

comment:2 in reply to: ↑ 1 ; follow-up: Changed 4 years ago by anonymous

Replying to wiqiu@…:

笨蛋,用英语

openwrt 不是中国软件

comment:3 in reply to: ↑ 2 Changed 4 years ago by k25c2yf

Replying to anonymous:

Replying to wiqiu@…:

笨蛋,用英语

openwrt 不是中国软件

openwrt本來就支持多國語言SSID,只不過是LUCI設計問題

Last edited 4 years ago by k25c2yf (previous) (diff)

comment:4 follow-up: Changed 4 years ago by jow

I cannot reproduce the issue on current Trunk / LuCI. How did you enter the SSID, with "uci set", the "vi" editor or through the gui? Was it copy-pasted from somewhere else?

root@uplink:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr 'c0:3f:0e:7a:a0:94'
	option hwmode '11ng'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '27'
	option country 'US'
	option channel '13'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid '梁振英正仆街'
	option encryption 'psk2'
	option key '...'
	option network 'lan'
	option wds '1'

root@uplink:~# wifi
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr c0:3f:0e:7a:a0:94 and ssid "\xe6\xa2\x81\xe6\x8c\xaf\xe8\x8b\xb1\xe6\xad\xa3\xe4\xbb\x86\xe8\xa1\x97"
Configuration file: /var/run/hostapd-phy1.conf
Using interface wlan1 with hwaddr c0:3f:0e:7a:a0:96 and ssid "Funkueberwachungswagen 5"
root@uplink:~# iwinfo wlan0 i
wlan0     ESSID: "梁振英正仆街"
          Access Point: C0:3F:0E:7A:A0:94
          Mode: Master  Channel: 13 (2.472 GHz)
          Tx-Power: 27 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -95 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 168C:0029 168C:A095 [Atheros AR9223]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0
root@uplink:~# 

http://luci.subsignal.org/~jow/ssid-chinese.png

comment:5 in reply to: ↑ 4 Changed 4 years ago by anonymous

Replying to jow:

I cannot reproduce the issue on current Trunk / LuCI. How did you enter the SSID, with "uci set", the "vi" editor or through the gui? Was it copy-pasted from somewhere else?

root@uplink:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr 'c0:3f:0e:7a:a0:94'
	option hwmode '11ng'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '27'
	option country 'US'
	option channel '13'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid '梁振英正仆街'
	option encryption 'psk2'
	option key '...'
	option network 'lan'
	option wds '1'

root@uplink:~# wifi
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr c0:3f:0e:7a:a0:94 and ssid "\xe6\xa2\x81\xe6\x8c\xaf\xe8\x8b\xb1\xe6\xad\xa3\xe4\xbb\x86\xe8\xa1\x97"
Configuration file: /var/run/hostapd-phy1.conf
Using interface wlan1 with hwaddr c0:3f:0e:7a:a0:96 and ssid "Funkueberwachungswagen 5"
root@uplink:~# iwinfo wlan0 i
wlan0     ESSID: "梁振英正仆街"
          Access Point: C0:3F:0E:7A:A0:94
          Mode: Master  Channel: 13 (2.472 GHz)
          Tx-Power: 27 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -95 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 168C:0029 168C:A095 [Atheros AR9223]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0
root@uplink:~# 

http://luci.subsignal.org/~jow/ssid-chinese.png

"WinSCP" edit the file

comment:6 follow-up: Changed 4 years ago by jow

Ok, please run "uci get wireless.@wifi-iface[1].ssid | hexdump -C" and post the output here.

Changed 4 years ago by k25c2yf

luci error

comment:7 Changed 4 years ago by k25c2yf

OpenWrt Attitude Adjustment 12.09

chinese ssid:梁振英正仆街
https://dev.openwrt.org/attachment/ticket/14142/error.jpg

Last edited 4 years ago by k25c2yf (previous) (diff)

comment:8 in reply to: ↑ 6 Changed 4 years ago by k25c2yf

Replying to jow:

Ok, please run "uci get wireless.@wifi-iface[1].ssid | hexdump -C" and post the output here.

root@OpenWrt:~# uci get wireless.@wifi-iface[1].ssid | hexdump -C
00000000 b1 e7 ae b6 ad 5e a5 bf a4 b2 b5 f3 0a |............|
0000000d

comment:9 Changed 4 years ago by jow

So this is the problem then. WinSCP did not save the file in UTF-8 format. If you set the SSID through the gui you browser will send "梁振英正仆街" as proper UTF-8 sequence which should be "e6 a2 81 e6 8c af e8 8b b1 e6 ad a3 e4 bb 86 e8 a1 97".

There are two options to resolve this:

1) edit the wireless config with WinSCP again and set the SSID to some simple ascii name like "test", then use LuCI to set the chinese SSID

or

2) See if WinSCP supports saving files in different encodings, make sure the wireless config is stored in UTF-8.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.