Modify

Opened 4 years ago

Last modified 2 years ago

#14120 reopened defect

ar8316 lan-to-lan routing performance is horribly slow

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Attitude Adjustment 12.09
Keywords: Cc:

Description

For some reason, on Buffalo WZR-HP-AG300H (and also 600DHP, tested both) routed traffic between e.g. eth0.1 and eth0.2 (given switch config which is fully routed, that is, each port is untagged on own vlan + CPU is tagged for that vlan) is _very_ slow (~100mbps with MTU sized frames). wan-lan routing works reasonably fast, although there's interesting speed difference there too between trunk and aa1209 (performance regression with later Linux kernels?).

http://www.employees.org/~mstenber/buffalo-performance.pdf

/etc/config (relevant pieces):

config interface 'wan'

option ifname 'eth1'
option _orig_ifname 'eth1'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '192.168.0.1'
option netmask '255.255.255.0'

config switch

option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'eth0'
option vlan '1'
option vid '1'
option ports '0t 1'

config switch_vlan

option device 'eth0'
option vlan '2'
option vid '2'
option ports '0t 2'

config interface 'lan1'

option proto 'static'
option ifname 'eth0.1'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'lan2'

option proto 'static'
option ifname 'eth0.2'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'

Attachments (0)

Change History (17)

comment:1 Changed 4 years ago by Markus Stenberg

As added data point, same problem also applies to Netgear's WNDR3800 (at least too).

within same switch, routed port
64MBit/s IPv4
140MBit/s IPv6

switch -> ext1
680 MBit/s IPv4
253 MBit/s IPv6

comment:2 Changed 4 years ago by BenFranske

Even though you are describing routing performance problems it is possible this may be related to some poor switching performance problems that I've seen in trunk as well. Take a look at my post in the forums: https://forum.openwrt.org/viewtopic.php?id=46561 for more information. If a dev who looks into this thinks they are separate problems please open a second ticket for the switching problems as that is also an issue.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:4 Changed 3 years ago by anonymous

I performed same test with my production config on AA and BB; in BB, the performance switch -> switch port is fine. May close with BB.

-Markus

comment:5 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 3 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

i have installed BB on a WNDR3800 - switch to switch within a vlan (so eth0.1 -> eth0.1 ) is slow as hell (1Mbit max). currently doing a test transfer at 380kiB/s.
If BB is reboted, a disconnect occurs, but then the speed jumps up to 80MiB/s, to drop back the second bootup is complete.
now this is a rtl8366s switch, but given the previous mention by Markus Stenberg.

comment:7 Changed 2 years ago by th200x@…

Slow as hell.

OpenWrt latest Build (this is today: openwrt-15.05-ar71xx-generic-tl-wr1043nd-v2-squashfs-sysupgrade)

PC<=>LAN-Cable<=>WR1043ND on WAN Interface

ethtool eth3 on PC:
Settings for eth3:

Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full

100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full

[cut]
=>>>>>>> Speed: 1000Mb/s

Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on



ethtool eth0 on OpenWrt WR1043ND-V2 TPLink Router:
Settings for eth0:
=>>>>>> Supported ports: [ ]

Supported link modes: 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: No
Advertised link modes: 1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: No

=>>>>>> Speed: 1000Mb/s

Duplex: Full
Port: MII
PHYAD: 0
Transceiver: external
Auto-negotiation: on
Current message level: 0x000000ff (255)

drv probe link timer ifdown ifup rx_err tx_err

Link detected: yes

Looks Nice, but (FYI: OpenWrt WAN IP = 10.10.10.8, PC (Debian) IP = 10.10.10.10) iperf -s on openwrt,
iperf -c 10.10.10.8 on Debian gives me a horrible Perfomance:

iperf -c 10.10.10.8


Client connecting to 10.10.10.8, TCP port 5001
TCP window size: 21.0 KByte (default)


[ 3] local 10.10.10.10 port 49600 connected with 10.10.10.8 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-11.1 sec 1.38 MBytes 1.03 Mbits/sec

again: iperf -c 10.10.10.8


Client connecting to 10.10.10.8, TCP port 5001
TCP window size: 21.0 KByte (default)


[ 3] local 10.10.10.10 port 49601 connected with 10.10.10.8 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-10.8 sec 896 KBytes 682 Kbits/sec

again: iperf -c 10.10.10.8


Client connecting to 10.10.10.8, TCP port 5001
TCP window size: 21.0 KByte (default)


[ 3] local 10.10.10.10 port 49602 connected with 10.10.10.8 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-13.7 sec 896 KBytes 537 Kbits/sec

Slow slow slow Transfer, on the WAN-Port! The Cable is ok. (only 4 Testing a 30cm Cable, tested under other hardware, the cable is ok)

What the hell is here wrong?

comment:8 Changed 2 years ago by jow

Did you run the iperf server *on* openwrt? If yes please repeat the tests with both iperf server and client being on pcs or laptops outside of the router itself, otherwise the speed test is cpu bound.

Last edited 2 years ago by jow (previous) (diff)

comment:9 Changed 2 years ago by th200x@…

Ty for Information.

Yes, iperf runs as server on openwrt. i made it the other way, and the results are very very slower...

iperf as server on the PC , and iperf on openwrt as client, over the WAN-Cable...

iperf -c 10.10.10.10


Client connecting to 10.10.10.10, TCP port 5001
TCP window size: 43.8 KByte (default)


[ 3] local 10.10.10.8 port 37364 connected with 10.10.10.10 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-18.2 sec 512 KBytes 231 Kbits/sec

And now....

iperf as server on the openwrt, and iperf as client on my Handy (Android, Lollipop)


Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)


[ 4] local 10.0.8.3 port 5001 connected with 10.0.8.9 port 56145
[ ID] Interval Transfer Bandwidth
[ 4] 0.0-10.1 sec 37.5 MBytes 31.1 Mbits/sec

I do not understand this Perfomance. When i make the iperf test (server on openwrt) and take my handy (android,lollipop) as client i reach 30 MBit! Faster as my 1gb/s WAN Port. What?

comment:10 Changed 2 years ago by jow

I mean do not run iperf on openwrt at all, neither as server nor as client. It will always be horribly slow as the process is cpu bound when copying test data to the socket.

comment:11 Changed 2 years ago by anonymous

no, jow. its slow too in all ways.

iperf as server on pc, iperf as client on android brings me the same horror slow transfer rates.

(~500 kb/s)

when i made a simple file-transfer between pc <> handy over ftp, i got a poor perfomance with openwrt. so i search the error, and ended on the switch from tp-link with the firmware openwrt....

with the original firmware from tplink, i have never this problem....

should i switch back to the original firmware?

comment:12 Changed 2 years ago by jow

If the performance is indeed so horrible then by all means yes :)

comment:13 Changed 2 years ago by anonymous

i´m ready with my flash to the original firmware. full speed in all directions. why openwrt can not do this? ok, u can close this bug. its fixed 4 me.

comment:14 Changed 2 years ago by anonymous

horrible slow performance on TL-WR1043ND and latest released openwrt version

two computers connected on lan
iperf3 between the two computers (iperf3 -s on computer1 and iperf3 -c IP_OFCOMP1 on computer 2)

with latest tp-link firmware: between 930 and 994 Mbit
with latest openwrt version: varies between 123 and 319 Mbit

please let me know what else information do you need besides dmesg. let me know what files from backup do you need. backup-OpenWrt-2016-01-04.tar.gz

root@OpenWrt:~# dmesg
[ 0.000000] Linux version 3.18.20 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46450) ) #1 Fri Sep 4 21:55:57 CEST 2015
[ 0.000000] MyLoader: sysp=2ababaaa, boardp=a2aa28a8, parts=aa20aaaa
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[ 0.000000] SoC: Atheros AR9132 rev 2
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 02000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x01ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x01ffffff]
[ 0.000000] Initmem setup node 0 [mem 0x00000000-0x01ffffff]
[ 0.000000] On node 0 totalpages: 8192
[ 0.000000] free_area_init_node: node 0, pgdat 8034e2b0, node_mem_map 81000000
[ 0.000000] Normal zone: 64 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 8192 pages, LIFO batch:0
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 8128
[ 0.000000] Kernel command line: board=TL-WR1043ND console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 28516K/32768K available (2621K kernel code, 129K rwdata, 344K rodata, 224K init, 194K bss, 4252K reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:5.000MHz
[ 0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.090000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.100000] NET: Registered protocol family 16
[ 0.100000] MIPS: machine is TP-LINK TL-WR1043ND
[ 0.390000] Switched to clocksource MIPS
[ 0.390000] NET: Registered protocol family 2
[ 0.400000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.400000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.410000] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.420000] TCP: reno registered
[ 0.420000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.420000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.430000] NET: Registered protocol family 1
[ 0.440000] PCI: CLS 0 bytes, default 32
[ 0.440000] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.450000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.460000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.470000] msgmni has been set to 55
[ 0.470000] io scheduler noop registered
[ 0.480000] io scheduler deadline registered (default)
[ 0.480000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.490000] console [ttyS0] disabled
[ 0.520000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 12500000) is a 16550A
[ 0.520000] console [ttyS0] enabled
[ 0.530000] bootconsole [early0] disabled
[ 0.540000] m25p80 spi0.0: found s25sl064p, expected m25p80
[ 0.550000] m25p80 spi0.0: s25sl064p (8192 Kbytes)
[ 0.570000] 5 tp-link partitions found on MTD device spi0.0
[ 0.570000] Creating 5 MTD partitions on "spi0.0":
[ 0.580000] 0x000000000000-0x000000020000 : "u-boot"
[ 0.580000] 0x000000020000-0x00000012e400 : "kernel"
[ 0.590000] 0x00000012e400-0x0000007f0000 : "rootfs"
[ 0.590000] mtd: device 2 (rootfs) set to be root filesystem
[ 0.600000] 1 squashfs-split partitions found on MTD device rootfs
[ 0.610000] 0x000000360000-0x0000007f0000 : "rootfs_data"
[ 0.620000] 0x0000007f0000-0x000000800000 : "art"
[ 0.620000] 0x000000020000-0x0000007f0000 : "firmware"
[ 0.630000] Realtek RTL8366RB ethernet switch driver version 0.2.4
[ 0.750000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
[ 0.750000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[ 0.940000] libphy: rtl8366rb: probed
[ 1.260000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RGMII
[ 1.260000] TCP: cubic registered
[ 1.270000] NET: Registered protocol family 17
[ 1.270000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[ 1.290000] Bridge firewalling registered
[ 1.290000] 8021q: 802.1Q VLAN Support v1.8
[ 1.300000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 1.310000] Freeing unused kernel memory: 224K (80368000 - 803a0000)
[ 2.590000] init: Console is alive
[ 2.590000] init: - watchdog -
[ 4.170000] usbcore: registered new interface driver usbfs
[ 4.180000] usbcore: registered new interface driver hub
[ 4.180000] usbcore: registered new device driver usb
[ 4.190000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 4.200000] ehci-platform: EHCI generic platform driver
[ 4.210000] ehci-platform ehci-platform: EHCI Host Controller
[ 4.210000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 4.220000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 4.250000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 4.250000] hub 1-0:1.0: USB hub found
[ 4.260000] hub 1-0:1.0: 1 port detected
[ 4.670000] init: - preinit -
[ 5.430000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[ 5.430000] eth0: link up (1000Mbps/Full duplex)
[ 5.470000] random: procd urandom read with 8 bits of entropy available
[ 8.700000] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
[ 8.740000] eth0: link down
[ 8.750000] procd: - early -
[ 8.760000] procd: - watchdog -
[ 9.540000] procd: - ubus -
[ 10.560000] procd: - init -
[ 11.520000] NET: Registered protocol family 10
[ 11.530000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 11.550000] Loading modules backported from Linux version master-2015-03-09-0-g141f155
[ 11.550000] Backport generated by backports.git backports-20150129-0-gdd4a670
[ 11.570000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 11.580000] nf_conntrack version 0.5.0 (449 buckets, 1796 max)
[ 11.630000] xt_time: kernel timezone is -0000
[ 11.660000] cfg80211: Calling CRDA to update world regulatory domain
[ 11.660000] cfg80211: World regulatory domain updated:
[ 11.670000] cfg80211: DFS Master region: unset
[ 11.670000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 11.680000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.690000] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.700000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.710000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.710000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 11.720000] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 11.730000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.740000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 11.830000] PPP generic driver version 2.4.2
[ 11.840000] NET: Registered protocol family 24
[ 11.910000] ath: EEPROM regdomain: 0x0
[ 11.910000] ath: EEPROM indicates default country code should be used
[ 11.910000] ath: doing EEPROM country->regdmn map search
[ 11.910000] ath: country maps to regdmn code: 0x3a
[ 11.910000] ath: Country alpha2 being used: US
[ 11.910000] ath: Regpair used: 0x3a
[ 11.930000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 11.930000] ieee80211 phy0: Atheros AR9100 MAC/BB Rev:7 AR2133 RF Rev:a2 mem=0xb80c0000, irq=2
[ 11.950000] cfg80211: Calling CRDA for country: US
[ 11.960000] cfg80211: Regulatory domain changed to country: US
[ 11.960000] cfg80211: DFS Master region: FCC
[ 11.970000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 11.980000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[ 11.990000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 1700 mBm), (N/A)
[ 12.000000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2300 mBm), (0 s)
[ 12.000000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[ 12.010000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[ 22.260000] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[ 22.260000] jffs2_build_filesystem(): unlocking the mtd device... done.
[ 22.270000] jffs2_build_filesystem(): erasing all blocks after the end marker...
[ 25.670000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[ 25.690000] eth0: link up (1000Mbps/Full duplex)
[ 25.710000] device eth0.1 entered promiscuous mode
[ 25.710000] device eth0 entered promiscuous mode
[ 25.760000] br-lan: port 1(eth0.1) entered forwarding state
[ 25.760000] br-lan: port 1(eth0.1) entered forwarding state
[ 27.760000] br-lan: port 1(eth0.1) entered forwarding state
[ 38.710000] random: nonblocking pool is initialized
[ 46.620000] done.
[ 46.620000] jffs2: notice: (981) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 787.630000] br-lan: port 1(eth0.1) entered disabled state
[ 787.660000] device eth0.1 left promiscuous mode
[ 787.660000] device eth0 left promiscuous mode
[ 787.660000] br-lan: port 1(eth0.1) entered disabled state
[ 787.690000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[ 787.690000] eth0: link down
[ 787.730000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[ 787.730000] eth0: link up (1000Mbps/Full duplex)
[ 787.740000] device eth0.1 entered promiscuous mode
[ 787.750000] device eth0 entered promiscuous mode
[ 787.780000] br-lan: port 1(eth0.1) entered forwarding state
[ 787.780000] br-lan: port 1(eth0.1) entered forwarding state
[ 789.780000] br-lan: port 1(eth0.1) entered forwarding state
[ 907.830000] br-lan: port 1(eth0.1) entered disabled state
[ 907.860000] device eth0.1 left promiscuous mode
[ 907.860000] device eth0 left promiscuous mode
[ 907.860000] br-lan: port 1(eth0.1) entered disabled state
[ 907.890000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[ 907.890000] eth0: link down
[ 907.930000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[ 907.930000] eth0: link up (1000Mbps/Full duplex)
[ 907.940000] device eth0.1 entered promiscuous mode
[ 907.950000] device eth0 entered promiscuous mode
[ 907.980000] br-lan: port 1(eth0.1) entered forwarding state
[ 907.980000] br-lan: port 1(eth0.1) entered forwarding state
[ 909.980000] br-lan: port 1(eth0.1) entered forwarding state
[ 1090.150000] cfg80211: Calling CRDA for country: RO
[ 1090.150000] cfg80211: Regulatory domain changed to country: RO
[ 1090.160000] cfg80211: DFS Master region: ETSI
[ 1090.160000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 1090.170000] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 1090.180000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 1090.190000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 1090.200000] cfg80211: (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s)
[ 1090.210000] cfg80211: (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[ 1091.980000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1092.020000] device wlan0 entered promiscuous mode
[ 1093.710000] br-lan: port 2(wlan0) entered forwarding state
[ 1093.720000] br-lan: port 2(wlan0) entered forwarding state
[ 1093.720000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1095.720000] br-lan: port 2(wlan0) entered forwarding state
[ 1126.640000] device wlan0 left promiscuous mode
[ 1126.640000] br-lan: port 2(wlan0) entered disabled state
[ 1128.350000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1128.400000] device wlan0 entered promiscuous mode
[ 1131.770000] br-lan: port 2(wlan0) entered forwarding state
[ 1131.780000] br-lan: port 2(wlan0) entered forwarding state
[ 1131.780000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1133.780000] br-lan: port 2(wlan0) entered forwarding state
[ 1483.930000] device wlan0 left promiscuous mode
[ 1483.930000] br-lan: port 2(wlan0) entered disabled state
[ 1485.490000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1485.600000] device wlan0 entered promiscuous mode
[ 1489.130000] br-lan: port 2(wlan0) entered forwarding state
[ 1489.130000] br-lan: port 2(wlan0) entered forwarding state
[ 1489.140000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1491.130000] br-lan: port 2(wlan0) entered forwarding state
[ 9069.840000] device wlan0 left promiscuous mode
[ 9069.840000] br-lan: port 2(wlan0) entered disabled state
[ 9071.550000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 9071.610000] device wlan0 entered promiscuous mode
[ 9074.350000] br-lan: port 2(wlan0) entered forwarding state
[ 9074.350000] br-lan: port 2(wlan0) entered forwarding state
[ 9074.360000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 9076.350000] br-lan: port 2(wlan0) entered forwarding state
[ 9145.730000] device wlan0 left promiscuous mode
[ 9145.730000] br-lan: port 2(wlan0) entered disabled state
[ 9147.440000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 9147.510000] device wlan0 entered promiscuous mode
[ 9150.040000] br-lan: port 2(wlan0) entered forwarding state
[ 9150.050000] br-lan: port 2(wlan0) entered forwarding state
[ 9150.050000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 9152.050000] br-lan: port 2(wlan0) entered forwarding state

comment:15 Changed 2 years ago by anonymous

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

option ula_prefix 'fdd7:fee9:7dd8::/48'

config interface 'lan'

option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ip6assign '60'
option ipaddr '192.168.3.2'
option mtu '9000'
option netmask '255.255.255.192'

config interface 'wan'

option ifname 'eth0.2'
option proto 'dhcp'

config interface 'wan6'

option ifname 'eth0.2'
option proto 'dhcpv6'

config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'
option mirror_source_port '0'
option mirror_monitor_port '0'
option enable_vlan4k '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option ports '1 2 3 4 5t'

config switch_vlan

option device 'switch0'
option vlan '2'
option ports '0 5t'

comment:16 Changed 2 years ago by anonymous

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'
option hwmode '11g'
option path 'platform/ath9k'
option country 'RO'
option htmode 'HT40'
option channel '6'
option txpower '0'

config wifi-iface

option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'psk-mixed'
option key 'mywifipass'
option ssid 'myssid'

comment:17 Changed 2 years ago by anonymous

ok, so I followed this guide to disable vlan (I only needed AP functionality) https://techbl.org/?p=131 and the speed is back to 830 Mbit.
Not as much as original firmware but more tolerable.
Any way to bring it back to 930Mbit?

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.