Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14074 closed defect (not_a_bug)

No br-lan when wifi disabled

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: br-lan remote connection Cc:

Description

Compile OpenWrt for bcm63xx
then connect eth0 to my box and get 192.168.0.190 ip
then ifconfig show

root@OpenWrt:/# ifconfig
eth0 Link encap:Ethernet HWaddr 2D:72:20:1f:22:20

inet addr:192.168.0.190 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3760 (3.6 KiB) TX bytes:4379 (4.2 KiB)
Interrupt:16

eth1 Link encap:Ethernet HWaddr 2D:72:20:1f:22:21

UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:15

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:144 errors:0 dropped:0 overruns:0 frame:0
TX packets:144 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11808 (11.5 KiB) TX bytes:11808 (11.5 KiB)

Also no way to connect remote telnet either with firewall off, only local telnet work

root@OpenWrt:/# netstat -apn
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 668/uhttpd
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 705/dropbear
tcp 0 0 0.0.0.0:23 0.0.0.0:* LISTEN 660/telnetd
netstat: /proc/net/tcp6: No such file or directory
netstat: /proc/net/udp6: No such file or directory
netstat: /proc/net/raw6: No such file or directory
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags Type State I-Node PID/Program name Path
unix 5 [ ] DGRAM 527 489/syslogd /dev/log
unix 2 [ ACC ] STREAM LISTENING 655 504/ubusd /var/run/ubus.sock
unix 2 [ ] DGRAM 1020 705/dropbear
unix 2 [ ] DGRAM 770 508/netifd
unix 2 [ ] DGRAM 761 508/netifd
unix 3 [ ] STREAM CONNECTED 759 504/ubusd /var/run/ubus.sock
unix 3 [ ] STREAM CONNECTED 758 508/netifd
unix 2 [ ] DGRAM 535 491/klogd

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by anonymous

network config file :

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'

option ifname 'eth1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'wan'

option ifname 'eth0'
option proto 'dhcp'

comment:2 Changed 4 years ago by anonymous

You can close ticket, issue is bad config

comment:3 Changed 4 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.