Modify

Opened 4 years ago

Closed 2 years ago

#14035 closed defect (fixed)

transmit queue 0 timed out

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Hello community.

Have PC connected by cable to router (LAN interface) and phone throw WiFi. (WLAN)
Reinstall WIN7 to WIN8 and now i have every half hour LAN interface disconnection/crash.
After that PC can't reconnect to router at all.
I can connect to router throw my phone (to LUCI) and push Connect on LAN interface - at that moment PC momently connect back to router.
Have: OpenWrt Barrier Breaker r37568 / LuCI Trunk (svn-r9869)
At kernel log i see error message and repeating "spam" about interface up/down every half second.

More of that may be last half year in any last build i has the same problem with WIN7 every time i close torrent. The same solution - push Connect on interface throw my phone. There no precise Error in logs, like in WIN8, only repeating of "spam" part.

The log is:

[ 5913.010000] ------------[ cut here ]------------
[ 5913.010000] WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0x180/0x288()
[ 5913.020000] NETDEV WATCHDOG: eth0 (ag71xx): transmit queue 0 timed out
[ 5913.020000] Modules linked in: ledtrig_usbdev ledtrig_netdev ip6t_REJECT ip6t_rt ip6t_hbh ip6t_mh ip6t_ipv6header ip6t_frag ip6t_eui64 ip6t_ah ip6table_raw ip6table_mangle ip6table_filter ip6_tables nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_irc nf_nat_ftp nf_conntrack_irc nf_conntrack_ftp xt_REDIRECT ipt_MASQUERADE iptable_nat xt_nat nf_nat_ipv4 nf_nat pppoe xt_conntrack xt_CT iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppox xt_mark xt_time ipt_REJECT xt_TCPMSS xt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k ath9k_common ath9k_hw ath mac80211 crc_ccitt ipv6 cfg80211 compat arc4 crypto_blkcipher aead leds_gpio ohci_hcd ledtrig_timer ledtrig_default_on ehci_platform ehci_hcd gpio_button_hotplug usbcore usb_common nls_base crypto_hash
[ 5913.100000] CPU: 0 PID: 0 Comm: swapper Not tainted 3.10.3 #1
[ 5913.110000] Stack : 00000006 00000000 00000000 00000000 00000000 00000000 80392a96 00000031
[ 5913.110000] 80323658 802d2c50 80372a0c 803233db 00000000 80394510 00200200 80390000
[ 5913.110000] 00200000 800793ac 00000003 80076dec 00000000 00000000 802d454c 8031dc7c
[ 5913.110000] 0031dc7c 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[ 5913.110000] 00000000 00000000 00000000 00000000 00000000 00000000 00000000 8031dc08
[ 5913.110000] ...
[ 5913.140000] Call Trace:
[ 5913.140000] [<8006df68>] show_stack+0x48/0x70
[ 5913.150000] [<80076ee8>] warn_slowpath_common+0x78/0xa8
[ 5913.150000] [<80076fa0>] warn_slowpath_fmt+0x2c/0x38
[ 5913.160000] [<8021bd3c>] dev_watchdog+0x180/0x288
[ 5913.160000] [<80082b2c>] call_timer_fn.isra.33+0x24/0x88
[ 5913.170000] [<80082d00>] run_timer_softirq+0x170/0x1cc
[ 5913.170000] [<8007dc28>] do_softirq+0xc8/0x1b4
[ 5913.180000] [<8007e000>] irq_exit+0x54/0x70
[ 5913.180000] [<8006082c>] ret_from_irq+0x0/0x4
[ 5913.190000] [<80060a60>]
r4k_wait+0x20/0x40
[ 5913.190000] [<8009ed70>] cpu_startup_entry+0xa0/0x108
[ 5913.200000] [<8033a908>] start_kernel+0x380/0x3a0
[ 5913.200000]
[ 5913.200000] ---[ end trace 2e47adab88a270cd ]---
[ 5913.210000] eth0: tx timeout
--here begin repeating part--
[ 5913.210000] eth0: link down
[ 5913.220000] br-lan: port 1(eth0) entered disabled state
[ 5913.430000] eth0: link up (1000Mbps/Full duplex)
[ 5913.430000] br-lan: port 1(eth0) entered forwarding state
[ 5913.440000] br-lan: port 1(eth0) entered forwarding state
[ 5915.440000] br-lan: port 1(eth0) entered forwarding state
[ 5915.600000] eth0: link down
--here repeating part end--

repeated part go in unstoppable list until i push connect in LUCI, before that LAN interface don't work, after that SPAM stop and interface is alive.
Can i provide some more information from SSH? Just don't know what i can see more for you information...

Attachments (1)

keepalive.7z (766 bytes) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 4 years ago by anonymous

forget to point my hardware - TP-Link TL-WR841N/ND v5

comment:2 Changed 4 years ago by anonymous

I have this issue now.
Router Model TP-Link TL-WR841N/ND v5
Firmware Version OpenWrt Attitude Adjustment 12.09 / LuCI 0.11.1 Release (0.11.1)
Kernel Version 3.3.8

I see similar problems all around including at: /ticket/12973.html

comment:3 Changed 4 years ago by anonymous

Considering that this issue with the AR7240 switch existed since 2011 ( https://lists.openwrt.org/pipermail/openwrt-devel/2011-September/012347.html ) and had many bugs reports including this bug report, which is from 3 months ago, and that one ( /ticket/12973.html ) which is from 9 months ago, it is difficult to expect any change to happen soon.

Without a fix, the affected routers are not usable as a routers, for networks that have a wired part. The only question that remains then, is if firmwares other than openwrt has the same problem.

Changed 4 years ago by anonymous

comment:4 Changed 4 years ago by anonymous

Till time we don't have a normal solution make a dirty workaround for that.
Script (started as service) check every 5 second dmesg about that flip/flop situation and if found that - restart LAN interface.At least we don't lost connection at all - only disconnect for some seconds.

comment:5 Changed 3 years ago by hnyman

Looks like I have now ran into this problem with CC trunk r42332 build for ar71xx/wndr3700.

The error materialized right after flashing on the first boot and also with subsequent reboots.

I did not have any similar problem with the previous build r42286, so this is probably

My log below:

[   32.930000] br-lan: port 2(wlan0) entered forwarding state
[  105.050000] ------------[ cut here ]------------
[  105.050000] WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0x1e8/0x26c()
[  105.060000] NETDEV WATCHDOG: eth0 (ag71xx): transmit queue 0 timed out
[  105.060000] Modules linked in: ifb ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pptp pppox ppp_mppe ppp_generic nf_nat_ipv4 nf_conntrack_ipv4 mac80211 ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_id xt_hl xt_helper xt_esp xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY usbserial ts_kmp ts_fsm ts_bm slhc nf_nat_rtsp nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_rtsp nf_conntrack_irc nf_conntrack_ftp iptable_raw iptable_mangle iptable_filter ipt_ah ipt_REJECT ipt_ECN ip_tables crc_ccitt compat act_connmark act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress leds_wndr3700_usb ledtrig_usbdev ip6t_REJECT ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables nf_conntrack_ipv6 nf_conntrack nf_defrag_ipv6 msdos ip_gre gre sit tunnel4 ip_tunnel tun vfat fat ntfs hfsplus cifs nls_utf8 nls_iso8859_15 nls_iso8859_1 nls_cp850 nls_cp437 nls_cp1250 ipv6 sha256_generic sha1_generic md5 md4 hmac ecb des_generic arc4 crypto_blkcipher usb_storage ohci_hcd ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 crc16 jbd2 mbcache usbcore nls_base usb_common crypto_hash [last unloaded: ifb]
[  105.180000] CPU: 0 PID: 0 Comm: swapper Not tainted 3.10.49 #1
[  105.190000] Stack : 00000000 00000000 00000000 00000000 8039bf1e 00000032 8031ef50 000000d9
[  105.190000] 	  802d7cc4 8031f37b 00000000 803939dc 8031ef50 000000d9 8039b874 00000001
[  105.190000] 	  00000004 8027e310 00000003 801e332c 802f04bc 000000d9 802d9354 8030fc74
[  105.190000] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[  105.190000] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 8030fc00
[  105.190000] 	  ...
[  105.230000] Call Trace:
[  105.230000] [<80223fcc>] show_stack+0x48/0x70
[  105.230000] [<8028d8d8>] warn_slowpath_common+0x78/0xa8
[  105.240000] [<8028d934>] warn_slowpath_fmt+0x2c/0x38
[  105.240000] [<80100fa8>] dev_watchdog+0x1e8/0x26c
[  105.250000] [<800e0dc4>] call_timer_fn.isra.38+0x24/0x84
[  105.250000] [<8020cf70>] run_timer_softirq+0x17c/0x1bc
[  105.260000] [<8008bc78>] __do_softirq+0xd0/0x1bc
[  105.260000] [<80115b2c>] do_softirq+0x48/0x68
[  105.270000] [<80173488>] irq_exit+0x54/0x70
[  105.270000] [<80060830>] ret_from_irq+0x0/0x4
[  105.280000] [<80060a80>] __r4k_wait+0x20/0x40
[  105.280000] [<800f0a14>] cpu_startup_entry+0xa4/0x104
[  105.280000] [<8032b910>] start_kernel+0x38c/0x3a4
[  105.290000] 
[  105.290000] ---[ end trace 80ba0d8c257057ce ]---
[  105.300000] eth0: tx timeout
[  105.300000] eth0: link down
[  105.310000] ar71xx: pll_reg 0xb8050010: 0x11110000

comment:6 Changed 3 years ago by hnyman

My error is probably caused by r42328, as reverting r42328 makes my 42332 build to work normally again. So, my error is related to #13072.

comment:7 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r47892, r47895

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.