Modify

Opened 4 years ago

Last modified 4 years ago

#14033 new defect

batman_adv: Unable to register the batman interface '': -22 and Kernel Crash while booting

Reported by: Sandip Sitapara <s13884neo@…> Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: batman-adv, openwrt, r31729, 31727, kernel crash Cc:

Description

I got following error while loading batman interface

[ 18.230000] batman_adv: Unable to register the batman interface : -22

here is my network configration

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan1'

option ifname 'eth0'
option type 'bridge'
option proto 'dhcp'
option ipaddr '192.51.1.1'
option netmask '255.255.255.0'
option plug_event '/sbin/plugevent'

config interface 'mesh'

option ifname 'mesh0'
option mtu '1528'
option proto 'batadv'

Wireless configuration
config wifi-device radio0

option type mac80211
option channel 11
option country US
option macaddr ac:86:74:0f:3c:0a
option hwmode 11ng
option htmode HT20
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
option disabled 0

config wifi-iface 'wmesh'

option device 'radio0'
option ifname 'mesh0'
option network 'mesh'
option mode 'adhoc'
option ssid 'mesh'
option bssid '02:CA:FE:FF:FA:40'
option disabled '0'
option mcast_rate '18000'
option encryption 'none'

Also its crashing kernel when I add option mesh 'bat0' to network as following

config interface 'mesh'

option ifname 'mesh0'
option mtu '1528'
option proto 'batadv'
option mesh 'bat0'

CRASHLOGS
[ 18.090000] CPU 0 Unable to handle kernel paging request at virtual address 00000108, epc == 801d7168, ra == 801d7168
[ 18.100000] Oops#1:
[ 18.100000] Cpu 0
[ 18.100000] $ 0 : 00000000 00000000 83789cc0 83786820
[ 18.100000] $ 4 : 83786f64 00000000 00000000 00000223
[ 18.100000] $ 8 : 00000024 801638cc 00000003 46990adf
[ 18.100000] $12 : 802c7538 3003333a 54484e17 5b5c34be
[ 18.100000] $16 : 00000000 83786380 83786380 83751000
[ 18.100000] $20 : 83763f10 80310000 83752880 83755598
[ 18.100000] $24 : 00000003 00000000
[ 18.100000] $28 : 83762000 83763d60 00000000 801d7168
[ 18.100000] Hi : 000003f5
[ 18.100000] Lo : 00116629
[ 18.100000] epc : 801d7168 0x801d7168
[ 18.100000] Tainted: G O
[ 18.100000] ra : 801d7168 0x801d7168
[ 18.100000] Status: 1000f403 KERNEL EXL IE
[ 18.100000] Cause : 00800008
[ 18.100000] BadVA : 00000108
[ 18.100000] PrId : 00019374 (MIPS 24Kc)
[ 18.100000] Modules linked in: ath79_wdt ledtrig_netdev batman_adv(O) nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_conntrack xt_CT xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc button_hotplug(O) ath9k(O) ath9k_common(O) ath9k_hw(O) ath(O) mac80211(O) libcrc32c crc16 crc_ccitt input_polldev cfg80211(O) compat(O) input_core arc4 aes_generic crc32c crypto_hash crypto_algapi ledtrig_timer ledtrig_default_on leds_gpio gpio_button_hotplug(O)
[ 18.100000] Process batadv.sh (pid: 974, threadinfo=83762000, task=83f06140, tls=7795d440)
[ 18.100000] Stack : 8026e040 00000000 00000010 83786380 83f38000 83679438 00000001 83786000
[ 18.100000] 83786380 83751000 00000001 83786000 83786380 83751000 83763f10 83669d18
[ 18.100000] 8367d8e8 83751000 83763f10 00000000 00000000 83786000 83786380 836711d0
[ 18.100000] 00000000 836712a0 00000000 00000000 83786000 00000000 00000000 801e4308
[ 18.100000] 83786000 801df540 83763f00 83769000 00000000 83786000 83751000 00000000
[ 18.100000] ...
[ 18.100000] Call Trace:[<83679438>] 0x83679438
[ 18.100000] [<83669d18>] 0x83669d18
[ 18.100000] [<836711d0>] 0x836711d0
[ 18.100000] [<836712a0>] 0x836712a0
[ 18.100000] [<801e4308>] 0x801e4308
[ 18.100000] [<801df540>] 0x801df540
[ 18.100000] [<83671ab4>] 0x83671ab4
[ 18.100000] [<801df28c>] 0x801df28c
[ 18.100000] [<83668454>] 0x83668454
[ 18.100000] [<836724c8>] 0x836724c8
[ 18.100000] [<800af6e0>] 0x800af6e0
[ 18.100000] [<8012076c>] 0x8012076c
[ 18.100000] [<800d6df4>] 0x800d6df4
[ 18.100000] [<80074f6c>] 0x80074f6c
[ 18.100000] [<800d70cc>] 0x800d70cc
[ 18.100000] [<80069a64>] 0x80069a64
[ 18.100000] [<80074f9c>] 0x80074f9c
[ 18.100000]
[ 18.100000]
[ 18.100000] Code: afbf0014 0c075c3e 00808021 <8e030108> 7c6304c0 1460000a 8fbf0014 10400009 8fb00010
[ 18.370000] ---[ end trace 2674baa9105ad68e ]---
[ 18.370000] Kernel panic - not syncing: Fatal exception in interrupt

Some issue while adding bat0 interface using batadv.sh (/lib/netifd/batadv.sh). So any patches for same?

So anybody knows how to resolve the same?

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Sandip Sitapara <s13884neo@…>

I have compiled older version batman 2013.1.0-1 and it works.

Here is the logs
[ 12.090000] batman_adv: B.A.T.M.A.N. advanced 2013.1.0 (compatibility version 14) loaded
[ 12.360000] Error: Driver 'gpio-keys-polled' is already registered, aborting...
[ 15.510000] device eth0 entered promiscuous mode
[ 16.770000] device eth1 entered promiscuous mode
[ 18.500000] eth0: link up (100Mbps/Full duplex)
[ 18.500000] br-lan1: port 1(eth0) entered forwarding state
[ 18.510000] br-lan1: port 1(eth0) entered forwarding state
[ 18.800000] batman_adv: bat0: Adding interface: mesh0
[ 18.800000] batman_adv: bat0: Interface activated: mesh0
[ 19.210000] batman_adv: bat0: orig_interval: Changing from: 1000 to: 5000
[ 19.250000] batman_adv: bat0: hop_penalty: Changing from: 30 to: 25
[ 19.250000] batman_adv: bat0: Changing gw mode from: off to: client
[ 20.510000] br-lan1: port 1(eth0) entered forwarding state
[ 40.490000] batman_adv: bat0: bridge_loop_avoidance: Changing from: disabled to: enabled

I am not sure but issue with newer batman version 2013.3.0-4 version while adding bat0 interface from netifd protocol script batadv.sh.

Anyone found issue for batman-2013.3.0-4? (Openwrt r31727 default version 2013.3.0-4)

comment:2 Changed 4 years ago by Sandip Sitapara <s13884neo@…>

Sorry, little bit mistake for working batman version 2013.1.0-2 not 2013.1.0-1

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.