Modify

Opened 5 years ago

Last modified 3 years ago

#14009 new defect

MIPS: no machine found for id '2011r5' on Mikrotik RB2011UAS-2HnD

Reported by: w58850@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: no machine found Cc:

Description

With latest trunk

Attachments (1)

2011r5.patch (1.5 KB) - added by SysRq 4 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 4 years ago by anonymous

......

Changed 4 years ago by SysRq

comment:2 Changed 4 years ago by SysRq

I found that in recent releases of the firmware (3.08), the kernel commandline parameter board is "2011r5" instead of "2011US" as in previous releases (I have the same board with firmware 3.0).
So I added an item in MIPS_MACHINE pointing to rb2011us_setup, and now everything works except SFP (port 6 of switch0).
There are also errors on usb (usb 1-1: device descriptor read/64, error -71) but I did not try it.
With firmware 3.10 instead the board reboots before the "Console is alive".

I attach my patch

comment:3 Changed 4 years ago by anonymous

Hi,

same issue with trunk.40019 on a MikroTik RB2011UiAS with booter 3.10
Without 2011r5 patch the serial console is working but nothing else :-(

[ 4.990000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd034, driver=Atheros AR8216/AR8236/AR8316]
[ 5.010000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RGMII
[ 5.560000] ag71xx-mdio.1: Found an AR934X built-in switch
[ 6.600000] eth1: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[ 6.600000] TCP: cubic registered
[ 6.610000] NET: Registered protocol family 17
[ 6.610000] 8021q: 802.1Q VLAN Support v1.8
[ 6.620000] Key type dns_resolver registered
[ 6.630000] Freeing unused kernel memory: 2520K (8038a000 - 80600000)
pr.

RouterBOOT booter 3.10

RouterBoard 2011UiAS

CPU frequency: 600 MHz

Memory speed: 225 MHz

Memory size: 128 MiB

NAND size: 128 MiB

Press any key within 2 seconds to enter setup..

comment:4 Changed 3 years ago by SysRq

By r41617 this patch is no longer needed, but I'm trying latest trunk (r42229) and the SFP module does not work for me yet (swconfig reports "link down", /sys/kernel/debug/gpio says "gpio-21 (SFP LOS) in hi").
I'm trying with a RB2011UAS connected to a RB2011UiAS: if I boot the UiAS with RouterOS, the UAS can see the link, so the interfaces and cables are ok

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.