Modify

Opened 5 years ago

Closed 4 years ago

#13977 closed defect (fixed)

Linksys E900 inaccessible from LAN

Reported by: mihai.luizescu@… Owned by: hauke
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Linksys E900 LAN Switch Cc:

Description

Installed BARRIER BREAKER (Bleeding Edge, r37618) onto a Linksys E900, it boots OK, but afterwards the LAN ports don't seem to work (I cannot ping the router). Attached are the NVRAM and bootlog.

Attachments (2)

Bootlog.txt (9.4 KB) - added by mihai.luizescu@… 5 years ago.
NVRAM.txt (1.5 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by mihai.luizescu@…

Changed 5 years ago by anonymous

comment:1 Changed 5 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to assigned

Could you build a image with kernel 3.10 and try again.

comment:2 Changed 5 years ago by LuisUK

Unfortunately I'm not familiar with building. Is there any prebuilt image with kernel 3.10?

comment:3 Changed 5 years ago by hauke

The current snapshots are using kernel 3.10

comment:4 Changed 5 years ago by anonymous

I used http://downloads.openwrt.org/snapshots/trunk/brcm47xx/openwrt-e900_v1-squashfs.bin, and it produced the result in the attached files.

Any other ideas?

After I flash the image above, I can only access the router via serial console.

If I try to revert back to stock firmware via TFTP, I get an "out of memory" error. The only way I can revert is to wipe the NVRAM from CFE prompt, and then run "flash -ctheader : flash1.trx". Otherwise, the stock firmware doesn't take.

comment:5 Changed 4 years ago by anonymous

I saw this in the bootlog: "bgmac bcma0:1: Support for Roboswitch not implemented"

Was this fixed in later builds?

comment:6 Changed 4 years ago by anonymous

Also, the board is not detected correctly:

[ 4.708000] Found board: "Unknown Board"
[ 4.712000] diag: unknown board found, try legacy detect
[ 4.716000] diag: please open a ticket at https://dev.openwrt.org and attach the complete nvram
[ 4.728000] diag: Detected 'Linksys WRT54G/GS/GL'

comment:7 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from assigned to closed

Thank you for reporting, the Ethernet problem was fixed in r37993, r37994, r37995.

To make the GPIOs work provide a patch which adds the device to target/linux/brcm47xx/patches-3.10/260-MIPS-BCM47XX-add-board-detection.patch and adds a gpio configuration in package/kernel/broadcom-diag/src/diag.c

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.