Modify

Opened 5 years ago

Closed 5 years ago

#13916 closed defect (fixed)

Crash setting up qos

Reported by: viric@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: tc, qos, bcm63xx Cc:

Description

Setting /etc/config/qos with 'enable 1', and starting qos, I get a kernel crash (in 3.9.8 and 3.9.10; r37384 the latest). This is in a HW553 (bcm63xx).


# /usr/lib/qos/generate.sh all | sh -x
+ rmmod ifb
+ insmod ifb numifbs=1
+ insmod cls_u32
+ insmod em_u32
+ insmod act_connmark
+ insmod act_mirred
+ insmod sch_ingress
+ insmod cls_fw
+ insmod sch_hfsc
+ insmod sch_fq_codel
+ ifconfig eth0 up txqueuelen 5
+ tc qdisc del dev eth0 root
+ tc qdisc add dev eth0 root handle 1: hfsc default 30
+ tc class add dev eth0 parent 1: classid 1:1 hfsc sc rate 128kbit ul rate 128kbit
+ tc class add dev eth0 parent 1:1 classid 1:10 hfsc rt m1 74kbit d 6103us m2 12kbit ls m1 74kbit d 6103us m2 71kbit ul rate 128kbit
+ tc class add dev eth0 parent 1:1 classid 1:20 hfsc rt m1 68kbit d 15258us m2 64kbit ls m1 68kbit d 15258us m2 35kbit ul rate 128kbit
+ tc class add dev eth0 parent 1:1 classid 1:30 hfsc ls m1 0kbit d 100000us m2 17kbit ul rate 128kbit
+ tc class add dev eth0 parent 1:1 classid 1:40 hfsc ls m1 0kbit d 200000us m2 3kbit ul rate 128kbit
+ tc qdisc add dev eth0 parent 1:10 handle 100: fq_codel limit 800 quantum 300
+ tc qdisc add dev eth0 parent 1:20 handle 200: fq_codel limit 800 quantum 300
+ tc qdisc add dev eth0 parent 1:30 handle 300: fq_codel limit 800 quantum 300
+ tc qdisc add dev eth0 parent 1:40 handle 400: fq_codel limit 800 quantum 300
+ tc filter add dev eth0 parent 1: prio 1 protocol ip handle 1/0xff fw flowid 1:10
+ tc filter add dev eth0 parent 1: prio 2 protocol ip handle 2/0xff fw flowid 1:20
+ tc filter add dev eth0 parent 1: prio 3 protocol ip handle 3/0xff fw flowid 1:30
+ tc filter add dev eth0 parent 1: prio 4 protocol ip handle 4/0xff fw flowid 1:40
+ ifconfig ifb0 up txqueuelen 5
+ tc qdisc del dev ifb0 root
+ tc qdisc add dev ifb0 root handle 1: hfsc default 30
+ tc class add dev ifb0 parent 1: classid 1:1 hfsc sc rate 1024kbit ul rate 1024kbit
+ tc qdisc del dev eth0 ingress
+ tc qdisc add dev eth0 ingress
+ tc filter add dev eth0 parent ffff: protocol ip prio 1 u32 match u32 0 0 flowid 1:1 action connmark action mirred egress redirect dev ifb0
Segmentation fault
+ tc class add dev ifb0 parent 1:1 classid 1:10 hfsc rt m1 232kbit d 1907us m2 102kbit ls m1 232kbit d 1907us m2 568kbit ul rate 1024kbit


[ 478.692000] u32 classifier
[ 478.692000] input device check on
[ 478.696000] Actions configured
[ 478.764000] Mirror/redirect action on
[ 545.788000] CPU 0 Unable to handle kernel paging request at virtual address
00000000, epc == 801ec8f4, ra == 801ec8a0
[ 545.800000] Oops#1:
[ 545.800000] Cpu 0
[ 545.800000] $ 0 : 00000000 10008400 0000f007 0000f007
[ 545.800000] $ 4 : 00000001 833fa1a0 00000000 00000060
[ 545.800000] $ 8 : 00000020 80014950 00000000 00000000
[ 545.800000] $12 : 00000000 8242eaa8 00000000 00000000
[ 545.800000] $16 : 00000001 8337b380 00000000 00000000
[ 545.800000] $20 : 8242ea3c 80316368 00000000 00000000
[ 545.800000] $24 : 00000000 77d7bb60
[ 545.800000] $28 : 8242a000 8242b8d8 00000001 801ec8a0
[ 545.800000] Hi : 00000000
[ 545.800000] Lo : 00000150
[ 545.800000] epc : 801ec8f4 tcf_hash_create+0xb4/0xe0
[ 545.800000] Not tainted
[ 545.800000] ra : 801ec8a0 tcf_hash_create+0x60/0xe0
[ 545.800000] Status: 10008403 KERNEL EXL IE
[ 545.800000] Cause : 8080000c
[ 545.800000] BadVA : 00000000
[ 545.800000] PrId : 0002a010 (Broadcom BMIPS4350)
[ 545.800000] Modules linked in: ifb xt_HL xt_hl xt_ecn ipt_ECN xt_CLASSIFY
xt_tcpmss xt_statistic xt_length xt_DSCP xt_dscp xt_string ts_fsm ts_bm ts_kmp
act_connmark xt_recent xt_helper xt_connmark xt_connbytes act_skbedit
act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc
sch_ingress ip6t_REJECT ip6t_rt ip6t_hbh ip6t_mh ip6t_ipv6header ip6t_frag
ip6t_eui64 ip6t_ah ip6table_raw ip6table_mangle ip6table_filter ip6_tables
nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_irc nf_nat_ftp nf_conntrack_irc
nf_conntrack_ftp xt_REDIRECT ipt_MASQUERADE iptable_nat xt_nat nf_nat_ipv4
nf_nat pppoe xt_conntrack xt_CT iptable_raw xt_state nf_conntrack_ipv4
nf_defrag_ipv4 nf_conntrack pppox xt_mark xt_time ipt_REJECT xt_TCPMSS xt_LOG
xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables
xt_tcpudp x_tables ppp_async ppp_generic slhc b43 bcma mac80211 crc_ccitt ipv6
cfg80211 compat arc4 crypto_blkcipher aead gpio_keys_polled button_hotplug
input_polldev input_core crypto_hash [last unloaded: ifb]
[ 545.800000] Process tc (pid: 1499, threadinfo=8242a000, task=830b39d8,
tls=77e11440)
[ 545.800000] Stack : 80303f10 830b3a08 80300000 8004c440 00000000 833fa1a0
833fa160 833f4d00
[ 545.800000] 00000000 833fa05c 27d14655 00000000 00000000 00000001
00000000 833fa300
[ 545.800000] 833fa1a0 00000001 ffffffea 801ecf24 00000000 27d14655
00000000 00000010
[ 545.800000] 00000000 00000001 636f6e6e 6d61726b 00000000 00000000
00000000 8242ea40
[ 545.800000] 00000000 00000000 00000000 00000000 00000000 00000000
00000001 8242b9ac
[ 545.800000] ...
[ 545.800000] Call Trace:
[ 545.800000] [<801ec8f4>] tcf_hash_create+0xb4/0xe0
[ 545.800000] [<833fa05c>] 0x833fa05c
[ 545.800000]
[ 545.800000]
[ 545.800000] Code: 02202021 0807b240 02008821 <0807b240> ae710000 2411fff4

8fbf0020

[ 546.040000] ---[ end trace ee500819d192f7d6 ]---

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by markuz@…

Confirmed on 37374 using ar71xx (tp link 1043nd) as soon as i setup qos i get a kernel error like yours and net start to drop until i reboot router. Then the only way to fix it is to factory reset settings :/

comment:2 Changed 5 years ago by mennozon@…

this seems to be triggered by /changeset/36294.html

just edit /usr/lib/qos/tcrules.awk and remove the "limit 800 quantum 300" part and qos starts up without a problem, this is a dup of #13876

comment:3 Changed 5 years ago by anonymous

That change doesn't fix my issue :/

comment:4 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r37493

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.