Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#13862 closed defect (worksforme)

Frequent crashes on Buffalo WZR-HP-G300NH

Reported by: db+openwrtnospam@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Attitude Adjustment 12.09
Keywords: Cc:

Description

My Buffalo WZR-HP-G300NH running 12.09 experiences frequent reboots and lock ups. I have forced 11g mode as per the advice at http://wiki.openwrt.org/toh/buffalo/wzr-hp-g300h#troubleshootingbugs , however the device is still experiencing issues.
For example: it appears that the device stops functioning as a router after an unaligned kernel access (I guess we are on x86 anymore Toto!), kernel oops follows -

[   28.180000] Unhandled kernel unaligned access[#1]:
[   28.180000] Cpu 0
[   28.180000] $ 0   : 00000000 00000001 00000015 00008000
[   28.180000] $ 4   : 832abe70 00000000 0000006c 832abdd0
[   28.180000] $ 8   : 000006c0 80350000 802e0000 fffffff8
[   28.180000] $12   : 80000000 000003fe 81007c00 00480000
[   28.180000] $16   : 00000000 832abe70 832abe24 00000000
[   28.180000] $20   : 00002000 00000000 83456000 00000024
[   28.180000] $24   : 00478778 80141f34                  
[   28.180000] $28   : 832aa000 832abdb8 00000000 800e4364
[   28.180000] Hi    : 00000007
[   28.180000] Lo    : 00000019
[   28.180000] epc   : 800e45a8 0x800e45a8
[   28.180000]     Tainted: G           O
[   28.180000] ra    : 800e4364 0x800e4364
[   28.180000] Status: 1000fc03    KERNEL EXL IE 
[   28.180000] Cause : 80800010
[   28.180000] BadVA : 00000035
[   28.180000] PrId  : 00019374 (MIPS 24Kc)
[   28.180000] Modules linked in: ath79_wdt ohci_hcd ledtrig_usbdev ledtrig_netdev nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat pppoe xt_conntrack xt_CT xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_hcd pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k(O) ath9k_common(O) ath9k_hw(O) ath(O) mac80211(O) usbcore usb_common nls_base crc_ccitt cfg80211(O) compat(O) arc4 aes_generic crypto_algapi ledtrig_timer ledtrig_default_on leds_gpio gpio_button_hotplug(O)
[   28.180000] Process S45firewall (pid: 1181, threadinfo=832aa000, task=83baa140, tls=776b5440)
[   28.180000] Stack : 83455d10 00000001 00000000 83807d30 83456000 396c3e7a 834cd980 803b700a
[   28.180000]         83956000 83384c80 832abe70 00000000 832abf00 832abe84 00000004 832abe24
[   28.180000]         fffff8ff 800e4c5c 00000004 0000000b 00000001 00000006 832abe18 800d7220
[   28.180000]         00000000 83807d30 834bae00 83807d30 834bc600 000003fe 007f1bd0 832abf00
[   28.180000]         ffffff9c 83370000 00000001 00000001 00480000 00000002 007f13ac 800e4e34
[   28.180000]         ...
[   28.180000] Call Trace:[<800e4c5c>] 0x800e4c5c
[   28.180000] [<800d7220>] 0x800d7220
[   28.180000] [<800e4e34>] 0x800e4e34
[   28.180000] [<8006c044>] 0x8006c044
[   28.180000] [<800ef214>] 0x800ef214
[   28.180000] [<800e189c>] 0x800e189c
[   28.180000] [<800d6c90>] 0x800d6c90
[   28.180000] [<8006a204>] 0x8006a204
[   28.180000] 
[   28.180000] 
[   28.180000] Code: 08039169  0000a821  8e220004 <12e00097> 8c520020  12400067  2410fffe  96420000  24034000 
[   28.420000] ---[ end trace 15fa0614e31bcad8 ]---

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by anonymous

I can setup serial logging from the device if it would help.

comment:2 Changed 5 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Please try a current trunk snapshot, or build latest 12.09 git branch. I believe these issues are fixed there.

comment:3 Changed 4 years ago by tonyinqd

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm using the latest trunk snapshot. It seems steady but too many package's cannot be installed.

Just forced pptp, and now usb got more errors:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
  • kernel (= 3.10.12-1-6fc86e497c03b93db249ff2b7d59c5b2) *
  • opkg_install_cmd: Cannot install package kmod-usb-storage.

How to manage? Thanks

comment:4 Changed 4 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

This is not a bug. You can only install kernel packages that were built along with the image that you have running on the system.
If you flash a snapshot build, and the next snapshot build comes along, you may no longer be able to install kernel related packages from the opkg feed.
If you build yourself, an easy way around this is to select all packages that you intend to use, and only use your own kernel packages.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.