Modify

Opened 5 years ago

Last modified 4 years ago

#13827 reopened defect

r37016 or newer break dir-615-d

Reported by: Viper <viper0508@…> Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

r37016 or newer don't work with dir-615-d, the ethernet ports all come up as a switch (lan&wan tied togheter, the leds act as it was a switch also), no reply on default ip.
I don't have a serial cable so i can't see what's realy going on.

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by Mitch <mitchhubers@…>

comment:2 Changed 5 years ago by Viper <viper0508@…>

rev D3

comment:3 Changed 5 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in latest trunk

comment:4 Changed 5 years ago by Viper <viper0508@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still the same. I've done a clean rebuild of r37206. maybe someone with a serial cable and this unit can help?

comment:5 Changed 5 years ago by Viper <viper0508@…>

Ok, i've done another rebuild of r37206 (after distclean) with kernel 3.8.13 set in Makefile for ralink, same issue. I don't know what else to test.

comment:6 Changed 5 years ago by blogic

maybe you should get a cable and help to fix the bug

comment:7 Changed 5 years ago by Viper <viper0508@…>

Unfortunately it's not accessible around here, i would've got one by now. Some change in r37016 broke it (if it doesn't work even with kernel 3.8 after that changeset) it runs just fine with r37015.

comment:8 Changed 5 years ago by anonymous

I can confirm this I have rt-n13u it was working on <37000 there's no problem with my cable because I can flash my router. Been trying this everyday to see if it's already fixed. The router is unpingable and the dhcp server is also not working. Even I assign an address 192.168.1.2/24 and gateway is 192.168.1.1 still no avail.

comment:9 Changed 4 years ago by Viper <viper0508@…>

Can be closed, i was out of the country till now, sorry. I've just tried with r38299 (and a serial cable this time, just in case it was still broken) and all is ok.
Thank you!

comment:10 Changed 4 years ago by Viper <viper0508@…>

And the output of a broken revision, r37078 (i was curious)

[    0.000000] Linux version 3.9.6 (viper@darkstar-v3) (gcc version 4.6.4 (OpenWrt/Linaro GCC 4.6-2012.12 r36976) ) #1 Fri Jun 28 23:05:14 EEST 2013
[    0.000000] SoC Type: Ralink RT3052 id:1 rev:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0001964c (MIPS 24KEc)
[    0.000000] MIPS: machine is D-Link DIR-615 D
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] __ex_table already sorted, skipping sort
[    0.000000] Writing ErrCtl register=0000f82e
[    0.000000] Readback ErrCtl register=0000f82e
[    0.000000] Memory: 29552k/32768k available (2099k kernel code, 3216k reserved, 369k data, 216k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:128
[    0.000000] CPU Clock: 384MHz
[    0.000000] Calibrating delay loop... 255.59 BogoMIPS (lpj=1277952)
[    0.070000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.110000] platform 10000300.memc: illegal read access from cpu - addr:0x08000000 offset:15 len:32
[    0.120000] platform 10000300.memc: illegal read access from cpu - addr:0x08000000 offset:15 len:32
[    0.130000] platform 10000300.memc: illegal read access from cpu - addr:0x08000000 offset:15 len:32

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.