Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13791 closed defect (fixed)

r37106: ar71xx / tl-wdr4300, lsmod segmentation fault and xt_connmark, xt_mark fails to load at boot

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

xt_connmark and xt_mark fails to load at boot (perhaps irrelevant), syslog below:

Fri Jun 28 18:35:02 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_mark.ko
Fri Jun 28 18:35:02 2013 auth.info kernel: [   19.030000] NET: Registered protocol family 24
Fri Jun 28 18:35:02 2013 auth.info kernel: [   19.110000] nf_conntrack version 0.5.0 (1977 buckets, 7908 max)
Fri Jun 28 18:35:03 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_connmark.ko

lsmod causes segmentation fault

root@dexter:~# lsmod
Segmentation fault
root@dexter:~#

normal operations seems to work okay though.

Attachments (1)

lsmod.strace (8.0 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by anonymous

forgot to mention, this is after a distclean and just a few basic packages selected (and luci).

comment:2 Changed 5 years ago by anonymous

xt_mark and xt_connmark are listed in /proc/modules though.

root@dexter:/proc# cat modules |grep xt_mark
xt_mark 672 26 - Live 0x869b0000
x_tables 10997 48 ip6t_REJECT,ip6t_rt,ip6t_hbh,ip6t_mh,ip6t_ipv6header,ip6t_frag,ip6t_eui64,ip6t_ah,ip6table_raw,ip6table_mangle,ip6table_filter,ip6_tables,xt_HL,xt_hl,xt_ecn,ipt_ECN,xt_CLASSIFY,xt_tcpmss,xt_statistic,xt_length,xt_DSCP,xt_dscp,xt_string,xt_layer7,xt_REDIRECT,ipt_MASQUERADE,xt_nat,xt_recent,xt_helper,xt_connmark,xt_connbytes,xt_conntrack,xt_CT,iptable_raw,xt_state,xt_mark,xt_time,ipt_REJECT,xt_TCPMSS,xt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,iptable_mangle,iptable_filter,ip_tables,xt_tcpudp, Live 0x86960000
root@dexter:/proc# cat modules |grep xt_connmark
xt_connmark 1040 2 - Live 0x869c7000
nf_conntrack 42721 18 act_connmark,nf_conntrack_ipv6,nf_nat_irc,nf_nat_ftp,nf_conntrack_irc,nf_conntrack_ftp,xt_layer7,ipt_MASQUERADE,iptable_nat,nf_nat_ipv4,nf_nat,xt_helper,xt_connmark,xt_connbytes,xt_conntrack,xt_CT,xt_state,nf_conntrack_ipv4, Live 0x869d0000
x_tables 10997 48 ip6t_REJECT,ip6t_rt,ip6t_hbh,ip6t_mh,ip6t_ipv6header,ip6t_frag,ip6t_eui64,ip6t_ah,ip6table_raw,ip6table_mangle,ip6table_filter,ip6_tables,xt_HL,xt_hl,xt_ecn,ipt_ECN,xt_CLASSIFY,xt_tcpmss,xt_statistic,xt_length,xt_DSCP,xt_dscp,xt_string,xt_layer7,xt_REDIRECT,ipt_MASQUERADE,xt_nat,xt_recent,xt_helper,xt_connmark,xt_connbytes,xt_conntrack,xt_CT,iptable_raw,xt_state,xt_mark,xt_time,ipt_REJECT,xt_TCPMSS,xt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,iptable_mangle,iptable_filter,ip_tables,xt_tcpudp, Live 0x86960000
root@dexter:/proc#

comment:3 Changed 5 years ago by anonymous

To further complicate things here.. I have two of these devices (tl-wdr4300). Both now on the same image (r37106), but the second device is not giving a segfault on lsmod.

The first one which throws a lsmod segfault is configured as following:

  • PPPoE internet with IPv6 (6relayd running), connectivity working.
  • 2.4GHz AP
  • 5.2GHz WDS AP

LAN-to-LAN bridge between the devices.

The second device that does not throw lsmod segfault:

  • Static IP (internet connectivity, IPv6 only local)
  • 5.2GHz WDS Client
  • 2.4GHz AP

everything else is identical between them. failed to insert xt_mark and xt_connmark shows up on both devices during boot. But still appears active in /proc/modules.

I've tried to reboot the first device but it still throws lsmod segfault.

Not quite sure how to continue debugging this, but some googling told me that some modules can sometimes cause lsmod to do this.

comment:4 Changed 5 years ago by anonymous

By reboot I meant reflash. And of course a few reboots too..

Changed 5 years ago by anonymous

comment:5 Changed 5 years ago by anonymous

Made a fresh distclean build with r37125, but the same issue persists. Still just on one of the devices, with exactly the same image. I can't make any sense out of it.

comment:6 Changed 5 years ago by Viper <viper0508@…>

Same issue here on wr842nd and r37132,

Tue Jul  2 15:28:02 2013 auth.info kernel: [   15.540000] xt_time: kernel timezone is -0000
Tue Jul  2 15:28:02 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_mark.ko
Tue Jul  2 15:28:02 2013 auth.info kernel: [   15.730000] NET: Registered protocol family 24
Tue Jul  2 15:28:03 2013 auth.info kernel: [   15.840000] nf_conntrack version 0.5.0 (457 buckets, 1828 max)
Tue Jul  2 15:28:03 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_connmark.ko
Tue Jul  2 15:28:04 2013 auth.info kernel: [   17.130000] ip6_tables: (C) 2000-2006 Netfilter Core Team

and lsmod segfaults.
i've tried an older build, r37015, and there are even more modules that sysinit complains about, (usb*) i don't have the logs from that, and lsmod also segfaults.

comment:7 Changed 5 years ago by duvi

Same thing here on RB433UAH, r37112.

root@OpenWrt:~# logread
...
Thu Jan  1 01:00:20 1970 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_mark.ko
Thu Jan  1 01:00:20 1970 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_connmark.ko
...
root@OpenWrt:~# lsmod
Segmentation fault

comment:8 Changed 5 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 5 years ago by duvi

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still, RB433UAH, r37180

root@OpenWrt:~# logread
...
Thu Jan  1 01:00:20 1970 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_mark.ko
Thu Jan  1 01:00:20 1970 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_connmark.ko
...

The lsmod segmentation fault is fixed indeed.

comment:10 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

Not a bug in insmod. Those messages only show up because the module entries in /etc/modules.d are duplicated and the second load attempt fails.

comment:11 Changed 5 years ago by nbd

the duplication should be fixed in r37344

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.