Modify

Opened 5 years ago

Last modified 2 years ago

#13763 reopened defect

r37033 extroot does not work (/tmp/overlay-disabled)

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Chaos Calmer 15.05
Component: other Version: Trunk
Keywords: Cc:

Description

In r37033 extroot does not work:
root@OpenWrt:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 4.7M 348.0K 4.3M 7% /
/dev/root 9.8M 9.8M 0 100% /rom
tmpfs 61.7M 364.0K 61.4M 1% /tmp
/dev/mtdblock4 4.7M 348.0K 4.3M 7% /overlay
overlayfs:/overlay 4.7M 348.0K 4.3M 7% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/sda3 1.3T 410.5G 894.6G 31% /mnt/sda3

The system log contains errors such as:

Tue Jun 25 19:31:02 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/ext4.ko
Tue Jun 25 19:31:02 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/gpio-button-hotplug.ko
Tue Jun 25 19:31:03 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_mark.ko
Tue Jun 25 19:31:04 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/sd_mod.ko
Tue Jun 25 19:31:04 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/ehci-hcd.ko
Tue Jun 25 19:31:04 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/ehci-platform.ko
Tue Jun 25 19:31:04 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/xt_connmark.ko
Tue Jun 25 19:31:05 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/ledtrig-default-on.ko
Tue Jun 25 19:31:05 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/ledtrig-timer.ko
Tue Jun 25 19:31:05 2013 auth.err kernel: [ 18.260000] siit: module license 'unspecified' taints kernel.
Tue Jun 25 19:31:05 2013 auth.err kernel: [ 18.270000] Disabling lock debugging due to kernel taint
Tue Jun 25 19:31:05 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/ohci-hcd.ko
Tue Jun 25 19:31:05 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/uhci-hcd.ko
Tue Jun 25 19:31:05 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/leds-gpio.ko
Tue Jun 25 19:31:05 2013 daemon.info sysinit: failed to insert /lib/modules/3.8.13/usb-storage.ko
/dev/sda1 121.8M 35.9M 79.3M 31% /tmp/overlay-disabled

Help please!

Attachments (1)

log_config (14.4 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (35)

comment:1 Changed 5 years ago by anonymous

Platform: - ar71xx

comment:2 Changed 5 years ago by anonymous

Yep! Same here! After all the latest updates not work automatically mount hard drives and extroot (r37035).
It is sad that after making changes (Ubox?) Is no longer available, that important functionality.

comment:3 Changed 5 years ago by anonymous

Yes i can confirm this in latest trunk Version.
Was a bad update morning today :(

comment:4 Changed 5 years ago by blogic

  • Resolution set to worksforme
  • Status changed from new to closed

Changed 5 years ago by anonymous

comment:5 Changed 5 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

It's not working on TP-Link 1043ND (ARxxx)
The Old extroot was working many Years here.

Please see the Log / Config in the Post before.

comment:6 Changed 5 years ago by jow

  • Priority changed from highest to response-needed

Is the uuid matching the one reported by "block detect"? The new block mounter might use different uuids then blkid.

comment:7 Changed 5 years ago by anonymous

@HeAvEn-Router:/root# blkid
/dev/mtdblock2: TYPE="squashfs"
/dev/sda1: UUID="27030164-f77c-40c0-b495-995c708eaf20" TYPE="ext4"
/dev/sda2: UUID="23831c8f-9fba-4c59-9fa9-b8c5195f61b0" TYPE="ext4"
/dev/sda3: TYPE="swap"
@HeAvEn-Router:/root# block detect
config 'global'

option anon_swap '0'
option anon_mount '0'
option auto_swap '1'
option auto_mount '1'
option delay_root '0'
option check_fs '0'

config 'mount'

option target '/mnt/sda1'
option uuid '27030164-f77c-40c0-b495-995c708eaf20'
option enabled '0'

config 'mount'

option target '/mnt/sda2'
option uuid '23831c8f-9fba-4c59-9fa9-b8c5195f61b0'
option enabled '0'

config 'swap'

option device 'sda3'
option enabled '0'

I can Mount /dev/sda as example to /mnt/sda1 without any Problems but not to '/' or '/overlay'

comment:8 Changed 5 years ago by anonymous

[ 4.210000] hub 1-1:1.0: 4 ports detected
[ 4.500000] usb 1-1.1: new full-speed USB device number 3 using ehci-platform
[ 4.710000] usb 1-1.2: new full-speed USB device number 4 using ehci-platform
[ 4.900000] usb 1-1.3: new high-speed USB device number 5 using ehci-platform

ehci comes up

[ 7.470000] jffs2: notice: (344) jffs2_build_xattr_subsystem: complete building xattr subsystem,
of xdatum (1 unchecked, 0 orphan) and 11 of xref (0 dead, 2 orphan) found.

extroot check

[ 14.170000] Initializing USB Mass Storage driver...

but usb storage is not inserted until 8 seconds later. did you modify anything in your openwrt tree ? usb-storage is clearly not inserted during preinit

comment:9 Changed 5 years ago by DarkStarXxX

I didn't modifing anything.
I use always Trunk Builds from the Build Bota (last version from yesterday)

comment:10 Changed 5 years ago by blogic

  • Resolution set to worksforme
  • Status changed from reopened to closed

i just tested this on trunk from today and it works for me flawlessly

comment:11 Changed 5 years ago by DarkStarXxX

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Take a Look @ https://forum.openwrt.org/viewtopic.php?id=44939

Do you think that we all are too stupid?

comment:12 Changed 5 years ago by poc

Same here - no pivot root working-, with BARRIER BREAKER (Bleeding Edge, r37207) on TP-Link TL-MR10U.

Already read and tried everything related to new block mount (http://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg18908.html)

Information:

BusyBox v1.19.4 (2013-07-09 06:27:25 PDT) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (Bleeding Edge, r37207)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    1.1M    548.0K    540.0K  50% /
/dev/root                 1.8M      1.8M         0 100% /rom
tmpfs                    14.2M     56.0K     14.1M   0% /tmp
/dev/mtdblock3            1.1M    548.0K    540.0K  50% /overlay
overlayfs:/overlay        1.1M    548.0K    540.0K  50% /
tmpfs                   512.0K         0    512.0K   0% /dev
root@OpenWrt:~# cat /etc/config/fstab 
config 'global'
	option	anon_swap	'0'
	option	anon_mount	'0'
	option	auto_swap	'1'
	option	auto_mount	'1'
	option	delay_root	'0'
	option	check_fs	'0'

config 'swap'
	option	uuid	'e86ff18f-31ee-4c84-abfc-30a0cf1955f7'
	option	enabled	'1'

config 'mount'
	option	target	'/'
	option	uuid	'4929d3e5-957a-494c-bb6b-ea52a1438d52'
	option	enabled	'1'

Also:

root@OpenWrt:~# cat /overlay/etc/config/fstab
config 'global'

option anon_swap '0'
option anon_mount '0'
option auto_swap '1'
option auto_mount '1'
option delay_root '0'
option check_fs '0'

config 'swap'

option uuid 'e86ff18f-31ee-4c84-abfc-30a0cf1955f7'
option enabled '1'

config 'mount'

option target '/'
option uuid '4929d3e5-957a-494c-bb6b-ea52a1438d52'
option enabled '1'

comment:13 Changed 5 years ago by anonymous

Still no Chance to get it working again with latest trunk (Kernel 3.10.1) on TP-Link 1043ND :(

comment:14 Changed 5 years ago by reply@…

the 'block' cmd has some hidden options (not shown with block -h):

block extroot
block hotplug

so I assume that in the startup scripts for AR71xx there is a missing call for that?

just 'block mount' will not mount an extroot FS, I looked into the source code of ubox:

        if (!strcmp(argv[1], "mount"))
            return main_mount(argc, argv);

that one goes into

static int mount_device(struct blkid_struct_probe *pr, int hotplug)
{
    struct mount *m;
    char *device = basename(pr->dev);

    if (!pr)
        return -1;

    if (!strcmp(pr->id->name, "swap")) {
        if (hotplug && !auto_swap)
            return -1;
        m = find_swap(pr->uuid, device);
        if (m || anon_swap)
            swapon(pr->dev, (m) ? (m->prio) : (0));

        return 0;
    }

    if (hotplug && !auto_mount)
        return -1;

    if (find_mount_point(pr->dev)) {
        fprintf(stderr, "%s is already mounted\n", pr->dev);
        return -1;
    }

    m = find_block(pr->uuid, pr->label, device, NULL);
    if (m && m->extroot)
        return -1;

so no / or /overlay targets can ever be mounted with 'block mount' - instead 'block extroot' must be used. IMO.

can someone check that this call is done on startup on AR71xx? I have no clue where to look.

comment:15 Changed 5 years ago by anonymous

on AR71xx the startup calls 'block hotplug' with this environment:

ACTION='add'
DEVNAME='sda1'
DEVPATH='/devices/platform/ehci-platform/usb1/1-1/1-1:1.0/host0/target0:0:0/0:0:0:0/block/sda/sda1'
DEVTYPE='partition'
HOME='/'
HOTPLUG_TYPE='block'
IFS='
'
LOGNAME='root'
MAJOR='8'
MINOR='1'
OPTIND='1'
PATH='/bin:/sbin:/usr/bin:/usr/sbin'
PPID='683'
PS1='\w \$ '
PS2='> '
PS4='+ '
PWD='/'
SEQNUM='474'
SUBSYSTEM='block'
TERM='linux'
USER='root'
board='TL-MR3220-v2'

however this code will prevent to do any action:

static int mount_device(struct blkid_struct_probe *pr, int hotplug):

this will prevent to reach mount when called for hotplug and / target:

    if (m && m->extroot)
        return -1;

there are also no calls to pivot_root - this should happen somewhere during boot right? before other partitions are mounted!

comment:16 follow-up: Changed 5 years ago by anonymous

Same behavior on TLMR3220V2 Trunk r37374, pivot root doesn't work.

comment:17 in reply to: ↑ 16 Changed 5 years ago by anonymous

Replying to anonymous:

Same behavior on TLMR3220V2 Trunk r37374, pivot root doesn't work.

I checked the new wiki and now it works ok.

comment:18 Changed 5 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:19 Changed 5 years ago by anonymous

Fixed @ r37551

Thanks to Jow

comment:20 Changed 4 years ago by anonymous

For anybody who might stumble across this while Googling after following http://wiki.openwrt.org/doc/howto/extroot

Tried the above tutorial from the wiki on my Dlink DIR-505 (rev A1) and didn't have any luck getting the USB mass storage device to show up as root.

I got this to work by increasing the option delay_root in the global section of /etc/config/fstab to 10.

For reference, I have a generic USB2.0 flash drive connected to my DIR-505 via a cheapo Ritmo USB 2.0 4 port hub.

comment:21 Changed 4 years ago by scorp <admin@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

/overlay root works on latest OpenWrt Barrier Breaker r38793 / LuCI Trunk (svn-r9934) only if you use: option device '/dev/sda1' (substitute sda1 with your device). Also don't forget to add option target '/overlay'.

If you use option uuid 'someuid' like Luci and tutorials suggest it doesn't work! Here is my /etc/config/fstab which finally got it working:

config global

option anon_swap '0'
option anon_mount '0'
option auto_swap '1'
option auto_mount '1'
option delay_root '10'
option check_fs '0'

config mount

option device '/dev/sda1'
option target '/overlay'
option fstype 'ext4'
option options 'rw,sync'
option enabled '1'
option is_rootfs '1'


config swap

option device '/dev/sda2'
option enabled '1'

I wish OpenWrt would have and easy usb root and swap installation as Gargoyle has. Haven't tested if it works also with option delay_root '0', lost already to much time=days with this. Please fix code and tutorials!

comment:22 Changed 4 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

I recently tested mounting by label, by uuid and by device node in latest trunk and verified that they're working correctly.

comment:23 Changed 4 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hi jow, please can you test again?
I'm using OpenWrt Barrier Breaker r39394 / LuCI Trunk (svn-r9951) and extroot configured with LuCI doesn't works!
No problem with 12.09, extroot doesn't work with r39394 and mr3220 and mr3420

Thanks

comment:24 Changed 4 years ago by anonymous

I tried everything but always

Thu Sep 5 16:24:05 2013 user.emerg syslog: this file has been obseleted. please call "/sbin/block mount" directly
Thu Sep 5 16:24:06 2013 user.emerg syslog: /dev/mtdblock3 is already mounted

comment:25 Changed 4 years ago by anonymous

Please close this ticket, with delay root 15 is working.

comment:26 Changed 4 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:27 follow-up: Changed 4 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hmm, again not able to mount extroot on boot. Fresh install of r39972 (ar71xx - wndr3800) with all of the necessary packages to mount ext4 from a usb drive using block-mount. Recreated fresh extroot on usb drive. Mount and block-mount work just fine manually. I've tried everything suggested on the extroot wiki, but the instructions are conflicting and appear to be outdated. I've also never seen '/tmp/overlay-disabled' during this episode or at any other time using extroot (whether extroot was working or not).

Checked & double-checked:

  • usb storage & ext4 packages
  • delay_root
  • existence & removal of /etc/.extroot-uuid
  • fstab settings, including mounting by device, uuid, and label
  • using target '/overlay' vs option 'is_rootfs'

Was previously using r38987 on same hardware with extroot working perfectly.

If this is not a bug, what are the current correct steps to troubleshoot?

Thanks

comment:28 in reply to: ↑ 27 Changed 4 years ago by anonymous

Well, I will retract my re-opening of this issue... looks like I spoke too soon. I recompiled my image, and now mounting extroot at boot works. I can't say for sure what made the difference, but I'll post again if I find it.

comment:29 Changed 4 years ago by Gutleib@…

Another anonymous.
Dir-825, latest trunk, cannot mount extroot.
My findings: /etc/init.d/fstab always mounts /dev/mtdblock5 for /overlay, independent of config.
If I try to mount it manually, it reluctantly mounts, but all writes go to small flash.

My guess is that overlayfs has some lock on /, and it is not released or acknowledged by block mount. The default mechanism is in use and all later configs have no impact.

Also, /home mount works ok, and if I change mountpoint in /etc/config/fstab from / or /overlay, /dev/sda1 successfuly mounts.

comment:30 Changed 4 years ago by Gutleib@…

/etc/config/fstab

onfig 'global'
        option  anon_swap       '0'
        option  anon_mount      '0'
        option  auto_swap       '1'
        option  auto_mount      '1'
        option  delay_root      '15'
        option  check_fs        '1'

config 'mount'
        option  target        '/home'
        option  uuid            '282b7cca-9d24-4f16-8b19-ba42b930ee17'
#        option  device        '/dev/sda2'
        option  fstype        'ext4'
        option  options       'noatime'
        option  options       'noatime,commit=60'
#        option  options       'errors=remount-ro'
        option  enabled       '1'
#       option  enabled_fsck  '0'

config 'mount'
#        option  target          '/mnt/sda3'
        option  uuid            '411429aa-b312-43ed-8892-68306c1febed'
        option  target          '/var/log'
        option  fstype          'ext4'
        option  'options'       'noatime'
        option  'options'       'commit=60'
#        option  'options'       'errors=remount-ro'
        option  enabled         '1'


config 'mount'
        option  'target'        '/overlay'
#       option  'device'        '/dev/sda1'
        option  'uuid'          'e9a55d16-a28b-409e-ab97-2cca5a42c08c'
        option  'fstype'        'ext4'
        option  'options'       'rw'
        option  'options'       'sync'
        option  'options'       'noatime'
        option  'options'       'commit=60'
#        option  'options'       'errors=remount-ro'
#        option  'is_rootfs'     '1'
        option  'enabled'       '1'

and terminal output

root@OpenWrt:/# /etc/init.d/fstab start
this file has been obseleted. please call "/sbin/block mount" directly
block: /dev/mtdblock5 is already mounted
block: /dev/sda2 is already mounted
block: /dev/sda3 is already mounted 

and results in df

root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    3.3M      1.1M      2.2M  33% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    30.0M     52.0K     29.9M   0% /tmp
/dev/mtdblock5            3.3M      1.1M      2.2M  33% /overlay
overlayfs:/overlay        3.3M      1.1M      2.2M  33% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda2                 3.8G      8.0M      3.6G   0% /home
/dev/sda3 

PS
This is default build from repo, so, no tinkering with build.

comment:31 follow-ups: Changed 4 years ago by Gutleib@…

Ummm. I kinda solved my issue.

No idea if that matters, but I've built image from trunk src.
It didn't mount either.

But then I added

config mount
	option target	/overlay-boot
	option device	/dev/mtdblock5
	option fstype	jffs2
	option options	rw,sync
	option enabled	1
	option enabled_fsck 0

to /etc/config/fstab

After reboot everything just worked.
I stick to my guess that internal flash mount somehow prevents mount of external usb drive.

comment:32 in reply to: ↑ 31 Changed 3 years ago by anonymous

sorry for necrobumping.
just upgraded to chaos calmer trunk r44053 and had the same issue of neither pivot overlay nor pivot root working.

Editing my fstab to mount the mtdblock<n> on a different location helped.
After several reboots it still mounts my sda1 as /overlay and I am happy.

Not sure if the delay_root is needed, but it didn't harm the boot duration, so I'll leave it at 15.

config 'global'
	option	anon_swap	'0'
	option	anon_mount	'0'
	option	auto_swap	'1'
	option	auto_mount	'1'
	option	delay_root	'15'
	option	check_fs	'1'

config 'mount'
	option	tartet	'/overlay-boot'
	option	device	'/dev/mtdblock3'
	option	fstype	'jffs2'
	option	options	'rw,sync'
	option	enabled	'1'
	option	check_fs	'0'

After the first reboot and several other reboots it says:

root@router:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                  238.1M     11.1M    223.0M   5% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    14.0M    452.0K     13.6M   3% /tmp
/dev/sda1               238.1M     11.1M    223.0M   5% /overlay
overlayfs:/overlay      238.1M     11.1M    223.0M   5% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda2               914.6G     74.7M    914.5G   0% /mnt/daten
/dev/mtdblock3            4.6M      2.3M      2.4M  49% /mnt/mtdblock3

Router is a Linksys WRT160NL (ar71xx). Hope this can help someone.

Replying to Gutleib@…:

Ummm. I kinda solved my issue.

No idea if that matters, but I've built image from trunk src.
It didn't mount either.

But then I added

config mount
	option target	/overlay-boot
	option device	/dev/mtdblock5
	option fstype	jffs2
	option options	rw,sync
	option enabled	1
	option enabled_fsck 0

to /etc/config/fstab

After reboot everything just worked.
I stick to my guess that internal flash mount somehow prevents mount of external usb drive.

comment:33 in reply to: ↑ 31 Changed 3 years ago by walter.huettenmeyer@…

sorry for necrobumping.
just upgraded to chaos calmer trunk r44053 and had the same issue of neither pivot overlay nor pivot root working.

Editing my fstab to mount the mtdblock<n> on a different location helped.
After several reboots it still mounts my sda1 as /overlay and I am happy.

Not sure if the delay_root is needed, but it didn't harm the boot duration, so I'll leave it at 15.

config 'global'
	option	anon_swap	'0'
	option	anon_mount	'0'
	option	auto_swap	'1'
	option	auto_mount	'1'
	option	delay_root	'15'
	option	check_fs	'1'

config 'mount'
	option	tartet	'/overlay-boot'
	option	device	'/dev/mtdblock3'
	option	fstype	'jffs2'
	option	options	'rw,sync'
	option	enabled	'1'
	option	check_fs	'0'

After the first reboot and several other reboots it says:

root@router:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                  238.1M     11.1M    223.0M   5% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    14.0M    452.0K     13.6M   3% /tmp
/dev/sda1               238.1M     11.1M    223.0M   5% /overlay
overlayfs:/overlay      238.1M     11.1M    223.0M   5% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda2               914.6G     74.7M    914.5G   0% /mnt/daten
/dev/mtdblock3            4.6M      2.3M      2.4M  49% /mnt/mtdblock3

Router is a Linksys WRT160NL (ar71xx). Hope this can help someone.

Replying to Gutleib@…:

Ummm. I kinda solved my issue.

No idea if that matters, but I've built image from trunk src.
It didn't mount either.

But then I added

config mount
	option target	/overlay-boot
	option device	/dev/mtdblock5
	option fstype	jffs2
	option options	rw,sync
	option enabled	1
	option enabled_fsck 0

to /etc/config/fstab

After reboot everything just worked.
I stick to my guess that internal flash mount somehow prevents mount of external usb drive.

comment:34 Changed 2 years ago by valentinomoscow@…

Guys, I got only blkid on my r5880 Can't install block-mount:
root@NBG6616:~# opkg install block-mount
Upgrading block-mount on root from 0.2.0-10 to 2015-11-02-0f4571b9e484f3b3504b872afd3a11be98571c03...
Downloading http://downloads.openwrt.org/snapshots/ … r71xx.ipk.
Installing ubox (2015-07-14-907d046c8929fb74e5a3502a9498198695e62ad8) to root...
Downloading http://downloads.openwrt.org/snapshots/ … r71xx.ipk.
Collected errors:

  • check_data_file_clashes: Package ubox wants to install file /sbin/logread

But that file is already provided by package * busybox

  • opkg_install_cmd: Cannot install package block-mount.

And I got :
root@NBG6616:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
rootfs 384 276 108 72% /
/dev/root 15232 14864 368 98% /rom
tmpfs 63236 8988 54248 14% /tmp
tmpfs 512 0 512 0% /dev
/dev/mtdblock3 384 276 108 72% /overlay
overlayfs:/overlay 384 276 108 72% /
/dev/sda5 1947559 8322 1838681 0% /tmp/overlay-disabled
/dev/sdb5 1947559 8322 1838681 0% /tmp/storage/usb2/usb2-1
Help me with this please!

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.