Modify

Opened 5 years ago

Closed 3 years ago

#13727 closed defect (moved_to_github)

asterisk11-chan-iax2 not working

Reported by: anonymous Owned by: slachta
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Asterisk IAX2 Cc:

Description

Has anyone managed to get IAX2 working on Asterisk 11.4?

I seems like it is unable to dequeue the network packets.

If I run: netstat -nlp
I get something like this:
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
udp 4480 0 0.0.0.0:4569 0.0.0.0:* 4239/asterisk

Notice how "Recv-Q" goes up and up and never goes down.

Incoming IAX2 calls simply brings the "Recv-Q" up in values but asterisk seens nothing.
Outgoing calls get a "Auto-congesting call due to slow response" since it can't see the response.

Thanks,
Gérald

Attachments (0)

Change History (13)

comment:1 Changed 5 years ago by anonymous

Might be fixed in 11.5.0-rc1 (search for "IAX2, prevent network thread starting").

comment:2 Changed 5 years ago by slachta@…

There is newer version of asterisk (11.5.0) that should have fixed this issue. Could you try this again if IAX2 does work? It does for me. If it does not work for you, I will start to investigate where the problem is.

Jiri

comment:3 Changed 5 years ago by anonymous

I finished my tests and unfortunately the behaviour has not changed with 11.5.0

Gérald

comment:4 Changed 4 years ago by anonymous

Asterisk 11.5.1 - nothing changed :( Does anyone have in working?

comment:5 Changed 4 years ago by slachta@…

Hello,

I've succesfully tested call between two users via IAX2 protocol on ar71xx and x86. Could you paste your asterisk and openwrt buildroot configuration?

My simple working config was:

/etc/asterisk/iax.conf

[1]
username=1
type=friend
context=test
host=dynamic
secret=test
canreinvite=no
allow=all
requirecalltoken=no

[2]
username=1
type=friend
context=test
host=dynamic
secret=test
canreinvite=no
allow=all
requirecalltoken=no

/etc/asterisk/extensions.conf

[test]
exten => _X,1,Dial(IAX2/\${EXTEN},25,r)

and call between two peers (from peer 1 to peer 2) worked flawlessly. Also if it does not work for you, you can debug it with command "iax2 set debug on" which prints all debug info for iax2 protocol.

Jiri Slachta

I need more info about your platform, asterisk config, openwrt config and specific version of openwrt(git commit hash or svn commit number).

comment:6 Changed 4 years ago by slachta

  • Owner changed from developers to slachta
  • Status changed from new to assigned

comment:7 Changed 4 years ago by slachta

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:8 Changed 4 years ago by tsolo

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I am having the same issue as Gérald using Asterisk 11.8.1 and OpenWrt Barrier Breaker r40864 on tp-link wdr3500.
I've also tested the current trunk with no success. Any help is appreciated.

comment:9 Changed 4 years ago by slachta

  • Priority changed from normal to response-needed

Hello,

would you be so kind to test the iax2 module functionality with timing modules? Please install res-timing-timerfd and res-timing-pthread (especially the timerfd module). Even if I tried to replicate your issue, iax2 worked without any problem for me.

If the res-timing-timerfd solves the issue, I can add this module as a dependency to iax2 module.

Thank you so much,
Jiri

comment:10 Changed 4 years ago by tsolo

Hello,

After installing res-timing-timerfd the problem is solved, I can successfully register iax client and there are 0 packets in the Recv-Q.
But, after loading the module sound become choppy and unusable ( both iax and sip ) using chan_dongle. I have tested different soft clients, and the system is at 90% idle. If you have any idea why, please share.

Thank you very much for the help and the great work with asterisk package.

comment:11 Changed 4 years ago by slachta

Would you be so kind to test your issue on asterisk18 with the same configuration?

comment:12 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:13 Changed 3 years ago by jogo

  • Resolution set to moved_to_github
  • Status changed from reopened to closed

Asterisk is now maintained here: https://github.com/openwrt/telephony.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.