Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13722 closed defect (duplicate)

PPTP Interface not working on r36968

Reported by: finas Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

OpenWRT has some interfaces, LAN ( PPPOE ), IPTV ( DHCP ), SS ( PPTP ).

The PPTP interface doesn't work. On the network interfaces page it doesn't come up.

On CLI:

route -n:
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 194.65.169.xyz 0.0.0.0 UG 0 0 0 pppoe-wan
192.168.88.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
194.65.169.xyz 0.0.0.0 255.255.255.255 UH 0 0 0 pppoe-wan
195.23.abc.abc 194.65.169.xyz 255.255.255.255 UGH 0 0 0 pppoe-wan ( this is the PPTP connection ).

so, at least part of the connection apears to be set up, but OpenWRT does not gain any IP interface, on ifconfig:

br-lan Link encap:Ethernet HWaddr 4C:E6:76:F9:56:54

inet addr:192.168.88.254 Bcast:192.168.88.255 Mask:255.255.255.0
inet6 addr: fe80::4ee6:76ff:fef9:5654/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5248 errors:0 dropped:0 overruns:0 frame:0
TX packets:5743 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:841109 (821.3 KiB) TX bytes:3001497 (2.8 MiB)

eth0 Link encap:Ethernet HWaddr 4C:E6:76:F9:56:54

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4448 errors:0 dropped:0 overruns:0 frame:0
TX packets:5446 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:749920 (732.3 KiB) TX bytes:2727788 (2.6 MiB)
Interrupt:4

eth1 Link encap:Ethernet HWaddr 4C:E6:76:F9:56:56

inet6 addr: fe80::4ee6:76ff:fef9:5656/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3748 errors:0 dropped:0 overruns:0 frame:0
TX packets:3442 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1878743 (1.7 MiB) TX bytes:487325 (475.9 KiB)
Interrupt:5

eth1.10 Link encap:Ethernet HWaddr 4C:E6:76:F9:56:56

inet6 addr: fe80::4ee6:76ff:fef9:5656/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3739 errors:0 dropped:0 overruns:0 frame:0
TX packets:3432 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1810361 (1.7 MiB) TX bytes:471973 (460.9 KiB)

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:160 errors:0 dropped:0 overruns:0 frame:0
TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12660 (12.3 KiB) TX bytes:12660 (12.3 KiB)

pppoe-wan Link encap:Point-to-Point Protocol

inet addr:144.64.29.252 P-t-P:194.65.169.xyz Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:2859 errors:0 dropped:0 overruns:0 frame:0
TX packets:2547 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:1750475 (1.6 MiB) TX bytes:388994 (379.8 KiB)

the remote PPTP server is serving ip's on the 192.168.1.x range, but OpenWRT doesnt gain any.

the relevant line that is running ( ps ) is:

/usr/sbin/pppd nodetach ipparam SS ifname pptp-SS nodefaultroute usepeerdns persist maxfail 1 user abcd password efgh ip-up-script /lib/netifd/ppp-up ipv6-up-script /lib/netif

the configuration I'm using is the same I always used, and this worked a couple of months ago, maybe trunk from two months ago. I updated to trunk now, and not working.

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by finas

sorry,
OpenWRT has some interfaces, LAN ( Fixed IP ), WAN ( PPPOE ), IPTV ( DHCP ), SS ( PPTP ).

comment:2 Changed 5 years ago by finas

log error is:
Jun 19 00:22:29 gateway daemon.err pppd[3137]: PPTP: failed to connect PPTP socket (No route to host)

comment:3 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 5 years ago by jow

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 5 years ago by jow

  • Resolution set to duplicate
  • Status changed from reopened to closed

Sorry, this was meant to be a dupe of #13407

comment:6 Changed 5 years ago by finas

Sorry for the dupe!

any idea if it is going to be fixed/ when?
please don't see this question as a way of making pressure, it is not. I can just go back to an older version!

thanks!!

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.