Modify

Opened 5 years ago

Last modified 20 months ago

#13688 reopened defect

r36408 breaks hostapd/nl80211 on phy0 for a b43-phy

Reported by: earias@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc: nbd@…

Description

Previous release r36407 works perfectly.

System log (extract):

...
Jun 11 12:07:05 OpenWrt kern.info kernel: [   11.712000] NET: Registered protocol family 10
Jun 11 12:07:05 OpenWrt kern.warn kernel: [   12.168000] PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
Jun 11 12:07:05 OpenWrt kern.info kernel: [   12.600000] b43-phy0: Broadcom 43225 WLAN found (core revision 23)
Jun 11 12:07:05 OpenWrt kern.info kernel: [   12.608000] b43-phy0: Found PHY: Analog 8, Type 4 (N), Revision 6
Jun 11 12:07:05 OpenWrt kern.info kernel: [   12.612000] Broadcom 43xx driver loaded [ Features: PNL ]
Jun 11 12:07:05 OpenWrt kern.debug kernel: [   12.916000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Jun 11 12:07:05 OpenWrt kern.info kernel: [   12.952000] PPP generic driver version 2.4.2
Jun 11 12:07:05 OpenWrt kern.info kernel: [   13.172000] ip_tables: (C) 2000-2006 Netfilter Core Team
Jun 11 12:07:05 OpenWrt kern.info kernel: [   13.384000] NET: Registered protocol family 24

...

Jun 11 23:41:51 OpenWrt user.info sysinit: Configuration file: /var/run/hostapd-phy0.conf
Jun 11 23:41:51 OpenWrt user.info sysinit: Could not set interface wlan0 flags (UP): Cannot assign requested address
Jun 11 23:41:51 OpenWrt user.info sysinit: nl80211: Could not set interface 'wlan0' UP
Jun 11 23:41:51 OpenWrt user.info sysinit: nl80211: Failed to add interface wlan0 into bridge br-lan: Invalid argument
Jun 11 23:41:51 OpenWrt user.info sysinit: nl80211 driver initialization failed.
Jun 11 23:41:51 OpenWrt user.info sysinit: Failed to start hostapd for phy0
...

My system:

[    0.000000] Linux version 3.8.8 (emilito@OpenWRT-dev.emilioarias) (gcc version 4.6.4 (OpenWrt/Linaro GCC 4.6-2012.12 r36408) ) #1 Tue Jun 11 14:17:49 CEST 2013
[    0.000000] Detected Broadcom 0x6328 CPU revision b0
[    0.000000] CPU frequency is 320 MHz
[    0.000000] 32MB of RAM installed
[    0.000000] registering 32 GPIOs
[    0.000000] board_bcm963xx: Boot address 0xb8000000
[    0.000000] board_bcm963xx: CFE version: A4001N-V0003
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a075 (Broadcom BMIPS4350)
[    0.000000] board_bcm963xx: board name: 963281T_TEF

Attachments (5)

network (754 bytes) - added by earias@… 5 years ago.
wireless (359 bytes) - added by earias@… 5 years ago.
System Log r37521 Defaults + Wifi enable.txt (18.7 KB) - added by earias@… 5 years ago.
r37521 log with default configuration after wifi enabled with defaults.
System Log r37521 myconfig.txt (18.6 KB) - added by earias@… 5 years ago.
r37521 with my configuration (formerly attached)
Snap1.png (31.6 KB) - added by Emilio <earias@…> 4 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 5 years ago by anonymous

And latest trunk works perfecty without r36408.

comment:2 Changed 5 years ago by nbd

please try latest trunk *with* that commit

comment:3 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:4 Changed 5 years ago by earias@…

  • Resolution no_response deleted
  • Status changed from closed to reopened

BB r37357 fails the same way:

Tue Jul 16 09:25:52 2013 daemon.info sysinit: Could not set interface wlan0 flags (UP): Cannot assign requested address
Tue Jul 16 09:25:52 2013 daemon.info sysinit: nl80211: Could not set interface 'wlan0' UP
Tue Jul 16 09:25:52 2013 daemon.info sysinit: nl80211 driver initialization failed.
Tue Jul 16 09:25:52 2013 daemon.info sysinit: Failed to initialize interface
Tue Jul 16 09:25:52 2013 daemon.info sysinit: Failed to start hostapd for phy0

comment:5 Changed 5 years ago by nbd

please post your configuration (network and wireless)

Changed 5 years ago by earias@…

Changed 5 years ago by earias@…

Changed 5 years ago by earias@…

r37521 log with default configuration after wifi enabled with defaults.

Changed 5 years ago by earias@…

r37521 with my configuration (formerly attached)

comment:6 Changed 4 years ago by nbd

I see in your log that it fails to detect SPROM data. Could it be that wlan0 gets created with a MAC address of 00:00:00:00:00:00?

comment:7 Changed 4 years ago by Emilio <earias@…>

SPROM is not detected OK for this device in any version, but MAC is assigned 02:00:00:00:00:00 in r36407 and before. It is change in trunk/package/mac80211/files/lib/wifi/mac80211.sh (mac80211_generate_mac()) r36408, that breaks MAC assignment for this device.

I do not understand the logic of the function, so I cannot help.... Comments say that MAC can be assigned in device section or automatically generated....

Please let me know how can I help.

Thanks a lot!!

comment:8 Changed 4 years ago by nbd

The problem is not in the change you keep mentioning. The problem is the fact that your device does not come up with a proper MAC address. What kind of device are you using? And is it one that is already supposed to be properly supported by OpenWrt?

Changed 4 years ago by Emilio <earias@…>

comment:9 Changed 4 years ago by Emilio <earias@…>

The device is an ADB P.DG 4001N (without the last 1) supported as in http://wiki.openwrt.org/toh/adb/p.dg_a4001n1 (See the attached logs).

Where is is supposed to be stored the MAC address for the device? The label on the back prints a MAC and that MAC is assigned to the br-lan interface, that interface bridges lan (ethx) with wlan0. (See atttached image). Curiously, the Wireless line on the image says (lan) ¿shouldn't it be wlan0 or radio0?)

I can try the original FW to check MAC address for wlan.

comment:10 Changed 4 years ago by Emilio <earias@…>

OK, the original FW sets wlan0 MAC to ethx MAC + 1.

comment:11 Changed 4 years ago by Emilio <earias@…>

Where can I find the "device section" stated in the file mac80211.sh?

comment:12 Changed 3 years ago by fernando.arconada@…

Anyone have the wifi working? I have the same problem. any patch?
I'm using the last stable release BARRIER BREAKER (14.07, r43737)

comment:13 Changed 3 years ago by fernando.arconada@…

Anyone have the wifi working? I have the same problem. any patch?
I'm using the last stable release BARRIER BREAKER (14.07, r43737)

comment:14 Changed 3 years ago by jayjay@…

I have the same device, BARRIER BREAKER (14.07, r42625) and the same problem.

comment:15 Changed 3 years ago by jayjay@…

Ok, I could fix the issue for me when adding
option macaddr 'xx:yy:..' to /etc/config/wireless
section wifi-iface
but I stumbled into a second issue which is adressed by ticket #13222 (unsolved).

comment:16 Changed 20 months ago by earias@…

This device is supported now (including SPROM).

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.