Modify

Opened 5 years ago

Last modified 4 years ago

#13680 new defect

openwrt not mounting root filesystem on NS M5

Reported by: trhura@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Attitude Adjustment 12.09
Keywords: preinit, init, uboot Cc: allen.mui@…

Description

Hello guys,

I am trying to boot openwrt on Ubiquiti NS M5. Openwrt is not booting up properly — root filesystem is not getting mounted and booted into fail-safe mode. I can recover the system by mounting rootfs (mount_root) and launch inittab (/etc/init.d/rcS S boot).

I have tried with both attitude, and trunk images. And I have tried with another NS M5 device. The problem persists with those images/devices. However, if I use the same image with NS LoCo M5, it is booting properly. So, this problem is specific to NS M5.

Another strange thing is it is booting properly when the serial console is attached and kernel command line is somewhat different.

with serial console — [ 0.000000] Kernel command line: board=UBNT-NM console=ttyS0,115200 mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)rod

without serial console — [ 0.000000] Kernel command line: board=UBNT-NM console=ttyS0,115200 mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)ro,7552k@0x50000(firmware) rootfstype=squashfs,jffs2 noinitrd

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.