Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13638 closed defect (worksforme)

AA: restarting firewall3 does not restore qos iptables

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Attitude Adjustment 12.09.1
Component: packages Version: Attitude Adjustment 12.09
Keywords: firewall3 iptables qos qos-scripts Cc:

Description

Restarting the firewall (on both Luci and command line) with the firewall3 package will not re-create qos-scripts rules in the mangle table. They will be missing until next reboot or when "/etc/init.d/qos restart" is ran.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

That is not a bug of the firewall3 package but a design limitation of the old firewall. Also use reload, not restart if you want to preserve external rules.

comment:2 Changed 5 years ago by jow

LuCI in 12.09 still calls the old firewall init script and /etc/init.d/firewall3 restart flushes everything, so use /etc/init.d/firewall3 reload or fw3 reload to properly reinitialize the firewall without flushing QoS rules. This issue will solve itself once we actually switch to firewall3 in AA.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.