Modify

Opened 5 years ago

Closed 5 years ago

#13630 closed defect (no_response)

Module loading broken

Reported by: projekt-wlan@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

Hi,

the current module loading is broken, see #11107.
For me, insmod expects a filename including path, but is given a module name - so it does not work.

# grep ath9k$ /etc/modules.d/*
/etc/modules.d/28-ath9k:ath9k

root@femap0106:/etc/modules.d# insmod ath9k
insmod: can't read 'ath9k': No such file or directory

# strace -f insmod ath9k
execve("/sbin/insmod", ["insmod", "ath9k"], /* 11 vars */) = 0
brk(0) = 0x10284000
brk(0x1028445c) = 0x1028445c
ioctl(0, TCGETS, {B38400 opost isig icanon echo ...}) = 0
ioctl(1, TCGETS, {B38400 opost isig icanon echo ...}) = 0
getuid() = 0
brk(0x1028545c) = 0x1028545c
brk(0x10286000) = 0x10286000
uname({sys="Linux", node="femap0106", ...}) = 0
open("ath9k", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
brk(0x10287000) = 0x10287000
write(2, "insmod: can't read 'ath9k': No s"..., 54insmod: can't read 'ath9k': No such file or directory
) = 54
exit_group(1) = ?

The solution has already been given in 11107 and is to replace insmod with modprobe, which does the path lookup.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Damian Kaczkowski <damian.kaczkowski+openwrt@…>

For me:

rmmod ath9k
insmod ath9k

works without a problem (on self compiled image however)

comment:2 Changed 5 years ago by nbd

Did you change anything weird in your config? Please show the output of ./scripts/diffconfig.sh

comment:3 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.