Modify

Opened 5 years ago

Last modified 4 years ago

#13599 new defect

bandwidth allocation problems with external USB FullSpeed audio at EHCI platform

Reported by: covokoff@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Attitude Adjustment 12.09
Keywords: usb, audio Cc:

Description

Hi. Im using AA 12.09 @36714.
USB Full Speed Audio device not working via USB 2.0 Multi-TT Hub.
When trying to play Internet radio in the log is:
cannot submit datapipe for urb 0, error -28: not enough bandwidth

USB sound card is Audio Class 1.0 deivice.
Tested on Tp-link MR3020 V1.7, DIR615 C2 with usb-mod. installed Kmod-sound-core, Kmod-usb-audio, madplay.

Attachments (0)

Change History (3)

comment:1 in reply to: ↑ description Changed 5 years ago by neryba@…

Replying to covokoff@…:

Hi. Im using AA 12.09 @36714.
USB Full Speed Audio device not working via USB 2.0 Multi-TT Hub.
When trying to play Internet radio in the log is:
cannot submit datapipe for urb 0, error -28: not enough bandwidth

USB sound card is Audio Class 1.0 deivice.
Tested on Tp-link MR3020 V1.7, DIR615 C2 with usb-mod. installed Kmod-sound-core, Kmod-usb-audio, madplay.

http://wiki.openwrt.org/toh/tp-link/tl-mr3020

AR7240 have USB 1.1

cat /sys/bus/usb/devices/usb1/speed

return USB speed

comment:2 Changed 5 years ago by covokoff@…

root@OpenWrt:~# cat /sys/bus/usb/devices/usb1/speed
480

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.