Modify

Opened 5 years ago

Closed 4 years ago

#13598 closed defect (fixed)

[asus wl-500-gpv2] unaligned access kernel crash after skb_warn_bad_offload()

Reported by: pupykin.s@… Owned by: developers
Priority: normal Milestone:
Component: base system Version: Trunk
Keywords: Cc:

Description

Log is from netconsole.

OpenWRT build: trunk r36674

Attachments (3)

asus-wl500gpv2-crash.txt (23.4 KB) - added by pupykin.s@… 5 years ago.
kernel crash
router.log (22.5 KB) - added by anonymous 5 years ago.
router_serial.log (9.5 KB) - added by anonymous 5 years ago.
2 panics captured using serial console

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by pupykin.s@…

kernel crash

comment:1 Changed 5 years ago by nbd

please enable CONFIG_KERNEL_KALLSYMS in your .config, so that the kernel crash log includes the information necessary to track down the cause.

comment:2 Changed 5 years ago by anonymous

enabled, waiting for bad offload

Changed 5 years ago by anonymous

comment:3 Changed 5 years ago by anonymous

router.log looks slightly damaged probably because of netconsole, but it contains function names.

Changed 5 years ago by anonymous

2 panics captured using serial console

comment:4 Changed 5 years ago by anonymous

I attached ttl2usb converter and got serial console. router_serial.log contains "unaligned access" and "unable to handle kernel paging request".

comment:5 Changed 4 years ago by pupykin.s@…

It looks like some kind of race conditions. I've limited outgoing bandwidth to 8Mbit on all interfaces using "tc" and there is no more crashes now.

Sometimes watchdog fires when I watch IPTV. Hopefully starting watchdog daemon with "nice -n -20" will help.

comment:6 Changed 4 years ago by anonymous

Probably it was kmod-switch bug. After switching to 3.10 kernel and b53 it looks working..

comment:7 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

With kernel 3.10 it works.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.