Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13595 closed defect (fixed)

brcm47xx usb videocam does not work i2c v4l2

Reported by: anonymous Owned by: developers
Priority: low Milestone:
Component: packages Version: Trunk
Keywords: Cc:


After installing the openwrt-brcm47xx-squashfs.trx snapshot (27-May-2013) on my Asus RT-N16, my uvc Logitech webcam does not work. I followed and get the following errors during startup (dmesg)
{{{ [ 13.228000] videodev: Unknown symbol i2c_unregister_device (err 0)
[ 13.256000] v4l2_common: Unknown symbol i2c_new_device (err 0)
[ 13.260000] v4l2_common: Unknown symbol v4l2_subdev_init (err 0)
[ 13.268000] v4l2_common: Unknown symbol v4l2_device_register_subdev (err 0)
[ 13.276000] v4l2_common: Unknown symbol i2c_unregister_device (err 0)
[ 13.280000] v4l2_common: Unknown symbol v4l2_ctrl_get_menu (err 0)
[ 13.288000] v4l2_common: Unknown symbol i2c_new_probed_device (err 0)
[ 13.296000] v4l2_common: Unknown symbol v4l2_ctrl_fill (err 0)
[ 13.336000] videobuf2_core: Unknown symbol video_devdata (err 0)
[ 13.340000] videobuf2_core: Unknown symbol v4l2_fh_release (err 0)
[ 13.348000] videobuf2_core: Unknown symbol v4l2_event_pending (err 0)
[ 13.460000] uvcvideo: Unknown symbol vb2_queue_init (err 0)
[ 13.464000] uvcvideo: Unknown symbol v4l2_fh_exit (err 0)
[ 13.472000] uvcvideo: Unknown symbol vb2_streamoff (err 0)
[ 13.476000] uvcvideo: Unknown symbol vb2_queue_release (err 0)
[ 13.484000] uvcvideo: Unknown symbol vb2_poll (err 0)
[ 13.488000] uvcvideo: Unknown symbol v4l2_prio_max (err 0)
[ 13.492000] uvcvideo: Unknown symbol v4l2_fh_del (err 0)
[ 13.500000] uvcvideo: Unknown symbol v4l2_fh_add (err 0)
[ 13.504000] uvcvideo: Unknown symbol v4l2_prio_change (err 0)
[ 13.512000] uvcvideo: Unknown symbol vb2_dqbuf (err 0)
[ 13.516000] uvcvideo: Unknown symbol vb2_reqbufs (err 0)
[ 13.524000] uvcvideo: Unknown symbol video_devdata (err 0)
[ 13.528000] uvcvideo: Unknown symbol vb2_streamon (err 0)
[ 13.532000] uvcvideo: Unknown symbol v4l2_ctrl_replace (err 0)
[ 13.540000] uvcvideo: Unknown symbol v4l2_prio_check (err 0)
[ 13.548000] uvcvideo: Unknown symbol v4l_printk_ioctl (err 0)
[ 13.552000] uvcvideo: Unknown symbol vb2_querybuf (err 0)
[ 13.556000] uvcvideo: Unknown symbol vb2_qbuf (err 0)
[ 13.564000] uvcvideo: Unknown symbol vb2_buffer_done (err 0)
[ 13.568000] uvcvideo: Unknown symbol vb2_plane_vaddr (err 0)
[ 13.576000] uvcvideo: Unknown symbol v4l2_fh_init (err 0)
[ 13.580000] uvcvideo: Unknown symbol video_unregister_device (err 0)
[ 13.588000] uvcvideo: Unknown symbol v4l2_prio_init (err 0)
[ 13.592000] uvcvideo: Unknown symbol v4l2_event_subscribe (err 0)
[ 13.600000] uvcvideo: Unknown symbol video_device_alloc (err 0)
[ 13.608000] uvcvideo: Unknown symbol v4l2_device_register (err 0)
[ 13.612000] uvcvideo: Unknown symbol v4l2_ctrl_merge (err 0)
[ 13.620000] uvcvideo: Unknown symbol video_register_device (err 0)
[ 13.624000] uvcvideo: Unknown symbol v4l2_event_dequeue (err 0)
[ 13.632000] uvcvideo: Unknown symbol v4l2_device_unregister (err 0)
[ 13.636000] uvcvideo: Unknown symbol video_usercopy (err 0)
[ 13.644000] uvcvideo: Unknown symbol video_device_release (err 0)
[ 13.652000] uvcvideo: Unknown symbol vb2_mmap (err 0)
[ 13.656000] uvcvideo: Unknown symbol v4l2_event_queue_fh (err 0)
[ 13.660000] uvcvideo: Unknown symbol v4l2_event_unsubscribe (err 0)

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by anonymous

version is BARRIER BREAKER (Bleeding Edge, r36730)

comment:2 Changed 5 years ago by anonymous


Any update on this? Is it possible to revert to previous build?


comment:3 Changed 5 years ago by jogo

Try installing kmod-i2c-core. Looks like a missing dependency.

comment:4 Changed 5 years ago by bur

Hi Jogo,

thank you for your reply. I tried installing i2c-core but no luck. I posted my issue on the openwrt forum as well just now (

If you have any other suggestion, please let me know. Thanks.

comment:5 Changed 5 years ago by vlipert@…

My webcam works, it seems really problem that you are missing some package. Try install this all packages:

opkg install kmod-usb-ohci
opkg install kmod-i2c-core
opkg install kmod-video-gspca-*
opkg install v4l-utils

  • replace with driver that is for your webcam, in my case it is kmod-video-gspca-zc3xx

comment:6 Changed 5 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

This problem should be fixed with r37421.

comment:7 follow-up: Changed 4 years ago by bur

@vlipert: I only have webcams that support "pwc" and "uvc", so "gspca" is no use, as far as I understand. However I did try to install "v4l-utils" and received following error:

root@OpenWrt:~# opkg install v4l-utils
Unknown package 'v4l-utils'.
Collected errors:

  • opkg_install_cmd: Cannot install package v4l-utils.

Any additional thoughts?

@hauke: I'm still having a problem getting my webcam working. Could you please help me how to apply the fix you linked to. Cheers.

comment:8 Changed 4 years ago by anonymous

@jogo: Could you please let me know how I can apply your fix. Cheers.

comment:9 in reply to: ↑ 7 Changed 4 years ago by vlipert@…

Replying to bur:

@vlipert: I only have webcams that support "pwc" and "uvc", so "gspca" is no use, as far as I understand. However I did try to install "v4l-utils" and received following error:

root@OpenWrt:~# opkg install v4l-utils
Unknown package 'v4l-utils'.
Collected errors:

  • opkg_install_cmd: Cannot install package v4l-utils.

Any additional thoughts?

Try at first run

opkg update

Ok, so in your case you don't need gspca drivers, but all other packages you should have installed

comment:10 Changed 4 years ago by bur

@vlipert: I managed to get v4l-utils installed, but I had to re-flash my firmware. I installed all the necessary packages (see link I already posted above for full description), but I still receive error when running mjpg-streamer.

Perhaps the random thing though is that I don't get the same error when I run dmesg, as the first post mentioned above.

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.