Modify

Opened 5 years ago

Last modified 4 years ago

#13548 new defect

boost shared libraries gets wrong file extension when building on OS X

Reported by: per@… Owned by: developers
Priority: normal Milestone: Attitude Adjustment 12.09.1
Component: packages Version: Attitude Adjustment 12.09
Keywords: Cc:

Description

Building boost for openwrt fails on OS X. The build goes ok, but the shared libraries are created with a .dylib extension instead of .so, and the build halts. I tried just renaming them which lets the build go on, but the SONAME inside the library is still wrong so it's likely to still not work.

Steps to reproduce:
make menuconfig
(enable boost-system in libraries)
make

Also reported at https://svn.boost.org/trac/boost/ticket/8592

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by anonymous

Had the same issue with 1_47_0 on Mac. Fixed by adding target-os=linux to the ./b2 --toolset option. This works for both Linux and Mac builds.

Index: Makefile
===================================================================
--- Makefile	(revision 36978)
+++ Makefile	(working copy)
@@ -194,7 +194,7 @@
 		bjam \
 			'-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
 			$(filter -j%,$(PKG_JOBS)) \
-			--toolset=gcc-$(ARCH) --build-type=minimal --layout=system \
+			--toolset=gcc-$(ARCH) target-os=linux --build-type=minimal --layout=system \
 			--disable-long-double \
 			$(CONFIGURE_ARGS) \
 			$(if $(CONFIG_PACKAGE_boost-chrono),,--without-chrono) \

comment:2 Changed 4 years ago by per@…

trunk is still affected, patch still works. The file is at feeds/oldpackages/libs/boost/Makefile if anyone wonders.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.