Modify

Opened 5 years ago

Last modified 2 years ago

#13542 reopened defect

A new mac80211 warning, probably aggregation related

Reported by: duvi Owned by: developers
Priority: normal Milestone:
Component: base system Version: Trunk
Keywords: Cc:

Description

I've never seen this one before.
TL-WR1043ND, r36655

root@OpenWrt:~# cat /etc/config/wireless
config wifi-device      'radio0'
        option disabled '0'
        option type     'mac80211'
        option path     'platform/ath9k'
        option hwmode   '11ng'
        option htmode   'HT20'
        option noscan   '0'
        option channel  '1'
        option txpower  '20'
        list ht_capab   'SHORT-GI-40'
        list ht_capab   'DSSS_CCK-40'

config wifi-iface
        option device   'radio0'
        option mode     'ap'
        option network  'lan'
        option ssid     'prvate'
        option encryption       'psk-mixed'
        option key      '##########'
        option wpa_group_rekey  '3600'

config wifi-iface
        option device   'radio0'
        option mode     'ap'
        option network  'pub'
        option ssid     'public'
        option encryption       'psk-mixed'
        option key      '##########'
        option wpa_group_rekey  '3600'
[13052.480000] ------------[ cut here ]------------
[13052.490000] WARNING: at /home/duvi/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2013-04-16/net/mac80211/agg-tx.c:701 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
[13052.510000] Modules linked in: em_nbyte sch_dsmark sch_gred em_meta sch_htb sch_teql em_cmp act_ipt sch_red sch_prio em_text sch_tbf cls_basic sch_sfq act_police act_connmark act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_codel sch_ingress usblp ath79_wdt ohci_hcd ledtrig_usbdev ledtrig_netdev ip6t_REJECT ip6t_rt ip6t_hbh ip6t_mh ip6t_ipv6header ip6t_frag ip6t_eui64 ip6t_ah ip6table_raw ip6table_mangle ip6table_filter ip6_tables nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_irc nf_nat_ftp nf_conntrack_irc nf_conntrack_ftp xt_HL xt_hl xt_ecn ipt_ECN xt_CLASSIFY xt_time xt_tcpmss xt_statistic xt_mark xt_length xt_DSCP xt_dscp xt_string xt_layer7 ipt_MASQUERADE iptable_nat xt_nat nf_nat_ipv4 nf_nat xt_recent xt_helper xt_connmark xt_connbytes pppoe xt_conntrack xt_CT iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_platform ehci_hcd pppox ipt_REJECT xt_TCPMSS xt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables sit tunnel4 tun ppp_async ppp_generic slhc ath9k(O) ath9k_common(O) ath9k_hw(O) ath(O) mac80211(O) usbcore usb_common nls_base ts_fsm ts_bm ts_kmp crc_ccitt ipv6 cfg80211(O) compat(O) arc4 crypto_blkcipher aead ledtrig_timer ledtrig_default_on leds_gpio gpio_button_hotplug(O)
[13052.620000] Call Trace:
[13052.630000] [<8006df08>] dump_stack+0x8/0x34
[13052.630000] [<8007680c>] warn_slowpath_common+0x78/0xa4
[13052.640000] [<80076850>] warn_slowpath_null+0x18/0x24
[13052.640000] [<80d4a35c>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
[13052.650000] [<80d4e8ac>] ieee80211_ibss_leave+0x12d8/0x1988 [mac80211]
[13052.650000] [<8008bf64>] process_one_work+0x264/0x3a4
[13052.660000] [<8008c55c>] worker_thread+0x2d0/0x3e0
[13052.660000] [<8009090c>] kthread+0xb0/0xb8
[13052.670000] [<80060870>] ret_from_kernel_thread+0x10/0x18
[13052.670000]
[13052.680000] ---[ end trace d934d61a45a87dea ]---

Attachments (1)

2040.png (200.5 KB) - added by duvi 3 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in r36656

comment:2 Changed 5 years ago by duvi

I was just about to write that every time this happens, my laptop doesn't transmit anything anymore (although it stays connected), and I have to disconnect and reconnect to be able to use the network again.
I'll compile and test right away, thanks!

comment:3 follow-up: Changed 5 years ago by sfisher143@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Getting this message in the logs now, any suggestions?


May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.670000] WARNING: at /Openwrt/trunk/build_dir/target-mips_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2013-04-16/net/mac80211/agg-tx.c:701 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
May 18 11:07:19 OpenWrt kern.warn kernel: [truncated] [ 1798.690000] Modules linked in: ifb act_connmark act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_codel sch_ingress usbserial leds_wndr3700_usb ath79_wdt ledtrig_usbdev ledtr
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.820000] Call Trace:
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.830000] [<8006df08>] dump_stack+0x8/0x34
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.830000] [<8007680c>] warn_slowpath_common+0x78/0xa4
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.830000] [<80076850>] warn_slowpath_null+0x18/0x24
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.840000] [<8320a4bc>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.850000] [<8320ea40>] ieee80211_ibss_leave+0x130c/0x1a10 [mac80211]
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.850000] [<8008bf58>] process_one_work+0x264/0x3a4
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.860000] [<8008c550>] worker_thread+0x2d0/0x3e0
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.860000] [<80090900>] kthread+0xb0/0xb8
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.870000] [<80060870>] ret_from_kernel_thread+0x10/0x18
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.870000]
May 18 11:07:19 OpenWrt kern.warn kernel: [ 1798.870000] ---[ end trace 3c87a4b04068a9cf ]---

comment:4 in reply to: ↑ 3 Changed 5 years ago by hnyman <hannu.nyman@…>

Replying to sfisher143@…:

Getting this message in the logs now, any suggestions?

Based on the forum discussion ( https://forum.openwrt.org/viewtopic.php?pid=202225#p202225 ), that error was with 36655, before the fix was implemented. So, probably the ticket should still be left "fixed". You might test my 36656 build and see if the error really was fixed by r36656.

comment:5 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 Changed 4 years ago by duvi

  • Resolution fixed deleted
  • Status changed from closed to reopened

Seeing these on TL-MR3420 trunk r39586 in routed client + ap mode. Nnot sure if it's new or old error, I haven't used STA+AP config for a long time.
It seems to only happen when the device is in STA+AP mode simultaneously, I've never seen these in AP only mode.

The symptom: after a while, suddenly there is no more traffic between my laptop and the MR3420. It shows being connected, but no traffic goes through. There is no kernel warning yet.
Now I have to disconnect and reconnect my laptop to have working connection again, and this is the time when the kernel warning appears.

So first no traffic, then disconnect/reconnect laptop, then comes kernel warning, but connection is fine again.

The STA interface of the MR3420 stays connected to the main AP the whole time according to the logs (I see nothing related to the STA interface).

[14400.420000] ------------[ cut here ]------------
[14400.430000] WARNING: at /mnt/sda/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2014-01-23.1/net/mac80211/agg-tx.c:694 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
[14400.450000] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv4 mac80211 ipt_MASQUERADE cp210x cfg80211 xt_time xt_tcpudp xt_string xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_layer7 xt_helper xt_conntrack xt_connmark xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT usbserial usblp ts_kmp ts_fsm ts_bm slhc nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_irc nf_conntrack_ftp iptable_raw iptable_mangle iptable_filter ipt_REJECT ip_tables crc_ccitt compat em_nbyte sch_htb sch_gred em_meta sch_dsmark sch_teql em_cmp cls_basic act_ipt x_tables sch_tbf em_text sch_codel sch_red sch_sfq act_police sch_prio act_connmark nf_conntrack act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress ledtrig_usbdev ledtrig_netdev ipv6 arc4 crypto_blkcipher leds_gpio ohci_hcd ledtrig_timer ledtrig_default_on ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common
[14400.540000] CPU: 0 PID: 1334 Comm: kworker/u2:2 Tainted: G        W    3.10.28 #1
[14400.550000] Workqueue: phy0 ieee80211_ibss_leave [mac80211]
[14400.550000] Stack : 81708480 802bad6c 000002b6 80e0b2e8 00000009 80f9a3c0 80e3d320 80ee4c20
[14400.550000]    80f9a78c 80079038 80362a38 80092fa8 00000000 00000000 802c9970 81aedd3c
[14400.550000]    81aedd3c 80079038 00000003 8008f378 00000000 00000000 00000005 801ad460
[14400.550000]    00aedd5c 80d26300 80d26500 80e0ff50 00000000 00000000 00000000 00000000
[14400.550000]    00000000 00000000 70687930 00000000 00000000 00000000 00000000 81aedce8
[14400.550000]    ...
[14400.590000] Call Trace:
[14400.590000] [<8006e278>] show_stack+0x48/0x70
[14400.600000] [<80076b74>] warn_slowpath_common+0x78/0xa8
[14400.600000] [<80076bbc>] warn_slowpath_null+0x18/0x24
[14400.610000] [<80e0b2e8>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
[14400.620000] [<80e10018>] ieee80211_ibss_leave+0xdc8/0x1480 [mac80211]
[14400.620000]
[14400.620000] ---[ end trace 4c1681128c589cd6 ]---
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device      'radio0'
        option disabled '0'
        option type     'mac80211'
        option path     'pci0000:00/0000:00:00.0'
        option hwmode   '11ng'
        option htmode   'HT20'
        option noscan   '0'
        option channel  'auto'
        option txpower  '20'
        list ht_capab   'SHORT-GI-20'
        list ht_capab   'SHORT-GI-40'
        list ht_capab   'TX-STBC'
        list ht_capab   'RX-STBC1'
        list ht_capab   'DSSS_CCK-40'

config wifi-iface
        option disabled '0'
        option device   'radio0'
        option mode     'sta'
        option network  'wan'
        option ssid     'remotessid'
        option encryption       'psk2'
        option key      'remotekey'

config wifi-iface
        option disabled '0'
        option device   'radio0'
        option mode     'ap'
        option network  'lan'
        option ssid     'myssid'
        option encryption       'psk-mixed'
        option key      'mykey'
        option wpa_group_rekey  '3600'
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'wlan0'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

comment:7 Changed 4 years ago by nbd

please test if this still happens in current trunk

comment:8 Changed 4 years ago by marco

I got one today on a WDS wireless repeater setup. I think it happened on both devices at the same time.

WDS AP only / TL-WDR4300 / r39841

[75889.150000] ------------[ cut here ]------------
[75889.160000] WARNING: at /home/marco/WDR4300/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2014-01-23.1/net/mac80211/util.c:2429 ieee80211_smps_is_restrictive+0x40/0xa8 [mac80211]()
[75889.180000] Modules linked in: ath9k ath9k_htc ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic pl2303 nf_nat_pptp nf_nat_ipv4 nf_nat_amanda nf_conntrack_pptp nf_conntrack_ipv4 nf_conntrack_amanda mac80211 ipt_MASQUERADE ftdi_sio cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_ipv4options xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY usbserial usblp ts_kmp ts_fsm ts_bm slhc nf_nat_tftp nf_nat_snmp_basic nf_nat_sip nf_nat_proto_gre nf_nat_irc nf_nat_h323 nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_tftp nf_conntrack_snmp nf_conntrack_sip nf_conntrack_proto_gre nf_conntrack_irc nf_conntrack_h323 nf_conntrack_ftp nf_conntrack_broadcast iptable_raw iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables crc_ccitt compat sg ledtrig_usbdev ledtrig_netdev ip6t_REJECT ip6t_rt ip6t_hbh ip6t_mh ip6t_ipv6header ip6t_frag ip6t_eui64 ip6t_ah ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables nf_conntrack_ipv6 nf_conntrack nf_defrag_ipv6 tun cifs nls_utf8 ipv6 sha256_generic md5 md4 hmac ecb des_generic arc4 crypto_blkcipher usb_storage leds_gpio ohci_hcd ledtrig_timer ledtrig_default_on ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 crc16 jbd2 mbcache usbcore nls_base usb_common crypto_hash
[75889.300000] CPU: 0 PID: 0 Comm: swapper Not tainted 3.10.32 #2
[75889.310000] Stack : 00000006 00000000 00000000 00000000 00000000 00000000 803c2ac6 00000032
[75889.310000] 803494f8 802f565c 803a2a38 8034927b 00000000 8693e934 86b58498 0000000c
[75889.310000] 00000001 80079068 00000003 80076aa8 00000000 00000000 802f6f88 80343a84
[75889.310000] 00343a84 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[75889.310000] 00000000 00000000 00000000 00000000 00000000 00000000 00000000 80343a10
[75889.310000] ...
[75889.350000] Call Trace:
[75889.350000] [<8006e2a8>] show_stack+0x48/0x70
[75889.350000] [<80076ba4>] warn_slowpath_common+0x78/0xa8
[75889.360000] [<80076bec>] warn_slowpath_null+0x18/0x24
[75889.360000] [<86fa9d34>] ieee80211_smps_is_restrictive+0x40/0xa8 [mac80211]
[75889.370000] [<86f85548>] ieee80211_sta_ps_deliver_wakeup+0x254/0x5c8 [mac80211]
[75889.380000] [<86f9c5dc>] ieee80211_sta_ps_transition+0x984/0x3650 [mac80211]
[75889.390000]
[75889.390000] ---[ end trace f1b1ad3a51c0bfd2 ]---

WDS client / repeater TP-LINK TL-WR703N v1 / r39717

[ 3486.610000] ------------[ cut here ]------------
[ 3486.610000] WARNING: at /home/marco/WDR4300/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2014-01-23.1/net/mac80211/agg-tx.c:699 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
[ 3486.630000] Modules linked in: ath9k ath9k_htc ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv4 mac80211 iptable_raw iptable_mangle iptable_filter ipt_REJECT ipt_MASQUERADE ip_tables cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT x_tables slhc nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_irc nf_conntrack_ftp nf_conntrack crc_ccitt compat ledtrig_netdev ipv6 arc4 crypto_blkcipher leds_gpio ledtrig_timer ledtrig_default_on ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common
[ 3486.690000] CPU: 0 PID: 8 Comm: kworker/u2:1 Not tainted 3.10.32 #1
[ 3486.690000] Workqueue: phy0 ieee80211_ibss_leave [mac80211]
[ 3486.700000] Stack : 81846580 802b6a3c 000002bb 80d8b538 00000009 80e74ac0 80dc8ec8 80e74c20
[ 3486.700000] 80fb078c 80079038 80362a38 80092fa8 00000000 00000000 802c5630 81849d3c
[ 3486.700000] 81849d3c 80079038 00000003 8008f378 00000000 00000000 00000000 801af24c
[ 3486.700000] 00849d5c 81b0f900 81b0fb00 80d901f0 00000000 00000000 00000000 00000000
[ 3486.700000] 00000000 00000000 70687930 00000000 00000000 00000000 00000000 81849ce8
[ 3486.700000] ...
[ 3486.740000] Call Trace:
[ 3486.740000] [<8006e278>] show_stack+0x48/0x70
[ 3486.740000] [<80076b74>] warn_slowpath_common+0x78/0xa8
[ 3486.750000] [<80076bbc>] warn_slowpath_null+0x18/0x24
[ 3486.750000] [<80d8b538>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
[ 3486.760000] [<80d902b8>] ieee80211_ibss_leave+0xe18/0x1528 [mac80211]
[ 3486.770000]
[ 3486.770000] ---[ end trace f56b6b50f02b2aca ]---

comment:9 Changed 4 years ago by duvi

Seems to be solved for me, thank you!

comment:10 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 4 years ago by duvi

  • Resolution fixed deleted
  • Status changed from closed to reopened

Same thing started happening again, same device and setup as described in comment:6
Using trunk r40588

[86761.080000] ------------[ cut here ]------------
[86761.080000] WARNING: at /mnt/sda/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2014-03-31/net/mac80211/agg-tx.c:694 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
[86761.110000] Modules linked in: ath9k ath9k_common iptable_nat ath9k_hw ath snd_usb_audio nf_nat_ipv4 nf_conntrack_ipv4 mac80211 iptable_raw iptable_mangle iptable_filter ipt_REJECT ipt_MASQUERADE ip_tables cp210x cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT x_tables usbserial ts_kmp ts_fsm ts_bm snd_usbmidi_lib nf_nat nf_defrag_ipv4 nf_conntrack crc_ccitt compat ledtrig_usbdev snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_page_alloc snd_timer snd_rawmidi snd_seq_device snd_hwdep snd soundcore nls_utf8 nls_iso8859_2 arc4 crypto_blkcipher ohci_hcd ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug usbcore nls_base usb_common
[86761.170000] CPU: 0 PID: 3563 Comm: kworker/u2:2 Tainted: G        W    3.10.36 #1
[86761.180000] Workqueue: phy0 ieee80211_ibss_leave [mac80211]
[86761.190000] Stack : 80862380 802ba050 80d8b2f8 000002b6 80dbccec 80dbd830 0000001e 80c78c18
[86761.190000]    80dbd8ec 80078f38 00000deb 800931e8 80f45ef8 80dbd830 802c8bb8 80f1bd34
[86761.190000]    80f1bd34 80078f38 00000003 8008f518 80dbccec 00000000 00000005 801ad0f0
[86761.190000]    00000000 00000000 00000000 00000000 00000000 00000000 70687930 00000000
[86761.190000]    00000000 00000000 00000000 00000000 80ca0b00 80ca0d00 80d8fcd8 80f1bce0
[86761.190000]    ...
[86761.230000] Call Trace:
[86761.230000] [<8006e200>] show_stack+0x48/0x70
[86761.230000] [<80076ab8>] warn_slowpath_common+0x78/0xa8
[86761.240000] [<80076b70>] warn_slowpath_null+0x18/0x24
[86761.240000] [<80d8b2f8>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
[86761.250000] [<80d8fdb4>] ieee80211_ibss_leave+0xb3c/0x145c [mac80211]
[86761.260000]
[86761.260000] ---[ end trace aff13279a520c3f4 ]---

comment:12 Changed 4 years ago by duvi

Still getting on r40694, now with a bit more in the log.

[ 4832.580000] ------------[ cut here ]------------
[ 4832.590000] WARNING: at /mnt/sda/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2014-03-31/net/mac80211/agg-tx.c:694 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
[ 4832.600000] Modules linked in: ath9k ath9k_common iptable_nat ath9k_hw ath snd_usb_audio nf_nat_ipv4 nf_conntrack_ipv4 mac80211 iptable_raw iptable_mangle iptable_filter ipt_REJECT ipt_MASQUERADE ip_tables cp210x cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT x_tables usbserial ts_kmp ts_fsm ts_bm snd_usbmidi_lib nf_nat nf_defrag_ipv4 nf_conntrack crc_ccitt compat ledtrig_usbdev snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_page_alloc snd_timer snd_rawmidi snd_seq_device snd_hwdep snd soundcore nls_utf8 nls_iso8859_2 arc4 crypto_blkcipher ohci_hcd ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug usbcore nls_base usb_common
[ 4832.670000] CPU: 0 PID: 1499 Comm: kworker/u2:1 Not tainted 3.10.36 #1
[ 4832.680000] Workqueue: phy0 ieee80211_ibss_leave [mac80211]
[ 4832.680000] Stack : 81538800 802ba050 80d8b308 000002b6 80dbcd5c 80dbd8a0 0000001e 80dfcc18
[ 4832.680000]    80dbd95c 80078f34 000005db 800931e4 80f385d8 80dbd8a0 802c8bb8 81849d34
[ 4832.680000]    81849d34 80078f34 00000003 8008f514 80dbcd5c 00000000 00000005 801acfd0
[ 4832.680000]    00000000 00000000 00000000 00000000 00000000 00000000 70687930 00000000
[ 4832.680000]    00000000 00000000 00000000 00000000 80cbab00 80cbad00 80d8fd08 81849ce0
[ 4832.680000]    ...
[ 4832.720000] Call Trace:
[ 4832.730000] [<8006e200>] show_stack+0x48/0x70
[ 4832.730000] [<80076ab0>] warn_slowpath_common+0x78/0xa8
[ 4832.740000] [<80076b68>] warn_slowpath_null+0x18/0x24
[ 4832.740000] [<80d8b308>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
[ 4832.750000] [<80d8fde4>] ieee80211_ibss_leave+0xb3c/0x145c [mac80211]
[ 4832.750000] [<8009d390>] dequeue_task_fair+0x44/0x12c
[ 4832.760000] [<80067f08>] __schedule+0x390/0x488
[ 4832.760000] [<8008e07c>] worker_thread+0x234/0x388
[ 4832.770000] [<80092e78>] kthread+0xb0/0xb8
[ 4832.770000] [<80060878>] ret_from_kernel_thread+0x14/0x1c
[ 4832.780000]
[ 4832.780000] ---[ end trace a4e9b54adaa661ab ]---

comment:13 Changed 4 years ago by duvi

Upgraded to r40803, still the same.
After a couple of hours (3:30 after the upgrade this time), no more packets pass through the connection, although the connection stays up, and other devices can still connect. On the device I need to disable / enable the wireles interface to get it working again, and this also triggers the kernel warning above.

One thing I've noticed though: while streaming and playing music on this router (which makes it transmit / receive continously), my computer has never dropped the connection.

comment:14 Changed 4 years ago by duvi

Forget the second part, it has nothing to with the router's uplink interface continously sending / receiving; my laptop's connection still hung even though the stream was on.

comment:15 Changed 4 years ago by nbd

please try r41828

comment:16 Changed 3 years ago by duvi

I just had time to test with r42018, but it's still the same.
Although I figured out, that the hang only occurs if the main router has a special wireless config set.

Let me explain.

The devices setup is:
Main WLAN router (stock fw ASUS RT-N10E) <---> OpenWrt repeater (r42018 TL-MR3220) <---> wireless client

So my client laptops are connected to my OpenWrt box, that has a STA wifi interface connected to an ASUS RT-N10E. No wds, my Openwrt box simply creates a different subnet for the LAN side.

Openwrt repeater config:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'wlan0'
        option proto 'dhcp'

root@OpenWrt:~# cat /etc/config/wireless
config wifi-device      'radio0'
        option disabled '0'
        option type     'mac80211'
        option path     'pci0000:00/0000:00:00.0'
        option hwmode   '11g'
        option htmode   'HT20'
        option noscan   '0'
        option channel  'auto'
        option txpower  '20'
        option country  'HU'

config wifi-iface
        option disabled '0'
        option device   'radio0'
        option mode     'sta'
        option network  'wan'
        option ssid     'uplinkssid'
        option encryption       'psk2'
        option key      'uplinksecretpassword'

config wifi-iface
        option disabled '0'
        option device   'radio0'
        option mode     'ap'
        option network  'lan'
        option ssid     'myssid'
        option encryption       'psk-mixed'
        option key      'mysecretpassword'
        option wpa_group_rekey  '3600'

The wireless configuration of the main ASUS router is attached as a screenshot.
The setting on the ASUS router the "triggers" the hangs on my repeater is the Channel bandwidth setting. If it is set to "20/40 MHz", the errors reported above start happening on my repeater, and my clients loose their connection from time to time (this is explained in my previous posts).
However, if I set the channel bw on the main ASUS router to either fixed 20 MHz or fixed 40 MHz, I see no errors in the log, no connection drops, no hangs of my laptops.

Can this info help to solve the problem?

Thanks!

Changed 3 years ago by duvi

comment:17 Changed 3 years ago by nbd

please try current trunk

comment:18 Changed 3 years ago by duvi

Tried trunk r43087, but it's still the same.

Laptop in use drops the connection after a while, but the SSID stays up, and other devices are still able to connect.

Connection also stays OK between repeater and main router.

comment:19 Changed 3 years ago by duvi

Log is a bit less then before:

Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.210000] ------------[ cut here ]------------
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.220000] WARNING: at /mnt/sda/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2014-10-08/net/mac80211/agg-tx.c:698 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.240000] Modules linked in: ath9k ath9k_common iptable_nat ath9k_hw ath snd_usb_audio nf_nat_ipv4 nf_conntrack_ipv4 mac80211 iptable_raw iptable_mangle iptable_filter ipt_REJECT ipt_MASQUERADE ip_tables cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_id xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT x_tables snd_usbmidi_lib nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_irc nf_conntrack_ftp nf_conntracMon Oct 27 20:00:44 2014 kern.warn kernel: [10441.300000] CPU: 0 PID: 2045 Comm: kworker/u2:1 Not tainted 3.10.58 #1
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.310000] Workqueue: phy0 ieee80211_ibss_leave [mac80211]
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.310000] Stack : 80dde400 802d0814 80d0b84c 000002ba 80d40c48 80d41764 0000001e 80ca4e58
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.310000]         80d41848 80278068 000007fd 801e0acc 81b22370 80d41764 802dde20 816e7d24
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.310000]         816e7d24 80278068 00000003 801e05f0 80d40c48 00000000 00000005 80210dd0
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.310000]         00000000 00000000 00000000 00000000 00000000 00000000 70687930 00000000
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.310000]         00000000 00000000 00000000 00000000 80ca1000 80ca1200 80d105b4 816e7cd0
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.310000]         ...
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.350000] Call Trace:
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.350000] [<80220e68>] show_stack+0x48/0x70
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.360000] [<80287648>] warn_slowpath_common+0x78/0xa8
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.360000] [<80287700>] warn_slowpath_null+0x18/0x24
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.370000] [<80d0b84c>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.370000] [<80d10690>] ieee80211_ibss_leave+0xb7c/0x153c [mac80211]
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.380000]
Mon Oct 27 20:00:44 2014 kern.warn kernel: [10441.380000] ---[ end trace f1a3675bfca8f6b0 ]---

comment:20 Changed 3 years ago by dpape

Any news on this? I'm having exactly the same problem in AP+STA mode.

[ 3496.570000] ------------[ cut here ]------------
[ 3496.580000] WARNING: at /home/dpape/breakoutopenwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2014-05-22/net/mac80211/agg-tx.c:699 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
[ 3496.700000] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv4 mac80211 ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_irc nf_conntrack_ftp iptable_raw iptable_mangle iptable_filter ipt_REJECT ip_tables crc_ccitt compat ledtrig_usbdev ip6t_REJECT ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables nf_conntrack_ipv6 nf_conntrack nf_defrag_ipv6 ipv6 arc4 crypto_blkcipher ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common
[ 3497.070000] CPU: 0 PID: 2331 Comm: kworker/u2:0 Not tainted 3.10.36 #1
[ 3497.110000] Workqueue: phy0 ieee80211_ibss_leave [mac80211]
[ 3497.140000] Stack : 83b6b880 802bb228 8318b8c8 000002bb 831c9d8c 831ca8ec 00000021 831d8c18
          831ca9d4 80078f34 0000091b 800931e4 8296c1a8 831ca8ec 802c9d98 833a7d34
          833a7d34 80078f34 00000003 8008f514 831c9d8c 00000000 00000000 801b014c
          00000000 00000000 00000000 00000000 00000000 00000000 70687930 00000000
          00000000 00000000 00000000 00000000 830ec100 830ec200 8319044c 833a7ce0
          ...
[ 3497.350000] Call Trace:
[ 3497.370000] [<8006e200>] show_stack+0x48/0x70
[ 3497.390000] [<80076ab0>] warn_slowpath_common+0x78/0xa8
[ 3497.420000] [<80076b68>] warn_slowpath_null+0x18/0x24
[ 3497.450000] [<8318b8c8>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
[ 3497.490000] [<83190528>] ieee80211_ibss_leave+0xbd0/0x153c [mac80211]
[ 3497.530000]
[ 3497.540000] ---[ end trace 2b952ee532aca689 ]---

The problem randomly occurs and I have to restart my radio for the PC that lost connection could generate traffic again.

Last edited 3 years ago by dpape (previous) (diff)

comment:21 Changed 2 years ago by uysiquebien

[118623.490000] ------------[ cut here ]------------
[118623.500000] WARNING: CPU: 0 PID: 10918 at /home/vagrant/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2015-03-09/net/mac80211/agg-tx.c:741 ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]()
[118623.520000] Modules linked in: imq ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pptp pppox ppp_mppe ppp_generic nf_nat_ipv4 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE ebtable_nat ebtable_filter ebtable_broute cfg80211 xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_recent xt_quota xt_pkttype xt_physdev xt_owner xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_iprange xt_id xt_hl xt_helper xt_ecn xt_dscp xt_conntr
[118623.640000] CPU: 0 PID: 10918 Comm: kworker/u2:2 Tainted: G        W      3.18.23 #1
[118623.650000] Workqueue: phy0 ieee80211_ibss_leave [mac80211]
[118623.660000] Stack : 00000001 00000000 80f41580 80308100 80e51220 80e0c548 000002e5 80e51d54
[118623.660000]        81804a10 81804a00 80e51e10 800a35cc 00002aa6 800961f4 81b3da80 80e51d54
[118623.660000]        80318d30 80d57d1c 80d57d1c 800a35cc 00000003 80093be4 000002e5 00000000
[118623.660000]        00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[118623.660000]        70687930 00000000 00000000 00000000 00000000 00000000 80db7500 80db7600
[118623.660000]        ...
[118623.690000] Call Trace:
[118623.700000] [<80070fe0>] show_stack+0x50/0x84
[118623.700000] [<800804c4>] warn_slowpath_common+0x84/0xb4
[118623.710000] [<8008057c>] warn_slowpath_null+0x18/0x24
[118623.710000] [<80e0c548>] ieee80211_start_tx_ba_cb+0xbc/0x12c [mac80211]
[118623.720000] [<80e11460>] ieee80211_ibss_leave+0xc00/0x165c [mac80211]
[118623.720000]
[118623.730000] ---[ end trace a4c2004e1d569de8 ]---

This using AP+STA. When it happens, the device remains connected but no more traffic is ever generated so I have to manually reconnect it.

Last edited 2 years ago by uysiquebien (previous) (diff)

comment:22 Changed 2 years ago by uysiquebien

I must add to my last comment that it only happens with HT20, HT40+ or HT40-, never with NOHT. (Or at least, not thus far).

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.