Modify

Opened 5 years ago

Last modified 4 years ago

#13505 new defect

pptp connection unstable on AA final

Reported by: angelmanjk@… Owned by: developers
Priority: high Milestone: Attitude Adjustment 12.09.1
Component: base system Version: Attitude Adjustment 12.09
Keywords: Cc:

Description

Upgraded from AA RC1 to AA final and now my pptp connection is very unusable.
It goes up and down the whole time.
With RC1 its rock-stable for weeks.
Log-excerpt:

May 11 19:23:53 rectangle daemon.info dnsmasq[3877]: using local addresses only for domain lan
May 11 19:24:47 rectangle daemon.warn pppd[4594]: read error: Connection reset by peer
May 11 19:24:47 rectangle daemon.warn pppd[4594]: write error: Broken pipe
May 11 19:24:47 rectangle daemon.err pppd[4594]: Fatal signal 11
May 11 19:24:47 rectangle daemon.info pppd[4594]: Exit.
May 11 19:25:09 rectangle daemon.info pppd[950]: No response to 10 echo-requests
May 11 19:25:09 rectangle daemon.notice pppd[950]: Serial link appears to be disconnected.
May 11 19:25:09 rectangle daemon.info pppd[950]: Connect time 1.4 minutes.
May 11 19:25:09 rectangle daemon.info pppd[950]: Sent 29059 bytes, received 33175 bytes.
May 11 19:25:09 rectangle daemon.notice netifd: Interface 'wan' has lost the connection
May 11 19:25:10 rectangle user.info firewall: removing wan (pptp-wan) from zone wan

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by acan.den@…

I can confirm this too. "Fatal signal 11" error pops up quiet often. Can't see any pattern, though.

comment:2 Changed 5 years ago by andreas.grill@…

Can confirm this too.

comment:3 Changed 5 years ago by djbruno@…

I can confirm this too.
It seems to me that netifd is spawning 2 pppd processes.
The first one connects, while the second one will just timeout trying to connect.
When that happens, the connection dies for the first process.

Can anyone check if that's happening for you as well? Check the pids, and do a "ps w" right after connecting.

comment:4 Changed 4 years ago by plasticassius

I struggled with this for quite a while until I realized that switching back to RC1 makes my setup stable. I would of course prefer to use the release.

I am using pptp to VPN to Microsoft servers. I've also found that I can't pptp pass through from a Linux box (openwrt or unbuntu) through the openwrt gateway; but, the gateway itself can pptp and then route through the vpn. I can however pptp through the openwrt gateway from a Windows box (versions 2000 and 7).

comment:5 follow-up: Changed 4 years ago by iamsoaw

I fixed no echo responses via this:

config rule
option name Allow-PPTP-Control
option src wan
option proto tcp
option src_host x.x.x.x
option src_port 1723
option target ACCEPT

Where x.x.x.x — address of VPN server.

comment:6 in reply to: ↑ 5 Changed 4 years ago by piepmatz

Replying to iamsoaw:

I fixed no echo responses via this:

config rule
option name Allow-PPTP-Control
option src wan
option proto tcp
option src_host x.x.x.x
option src_port 1723
option target ACCEPT

Where x.x.x.x — address of VPN server.

Thank you!!
I changed

option src_host x.x.x.x

to

option src_ip x.x.x.x

and now works for me as well. Just in case someone wonders where put this rule: /etc/config/firewall

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.