Modify

Opened 5 years ago

Closed 2 years ago

#13487 closed defect (fixed)

thread safe issue in libopenssl

Reported by: coolspace Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: openssl Cc:

Description

Hello, I'm using OpenWrt Barrier Breaker r36570 and installed python, python-openssl and some other related packages by opkg from the official database.

When using some python programs, I found the process exits randomly and leaves messages like
"python: md_rand.c: 325: ssleay_rand_add: Assertion `md_c[1] == md_count[1]' failed."

When checked over the internet, it seems this was caused by the thread safe issue of libopenssl package. In openwrt package, the libopenssl was build without thread safe. So cause these problems in multi thread usage.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:2 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r39048

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.