Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#13480 closed defect (duplicate)

SubversionException: 24 - Can't open file '/var/svn/openwrt/db/revs/28499': Too many open files

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Come riprodurre il problema

Effettuando una operazione "GET" su /changeset/36577/trunk, Trac ha
generato un errore interno.

(per favore aggiungi ulteriori dettagli qui di seguito)

Parametri della request:

{'format': u'zip', 'new': u'36577', 'new_path': u'/trunk', 'old_path': u'/'}

User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.63 Safari/537.31

Informazioni sul sistema

Informazioni di sistema non disponibili

Componenti aggiuntivi abilitati

Informazioni sui prodotti aggiuntivi non disponibili

Traceback di Python

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 350, in process_request
    self._render_zip(req, filename, repos, data)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 769, in _render_zip
    old_path=data['old_path'], old_rev=data['old_rev']):
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/cache.py", line 400, in get_changes
  File "/usr/lib/python2.7/dist-packages/tracopt/versioncontrol/svn/svn_fs.py", line 647, in get_changes
    key=key))
  File "/usr/lib/python2.7/dist-packages/tracopt/versioncontrol/svn/svn_fs.py", line 690, in _get_changes
    subpool())
  File "/usr/lib/python2.7/dist-packages/libsvn/repos.py", line 454, in svn_repos_dir_delta
SubversionException: 24 - Can't open file '/var/svn/openwrt/db/revs/28499': Too many open files

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by hauke

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #13300

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.